Introduction to Creo Elements/Pro

Exercise and Reference Guide
Copyright © 2009 Parametric Technology Corporation. All Rights Reserved.

Copyright for PTC software products is with Parametric Technology Corporation, its subsidiary companies (collectively “PTC”), and their respective licensors. This software is provided under written license agreement, contains valuable trade secrets and proprietary information, and is protected by the copyright laws of the United States and other countries. It may not be copied or distributed in any form or medium, disclosed to third parties, or used in any manner not provided for in the software licenses agreement except with written prior approval from PTC.

UNAUTHORIZED USE OF SOFTWARE OR ITS DOCUMENTATION CAN RESULT IN CIVIL DAMAGES AND CRIMINAL PROSECUTION.

User and training guides and related documentation from PTC is subject to the copyright laws of the United States and other countries and is provided under a license agreement that restricts copying, disclosure, and use of such documentation. PTC hereby grants to the licensed software user the right to make copies in printed form of this documentation if provided on software media, but only for internal/personal use and in accordance with the license agreement under which the applicable software is licensed. Any copy made shall include the PTC copyright notice and any other proprietary notice provided by PTC. Training materials may not be copied without the express written consent of PTC. This documentation may not be disclosed, transferred, modified, or reduced to any form, including electronic media, or transmitted or made publicly available by any means without the prior written consent of PTC and no authorization is granted to make copies for such purposes.

Information described herein is furnished for general information only, is subject to change without notice, and should not be construed as a warranty or commitment by PTC. PTC assumes no responsibility or liability for any errors or inaccuracies that may appear in this document.

For Important Copyright, Trademark, Patent and Licensing Information see backside of this guide.
About the PTC Academic Program

3D CAD, Collaboration and Calculation Management Software for High Schools, Colleges & Universities

The PTC Education Program began in 1999, as a way to help teachers and professors bridge the gap between education and industry. We know that technology and innovation are keys to success in the global marketplace; and that companies look for students with the most up-to-date skills. For that reason, PTC is actively working with industry, secondary school teachers and university professors to develop a complete education solution - from the secondary school all the way to the college/university level. PTC is committed to building a new generation of “technological thinkers” and helping students gain access to technology education programs and innovative skills for the future.

Today, more than 35,000 schools and ten million students are using PTC solutions. In addition, our software has been incorporated in over 1800 universities globally, including 50 of the top mechanical engineering universities in the United States. The number of schools and universities continues to grow every year. We’re proud to be part of a technological literacy movement that seeks to help bridge the academic gap and inspire all students to design the products of the future, because the designers of the future are our future too.

With PTC’s School & University Program, students can:

• Build technological literacy
• Learn to work collaboratively in teams
• Develop communication, interpersonal and social skills
• Improve critical thinking and strategic thinking skills
• Increase confidence
• Experience project-based problem solving
• Become familiar with advanced design processes
• Prepare for real-world careers in technology
General PTC Academic Program Questions
• Email: PTCEducation@ptc.com

Creo Elements/Pro for Schools
• Email: schools@ptc.com
• Web: www.ptcschools.com

DOD STARBASE
• Email: starbase@ptc.com
• STARBASE Support Pages
  – www.starbasedod.org
  – www.ptcmissioncontrol.com

FIRST Robotics
• Email: firstsupport@ptc.com
• FIRST Support Pages
  – www.ptc.com/go/first
  – www.ptc.com/go/firstregistration
  – www.ptc.com/go/firstgettingstarted

RWDC - Real World Design Challenge
• Email: rwdc_support@ptc.com
• FIRST Support Pages
  – www.realworlddesignchallenge.org
  – www.ptc.com/go/rwdc/rwdcgettingstarted

Scalextric4Schools
• UK: www.scalextric4schools.org
• US: www.scalextric4schools.us
Training Agenda

Day 1
Module 01  — The Interface and Basic Concepts
Module 02  — Basic Part Modeling

Day 2
Module 03  — Basic Drawing Creation
Module 04  — Basic Assembly Modeling
Module 05  — Advanced Modeling and Design
Module 06  — Photorealistic Rendering
# Table of Contents

## Introduction to Creo Elements/Pro

**The Interface and Basic Concepts** ............................... 1-1
  - Downloading Model Files for this Course ..................... 1-2
  - Understanding Solid Modeling Concepts ........................ 1-3
  - Understanding Feature-Based Concepts ........................ 1-4
  - Understanding Parametric Concepts .................................. 1-5
  - Understanding Assembly Concepts .................................. 1-7
  - Understanding Associative Concepts .............................. 1-9
  - Understanding Model-Centric Concepts ......................... 1-11
  - Understanding the Creo Elements/Pro Interface ............ 1-13
  - Working Directories and Saving your Work .................... 1-16
  - Using Spin, Pan, Zoom and Named Views ....................... 1-18
  - Understanding Basic Display Options .............................. 1-23
  - Selecting Items using Direct Selection .......................... 1-28
  - Selecting Items using Query Selection ............................ 1-30
  - Understanding Selection Filters .................................. 1-36
  - Using the Smart Selection Filter .................................. 1-37
  - Managing Files in Creo Elements/Pro ............................ 1-42
  - Understanding the Basics of Sketcher ............................ 1-50

**Basic Part Modeling** ........................................ 2-1
  - Basic Part Modeling ........................................ 2-2

**Basic Drawing Creation** ..................................... 3-1
  - Basic Drawing Creation ........................................ 3-2

**Basic Assembly Modeling** .................................... 4-1
  - Basic Assembly Modeling ......................................... 4-2

**Advanced Modeling and Design** ............................... 5-1
  - Advanced Modeling and Design ................................... 5-2

**Photorealistic Rendering** .................................... 6-1
  - Photorealistic Rendering ......................................... 6-2

**Basic Part Modeling - References** .......................... 7-1
  - Reviewing Sketcher Theory ....................................... 7-2
  - Specifying the Sketch Setup ..................................... 7-3
  - Creating Sketches ('Sketch' Feature) ............................ 7-5
  - Creating Internal Sketches ...................................... 7-7
  - Sketching Lines .................................................. 7-9
  - Sketching Circles ............................................... 7-10
  - Sketching Centerlines ........................................... 7-11
  - Dimensioning Entities within Sketcher ........................ 7-12
Modifying Dimensions within Sketcher ............................................. 7-14
Creating Solid Extrude Features .................................................... 7-15
Common Dashboard Options: Extrude Depth ................................. 7-16
Common Dashboard Options: Feature Direction ......................... 7-18
Creating Coaxial Holes ........................................................... 7-20
Creating Linear Holes ............................................................ 7-21
Exploring Hole Profile Options .................................................. 7-23
Creating Datum Features Theory ............................................... 7-25

Basic Drawing Creation - References ........................................... 8-1
Understanding Drawing Concepts and Theory .............................. 8-2
Creating New Drawings using Drawing Templates ....................... 8-3
Creating New Drawings and Applying Formats ............................. 8-5
Understanding Basic 2-D Orientations ....................................... 8-7
Understanding the Drawing Ribbon User Interface .................... 8-9
Creating and Orienting General Views ....................................... 8-11
Creating Projection Views ......................................................... 8-12
Creating Cross-Section Views .................................................... 8-13
Modifying Drawing Views .......................................................... 8-15
Utilizing the Drawing Tree .......................................................... 8-17
Understanding Annotation Concepts and Types ......................... 8-18
Showing, Erasing, and Deleting Annotations ............................ 8-19
Cleaning Up Dimensions ............................................................. 8-21
Manipulating Dimensions ........................................................... 8-23
Creating Driven Dimensions ....................................................... 8-25
Inserting Notes ............................................................................ 8-27
Publishing Drawings ..................................................................... 8-29

Basic Assembly Modeling - References ......................................... 9-1
Understanding Constraint Theory .................................................. 9-2
Assembling Components using the Default Constraint ............... 9-4
Orienting the Component being Assembled ................................. 9-5
Constraining Components using Insert ....................................... 9-7
Constraining Components using Mate Coincident ..................... 9-8
Constraining Components using Align Coincident ..................... 9-10
Utilizing the Accessory Window .................................................. 9-12

Advanced Modeling and Design - References ............................... 10-1
Understanding Design Intent ......................................................... 10-2
Utilizing Constraints ................................................................. 10-4
Sketching with On-the-Fly Constraints ....................................... 10-6
Sketching Arcs ............................................................................... 10-8
Using Geometry Tools within Sketcher ....................................... 10-9
Utilizing Sketch References ......................................................... 10-11
Using Entity from Edge within Sketcher ..................... 10-13
Creating Solid Revolve Features ............................... 10-15
Creating Draft Features ........................................ 10-16
Creating Rounds Theory ....................................... 10-18
Axis Patterning in the First Direction ......................... 10-19
Viewing and Editing Model Properties ........................ 10-21
Analyzing Mass Properties ..................................... 10-23
Measuring Models ............................................... 10-25
Measuring Global Interference ................................. 10-27
Module 1

The Interface and Basic Concepts

Module Overview
In this module, you will learn about basic concepts and benefits of solid modeling using Creo Elements/Pro.

This module also introduces you to the main user interface and defines each area and how you will use it. You will gain an understanding of basic skills including setting the working directory and saving and opening files. You will learn basic Creo Elements/Pro display, orientation, and selection options.

Finally in this module, you will also learn the basics of using the sketcher and how to create a simple part model.

Objectives
After completing this module, you will be able to:
• Understand solid modeling concepts.
• Understand feature-based concepts.
• Understand parametric concepts.
• Understand assembly Concepts
• Understand associative concepts.
• Understand model-centric concepts.
• Understand Creo Elements/Pro’s main interface.
• Use Working Directories and Save your Work.
• Use spin, pan, zoom, and predefined named views to orient models.
• Understand basic display options including model display and datum display.
• Select models, features, and model geometry using your mouse.
• Understand the basics of sketcher and sketcher orientation.
Downloading Model Files for this Course

Before beginning this course, download and extract the Creo Elements/Pro model files that you will be using.

Download and Extract the Model Files:

• Download Intro_Creo_ElementsPro.zip.
• Move Intro_Creo_ElementsPro.zip to your Documents folder.
• Extract (unzip) the zip to create the folder Intro_Creo_ElementsPro.

The models used to complete this course are packaged in a zip file named Intro_Creo_ElementsPro.zip. Before beginning the exercises, you must download this file and extract its contents.

2. If necessary, move the downloaded Intro_Creo_ElementsPro.zip file to your Documents folder (this folder may be named My Documents on some computers).
3. Extract (unzip) the Intro_Creo_ElementsPro.zip file. This will create a folder named Intro_Creo_ElementsPro. You will use the models in this folder as you work through the course.
Understanding Solid Modeling Concepts

Creo Elements/Pro enables you to create solid representations of your part and assembly designs.

Solid Models:

- Are realistic visual representation of designs.
- Contain properties such as mass, volume, and center of gravity.
- Can be used to check for interferences in an assembly.

The models contain material properties such as mass, volume, center of gravity, and surface area. As features are added or removed from the model, these properties update. For example, if you add a hole to a model, then the mass of the model decreases.

In addition, solid models enable tolerance analysis and clearance/interference checking when placed into assemblies.
Understanding Feature-Based Concepts

Creo Elements/Pro is a feature-based product development tool.

With Feature-Based Modeling:

• You build one simple feature at a time.
• Each new feature can reference previous features.

Wheel Features

Understanding Feature-Based Concepts

Creo Elements/Pro is a feature-based product development tool. The models are constructed using a series of easy to understand features rather than confusing mathematical shapes and entities.

The geometric definition of a model is defined by the type of features used and by the order in which each feature is placed. Each feature builds upon the previous feature and can reference any of the preceding features; this enables design intent to be built into the model.

Individually, each feature is typically simple but as they are added together they form complex parts and assemblies.

In this example, we have a wheel showing the first six stages of its creation:

• First, an extrusion is created, which forms the initial shape and size of the model.
• An additional extrusion is created to add material to the middle of the model.
• A third extrusion is created to remove material from the model.
• A fourth extrusion is created to add a hub inside the model.
• A coaxial hole is created on the previous extrusion.
• A chamfer is created on the edge of the hole.
Understanding Parametric Concepts

The parametric nature and feature-to-feature relationships in Creo Elements/Pro enable you to easily capture design intent and make design changes.

**Parametric:**
- Model geometry is defined by features.
- Features are defined and by parameters, references and dimensions.
- When you modify dimension values, relevant geometry is automatically updated.

**Parent/Child Relationships:**
- Features referenced during creation become parents.
- If parent features change, child features accordingly and predictively change as well.

Creo Elements/Pro models are value driven, using dimensions and parameters to define the size and location of features within the model. If you change the value of a feature dimension, that feature will update according to the change. The change then automatically propagates through to related features in the model, updating the entire part.

**Parent/Child Relationships**

Relationships between features in Creo Elements/Pro provide a powerful tool for capturing design intent. During the modeling process, design intent is added as one feature is created with reference to another.

When creating a new feature, any feature referenced during its creation becomes a parent of the new feature. The new feature referencing the parent is referred to as a child of the parent. If the parent feature is updated, any children of the parent update accordingly. These relationships are referred to as parent/child relationships.

This example shows a piston model intersected with a hole feature. In the middle figure, the piston height is modified from 18.5 to 25. Notice that the hole moves upward as the piston height increases. The design intent of the piston is to have the hole located a specified distance from the top of the piston. The hole will maintain that distance no matter how tall the piston
becomes. This intent was added by dimensioning the hole to the top surface of the piston.

Alternatively, if the intent of the design is to have the hole located a specified distance from the bottom of the piston, the hole would be dimensioned from the bottom surface of the piston, yielding a different result when the height of the piston is modified.

The right most figure shows modifications made to the location and diameter of the hole.

**Best Practices**

When creating features in your model, try to reference features and geometry that are robust, will likely not be deleted, and provide the desired design intent. While this is not always possible, striving to do so will help you build robust, easy to modify models.
Understanding Assembly Concepts

An assembly is a collection of parts and other sub-assemblies that you bring together using constraints.

- Create assembly models from standardized templates.
- Capture assembly design intent using constraints.
- Create assembly constraints.

An Assembly Model that is Comprised of Parts

Understanding Assembly Theory

There are multiple methods to assemble components using Creo Elements/Pro. Assembling components with constraints is one of the primary methods used to create Creo Elements/Pro assemblies.

Like part models, all new assembly models share several characteristics in common. By creating your assembly models from standardized templates, you can save time by not repeatedly defining company standard information. This standard template enables all engineers to have a consistent starting point. After you create and name the new assembly, you can begin adding parts to the assembly. Similar to part models having design intent, assemblies also contain design intent. Assembly design intent is based upon which component is assembled first, and the constraints that you use during the assembly process. Design intent is important because it means that your assembly updates in a predictable manner when edited and regenerated.

All characteristics that hold true for assemblies also hold true for sub-assemblies. In fact, a sub-assembly is nothing more than an assembly that is assembled into another assembly.

Creo Elements/Pro has several types of constraints, such as Mate, Align, and Insert. Use of these constraints is made easier by using the Automatic option, which enables Creo Elements/Pro to automatically determine the constraint type based upon the orientation and position of the component and the references you select.

Every assembled component has a Placement node in the model tree that can be expanded to view the constraints used in that component's placement.
Assembling with component interfaces is a second method when assembling components. This method is especially useful when assembling common components because it can significantly cut the number of selections that you make when constraining a component. By using component interfaces, you save the referenced interfaces on the common part. Then, when you place the common part, you only need to select the assembly references.
Understanding Associative Concepts

Creo Elements/Pro is a bi-directionally associative product development tool.

Understanding Associative Concepts

Bi-directional associativity means that all changes made to an object in any mode of Creo Elements/Pro are automatically reflected in every related mode.

For example, a change made in a drawing is reflected in the part being documented in the drawing. That same change is also reflected in every assembly using that part model.

It is important to understand that the associativity between different modes is possible because the part shown in a drawing is not copied into the drawing, but rather associatively linked to the drawing. Likewise, an assembly is not a large file containing copies of every part in the assembly, but rather a file containing associative links to every model used in the assembly.

Best Practices

Because drawing and assembly files have associative links to the models contained in them, these objects cannot be opened without the models they contain being present.

In other words, you cannot send your colleague only a drawing file to open, he or she must have the drawing file along with any model referenced in the
drawing. For an assembly, he or she must have the assembly file and all models used in the assembly.

The best method for acquiring all files required for a drawing or assembly is to use the Backup function. With the required top-level drawing or assembly open, click **File > Backup** and back the files up to a new folder. This will place all the files required to open that top-level drawing or assembly into the new folder.
Understanding Model-Centric Concepts

In Creo Elements/Pro, the model is the center of all downstream deliverables such as drawings, assemblies, molds, analysis, and manufacturing.

Model-Centric

• Assemblies reference the models being assembled.
• The drawing references the model being documented.
• The Finite Element Mesh model references the model being analyzed.
• The mold tool references the model being molded.

Examples of downstream deliverables are:

• Slot car assemblies the wheel is used in, almost every car has wheels.
• The drawing used to document the wheel design, each view is generated from the wheel part.
• The mold tool uses the wheel part to define the geometry of the mold cavity.
A Finite Element Mesh (FEM) model is created from the wheel part. Engineers use this FEM model to determine the strength of the part, the flow properties of the modeled part, and so on.

The benefit of using a model-centric development tool is that a change made to the design model will automatically update all related downstream deliverables.
Understanding the Creo Elements/Pro Interface

The Main Interface includes the following areas:

- Graphics Area
- Main Menu
- Toolbars
- Dashboard
- Message Window
- Dialog Boxes
- Menu Manager
- Drawing Ribbon

Main Interface Theory

There are many different areas of the Creo Elements/Pro user interface that you use when creating models. The areas that display depend upon the function being performed. Areas of the main interface include:

- Graphics Area — The working area of Creo Elements/Pro in which you view, create, and modify Creo Elements/Pro models such as parts, assemblies, and drawings.
• Main Menu — Located at the top of the interface, the main menu contains standard options such as **File**, **Edit**, and **View**.

• Toolbars — Toolbars contain icons for commonly used tools and functions.

• Message Area — The message area provides you with prompts, feedback, and messages from Creo Elements/Pro.

• Dashboard — Locked at the top of the user interface, the Dashboard appears when you create or edit the definition of a feature.
  • The Dashboard provides you with controls, inputs, status, and guidance for carrying out a task, such as creating or editing a feature. Changes are immediately visible on the screen.
  • Various dashboard tabs are available with additional feature options.
  • Dashboard icons on the left include feature controls while the Pause, Preview, Create Feature, and Cancel Feature options are on the right.

• Dialog Boxes — Are content-sensitive windows that appear, displaying and prompting you for information.
• Menu Manager — A cascading menu that appears on the far right during the use of certain functions and modes within Creo Elements/Pro. You work from top to bottom in this menu; however, clicking “Done” is done from bottom to top. Bold menu options will be automatically selected if the middle mouse button is clicked.

• Drawing Ribbon — A context-sensitive menu across the top of the interface that appears when working on drawings. The drawing ribbon arranges commands into logical tasks through tabs and groups.
Working Directories and Saving your Work

The Working Directory is the location for opening files from and saving new files to.

Setting your Working Directory:

- Creo Elements/Pro is started in a default working directory.
- A working directory is the folder you open files from and save files to.
- The working directory is set per session, it is not saved when you exit Creo Elements/Pro.

Open Files - The File Open dialog box looks to the working directory.

Save Files - Files are saved to the folder they were opened from, this is not always the working directory.

Working Directory Theory

The working directory is the designated location for opening and saving files. The default working directory is the “Start in” location defined in the Creo Elements/Pro start icon, typically the “My Documents” folder.

If you are not using PTC’s Windchill PDMLink to manage your Creo Elements/Pro data, it is best practice to organized your work by creating a folder for each project you are working on. Each time you start Creo Elements/Pro, you should set the working directory to the folder you plan to work in. In this course you will be instructed to set your working directory to the location of the module and exercise folder.

There are three methods to set your working directory, use the method you are most comfortable with:

- From the File menu - Click File > Set Working Directory and browse to and select the directory that is to be the new working directory. Click OK. This the easiest and most straight forward method.
- From the Folder Tree or Browser - Right-click the folder that is to be the new working directory and select Set Working Directory.
• From the File Open dialog box - Right-click the folder that is to be the new working directory and select Set Working Directory.

You can browse directly to the working directory at any time by selecting the Working Directory common folder from the Navigator or File Open dialog box.

Opening Files

After you have set your working directory, you will see the files in that folder each time you click Open in Creo Elements/Pro.

You can use any of the following methods to open a file:

• Click File > Open from the main menu or Open from the main toolbar and the File Open dialog box appears. Browse to the file, select it, and either double-click it or click Open.
• Browse to the desired folder using the Navigator (either with Common Folders or through the Folder Tree) to display its contents in the browser. Then, you can either double-click the file in the file list, or right-click the file in the file list and select Open.
• You can also drag the file from the file list onto the graphics area.

The File Open dialog box is the equivalent of the Navigator and Browser combination in the main interface.

Saving Files

By default, files are saved to the folder they were opened from. If you create a new part, assembly, or drawing, it will be saved to your current working directory.

You can use any of the following methods to save a file:

• Click File > Save from the main menu.
• Click Save from the main toolbar.

Saving a Copy of Files

You can also save a copy of an existing file. Saving a copy enables you to create an exact copy of a file, but with a different name. When saving a copy of an assembly, you must also decide what to do about its dependent components. You can do nothing, or save a copy of them also and either rename them with a suffix or give them all new names.
Using Spin, Pan, Zoom and Named Views

Manipulate the 3-D orientation of your design models in the Creo Elements/Pro graphics area.

Keyboard/Mouse Orientation:

- Spin
- Pan
- Zoom
- Turn
- Wheel Zoom

Additional Orientation Options:

- Previous
- Refit
- Named View List
- Spin Center

Orientation using Keyboard and Mouse Combinations

To view a model in a specific orientation, you can spin, pan, and zoom the model using a combination of keyboard and mouse functions. For each orientation, you press and hold a key and click the appropriate mouse button, as shown in the following table.

<table>
<thead>
<tr>
<th>Orientation</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spin</td>
<td>![Spin Icon]</td>
</tr>
<tr>
<td>Pan</td>
<td>![Pan Icon]</td>
</tr>
<tr>
<td>Zoom</td>
<td>![Zoom Icon]</td>
</tr>
<tr>
<td>Turn</td>
<td>![Turn Icon]</td>
</tr>
</tbody>
</table>

The Spin Center

Orientations using the Keyboard and Mouse
Cursor over the area of interest before zooming in. The zoom function uses the cursor position as its area of focus. You can also zoom by using the scroll wheel. To control the level of zoom, press a designated key while using the scroll wheel, as shown in the following table:

<table>
<thead>
<tr>
<th>Zoom Level</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom</td>
<td></td>
</tr>
<tr>
<td>Fine Zoom</td>
<td><img src="Shift" alt="Shift" /></td>
</tr>
<tr>
<td>Coarse Zoom</td>
<td><img src="Ctrl" alt="Ctrl" /></td>
</tr>
</tbody>
</table>

### Additional Orientation Options

In addition to using keyboard and mouse combinations, the following additional model orientation options are available:

- **Previous** - Reverts the model to the previously displayed orientation by clicking **View > Orientation > Previous**.

- **Refit** - Refits the entire model in the graphics area.

- **Named View List** — Displays a list of saved view orientations available for a given model. Select the name of the desired saved view, and the model reorients to the selected view. Default Creo Elements/Pro template models come with the following saved views:
  - **Standard Orientation** — The initial 3-D orientation which cannot be altered.
  - **Default Orientation** — Similar to the Standard Orientation, but its orientation can be redefined to a different orientation.
  - BACK, BOTTOM, FRONT, LEFT, RIGHT, and TOP.

- **Spin Center** — Enables and disables the spin center. When enabled, the model spins about the location of the spin center. When disabled, the model spins about the cursor location. Disabling the spin center can be useful when orienting a long model, like a shaft.
PROCEDURE - Using Spin, Pan, Zoom and Named Views

Scenario
Practice orienting a model in the graphics area using saved views, the spin center, and basic keyboard and mouse model orientation.

Step 1: Set your working directory and disable datum displays.

1. Click File > Set Working Directory from main menu, at the top of the interface.
2. In the Select Working Directory dialog box:
   - Navigate to the folder Intro_Creo.ElementsPro.
   - Double-click the folder Module_01.
   - Double-click the folder Spin.
   - Click OK to set the folder as your working directory.
3. Use the datum display toolbar at the top of the interface to ensure the display of all datum features are disabled.

Step 2: Open CHASSIS.ASM and orient using saved views.

1. Click Open from the main toolbar.
2. In the File Open dialog box, select CHASSIS.ASM and then click Open.
3. Click Named View List from the main toolbar and select TOP.
4. Click Named View List and select LEFT.
5. Click Named View List and select Default Orientation.
**Step 3:** Orient with the spin center on and then off.

1. Middle-click and drag to spin the assembly.
2. Spin the assembly again in a different direction.
3. Spin the assembly in a third direction.

![The assembly is spinning about the spin center.]

4. Click **Named View List** and select **Standard Orientation**.
5. Click **Spin Center** from the main toolbar to disable it.
6. Cursor over the front portion the assembly and spin the assembly.

![Pan the assembly.]

7. Click **View > Orientation > Previous** from the main menu.
8. Cursor over the back of the assembly and spin the assembly. Notice that the center of rotation is the cursor location.
9. Click **Spin Center** from the main toolbar to enable it.

**Step 4:** Pan the assembly.

1. Press and hold **SHIFT**, then middle-click and drag to pan the assembly.
2. Click **Named View List** and select **Standard Orientation**.
Step 5: Zoom in and out of the assembly.

1. Press and hold CTRL, then middle-click and drag upward to zoom out.
2. Press and hold CTRL, then middle-click and drag downward to zoom in.

3. If your mouse is equipped with a wheel:
   • Roll the mouse wheel away from you to zoom out.
   • Roll the mouse wheel towards you to zoom in.
   • Press and hold CTRL, then roll the mouse wheel away from you to coarsely zoom out.
   • Press and hold SHIFT, then roll the mouse wheel towards you to finely zoom in.

The zoom function uses the cursor position as the center of focus. Because of this, be sure to place your cursor over the area of the model you wish to zoom in to.

4. Click Named View List and select Standard Orientation.
5. Cursor over the hole next to the teeth. Press and hold CTRL, then middle-click and drag downward to zoom in to the hole.
6. Click Refit from the main toolbar to refit the model.

7. Click File > Erase > Current.
8. In the Erase dialog box, click Select All, then click OK to erase all components of the assembly.

This completes the procedure.
Understanding Basic Display Options

You can modify the display of both the model and datum types.

- **Display is controlled independently for the following datum options:**
  - Datum Planes
  - Datum Axes
  - Datum Points
  - Coordinate Systems
- **There are four different model display options:**
  - Shaded
  - No Hidden
  - Hidden Line
  - Wireframe
- **Repaint** — Redraws or refreshes the screen.

### Setting Datum Display

Datum entities are 3-D reference geometry that you use for building feature geometry, orienting models, dimensioning, measuring, and assembling.

There are four main datum types:

- Datum Planes
- Datum Axes
- Datum Points
- Coordinate Systems

The display of each of these datum types is controlled independently by using the following icons on the main toolbar:

- **Plane Display** — Enable/Disable datum plane display.
- **Axis Display** — Enable/Disable datum axis display.
- **Point Display** — Enable/Disable datum point display.
- **CsSys Display** — Enable/Disable datum coordinate system display.
Setting Model Display

There are four different 3-D model display options in the graphics area:

- **Shading** — The model is shaded according to the view orientation. Hidden lines are not visible in shaded view display.

- **No hidden** — Hidden lines in the model are not displayed.

- **Hidden line** — Hidden lines in the model are displayed, by default, in a slightly darker color than visible lines.

- **Wireframe** — Hidden lines are displayed as regular lines. That is, all lines are the same color.

In the lower-right figure, the same model is displayed in four different ways. Clockwise from the top left, the display is Shaded, No Hidden, Wireframe, and Hidden Line.

Repainting the Screen

You can repaint a view to remove all temporarily displayed information. Repainting redraws or refreshes the screen, and is done either by clicking View > Repaint from the main menu or Repaint from the main toolbar.
PROCEDURE - Understanding Basic Display Options

Scenario
Edit the model and datum feature displays.

Step 1: Set your working directory.

1. If necessary, start Creo Elements/Pro.
2. Use the datum display toolbar at the top of the interface to ensure the display of all datum features are enabled.
3. Click **File > Set Working Directory** from main menu, at the top of the interface.
4. In the Select Working Directory dialog box:
   - Navigate to the folder **Intro_Creo_ElementsPro**.
   - Double-click the folder **Module_01**.
   - Double-click the folder **Display**.
   - Click **OK** to set the folder as your working directory.

Step 2: Open TIRE.PRT and edit the datum display.

1. Click **Open** from the main toolbar.
2. In the File Open dialog box, select TIRE.PRT and then click **Open**.
3. Disable the display of all datum features except datum planes:
4. Disable the display of all datum features except datum axes:

5. Disable the display of all datum features except datum points:

6. Disable the display of all datum features except datum coordinate systems:

7. Disable the display of all datum features:
**Step 3:** Edit the display of solid geometry.

1. Click **No hidden** from the main toolbar.
2. From the main menu, click **Tools > Environment**.
3. From the Display section of the Environment dialog box, click to deactivate **Colors**.
4. Click **OK** to close the dialog box.

5. Click **Hidden line**.

6. Click **Wireframe**.

7. Click **Shading**.
8. From the main menu, click **Tools > Environment**.
9. From the Display section of the Environment dialog box, click to activate **Colors**.
10. Click **OK** to close the dialog box.

11. Click **Window > Close** to close the TIRE.PRT window.
12. Click **File > Erase > Not Displayed**.
13. Click **OK** from the Erase Not Displayed dialog box.

This completes the procedure.
Selecting Items using Direct Selection

Direct selection occurs when you place the mouse cursor over a feature or component and click to select.

You can direct select:

• Components
• Features

Perform direct selection in:

• The graphics area
• The model tree

Select multiple items using CTRL.
Select a range of items using SHIFT.

Selecting Items using Direct Selection

After selecting features, geometry, or components in a model, assembly, or drawing, you are able to make modifications to the selected items. Direct selection is one of the three basic methods of selection.

Direct selection occurs when you place your mouse cursor over a feature or component and click to select it. Some key factors about direct selection include:

• You can perform direct selection on both components in an assembly and features in a model.

• You can perform direct selection in both the graphics area on a model or assembly, and in the model tree. When you initially cursor over a model in the Creo Elements/Pro graphics area, the component or feature preselects in the cyan color. When you select the item, it becomes highlighted in red. The selected item is dependent on whether you have a part or assembly open. If you have a part open, a selected feature highlights in a red wireframe. If you have an assembly open, the selected component highlights in a red wireframe.

• You can select multiple items by using the CTRL key.

• You can select a range of items from the model tree using the SHIFT key. If you select an item, press SHIFT and select a second item, the entire range of items in between is also selected.
• You can de-select components or features three different ways:
  – Press CTRL and click the selected item again.
  – Click in the graphics area background.
  – Click **Edit > Select > Deselect All** from the main menu.
Selecting Items using Query Selection

Query selection enables selection of features, geometry, or components that are hidden beneath another item.

Query Selection:
- Select by querying the model.
- Select using the Pick From List.

Pick From List

Original Model, Cursor Over to Highlight, Query to Highlight, Select

Selecting Items using Query Selection

Query selection is one of the three basic methods of selection. Query selection enables you to select features, geometry, or components that are hidden beneath another feature or model.

For example, in the figure shown, you may want to select the screw but the other models are obstructing your attempts to select it. In this situation, you can easily query and select the screw.

Query the Model

Use the following steps to query through components of an assembly or features of a part:
- Move your mouse over a component or feature in the graphics area and its edges will turn blue, highlighting the preselected item. Preselected means that if you click at that moment, that is what will be selected (and turn red).
- Right-click (tap your right mouse button) the preselected model or feature, you can query directly through the initial model or feature to the next model or feature. You can continue to right-click to query the next model or feature.
• When you have queried to the desired model or feature, you then click to make your selection.

Remember – Cursor over to highlight, right-click to query, and click to select.

**Pick From List**

The Pick From List is similar to querying the model, except that all of the query possibilities are listed in the Pick From List dialog box. This method is most useful in very large assemblies or complicated parts.

• Activate Pick From List by moving your cursor over the location you want to query, then right-click and select **Pick From List**.

• As you select items in the Pick From List dialog box, they will be highlighted in the graphics area.

• Select the item you want to select from the Pick From List dialog box, then select **OK** to make the selection.
PROCEDURE - Selecting Items using Query Selection

Scenario
Use query selection in an assembly and part model.

Step 1: Set your working directory and open QUERY.ASM.

1. Click File > Set Working Directory from main menu, at the top of the interface.
2. In the Select Working Directory dialog box:
   • Navigate to the folder Intro_Creo_ElementsPro.
   • Double-click the folder Module_01.
   • Double-click the folder Query.
   • Click OK to set the folder as your working directory.
3. Click Open from the main toolbar.
4. In the File Open dialog box, select QUERY.ASM, and then click Open.

Step 2: Use query to select the screw hidden behind other components.

1. Use the datum display toolbar at the top of the interface to ensure the display of all datum features are disabled.
2. Cursor over the center of assembly.
3. Right-click to query (tap your right-mouse button) until SCREW_NO2_SHLDR.PRT prehighlights, and then left-click to select it.

4. With the screw selected, right-click in the graphics area and select **Open** from the pop-up menu.

   It is necessary for you to right-click and hold to display pop-up menus.

5. Click **Window > Close** to close the window.

**Step 3:** Use Pick From List to select a feature hidden behind geometry in a model.

1. Cursor over SG SLOT.PRT and click to select it.

   Query is not required here as you have easy access to selecting the part.

2. With SG SLOT.PRT selected, right-click in the graphics area and select **Open** from the pop-up menu.
3. Cursor over the top cylindrical surface as shown.

4. Right-click and select **Pick From List** from the pop-up menu.

5. In the Pick From List dialog box, select F33(REVOLVE_4).

6. Click **OK** from the Pick From List dialog box.

7. Click in an empty spot in the graphics area to de-select the feature.

**Step 4:** Use query to select the same feature F33(REVOLVE_4).

1. Cursor over the area at the top of the cylindrical surface where the F33(REVOLVE_4) feature is located.

2. Right-click (tap the right-mouse button) to query the model until the F33(REVOLVE_4) feature prehighlights, and then left-click to select it.

3. Notice that the selected feature also highlights in the model tree.
4. Click **Window > Close** to close the SG_SLOT.PRT window.

5. Click **File > Erase > Current**.

6. In the Erase dialog box, click **Select All** 😘, then click **OK** to erase all components of the assembly.

This completes the procedure.
Understanding Selection Filters

The selection filter provides various filters to help you select items.

Filters include:

- Parts
- Features
- Geometry
- Datums
- Quilts
- Annotation

Understanding Selection Filters

Each filter in the selection filter narrows the item types that you can select, enabling you to easily select the item you are looking for. All filters are context-sensitive, so that only those filters that are valid for the geometrical context are available.

For example, the Parts filter would not be available while working in a part; rather it would be available while working in an assembly. Creo Elements/Pro automatically selects the best filter according to the context. However, you can always change the filter by simply selecting it from the selection filter.

The following filters are available in Part mode and Assembly mode:

- Parts — Available in Assembly mode only, enables you to only select components in the assembly.
- Features — Enables you to only select features in a part or component in the assembly.
- Geometry — Enables you to only select geometry, such as edges, surfaces, and vertices.
- Datums — Enables you to only select datum features, including datum planes, datum axes, datum points, and coordinate systems.
- Quilts — Enables you to only select surface quilts.
- Annotation — Enables you to only select annotation features.
Using the Smart Selection Filter

The smart filter enables you to select the most common types of items that are valid for the current geometrical context.

Smart Filter:

- The selection of features, geometry, or components is a nested process.
- Select specific items of interest after the initial selection.

Smart filter selection levels:

- Feature/Component level.
- Geometry level (surfaces, edges, or vertices).
  - You may need to zoom in for surface selection.

Using the Smart Selection Filter

Creo Elements/Pro automatically uses the Smart selection filter, if it is available. When using the Smart selection filter, the selection of features, geometry, or components is a nested process. This means you can select specific items of interest after the initial selection. There are two levels of selection when using the Smart Filter:

- **Feature/Component Level** – The features that comprise a part or components that comprise the assembly.
- **Geometry Level** – The surfaces, edges, and vertices (endpoints of edges) that comprise the model geometry.

When selecting a part in the graphics area, your initial selection highlights a feature in a red wireframe. The Smart selection filter then automatically narrows the selection scope, enabling you to select specific items on that feature that you wish to either modify or use to create another feature.

For example, you can select an edge where you wish to add a chamfer. The three specific items that you may wish to select highlight differently, as shown in the figure. Selected surfaces highlight as red-shaded items; selected edges highlight in bold red; and selected vertices highlight in red. The entire filtering process occurs automatically.
Assemblies have a similar selection scheme. Components are selected initially, followed by geometry such as surfaces, edges, and vertices.

Selection of items usually occurs easier if you zoom in on that area of the model first.
PROCEDURE - Using the Smart Selection Filter

Scenario
Use the smart selection filter in an assembly and part model.

**Step 1:** Set your working directory and open SMART.ASM.

1. Click **File > Set Working Directory** from main menu, at the top of the interface.
2. In the Select Working Directory dialog box:
   - Navigate to the folder *Intro_Creo_ElementsPro*.
   - Double-click the folder *Module_01*.
   - Double-click the folder *Smart*.
   - Click **OK** to set the folder as your working directory.
3. Click **Open** from the main toolbar.
4. In the File Open dialog box, select SMART.ASM and then click **Open**.

**Step 2:** Use the smart selection filter in an assembly.

1. Use the datum display toolbar at the top of the interface to ensure the display of all datum features are disabled.

2. In the graphics area, select component CHASSIS_SIDE-GEARS.PRT.

3. Zoom in to the hole in the upper-left area of the part.

4. Select the planar surface closest to you.
5. Select the cylindrical surface in the hole.

6. Select the edge of the hole.

7. Select the vertex on the edge of the hole.

8. Click in an empty space of the graphics area to de-select the vertex.

Step 3: Use the smart selection filter in a part model.

1. Press CTRL + D to orient the assembly to the standard orientation.
2. In the graphics area, select the M4–MACH_SCREW.PRT model, then right-click, and select Open from the pop-up menu.
3. Select the slotted extrude feature at the top of the screw.
4. Select the top edge of the slotted extrude feature.
5. Click in an empty space of the graphics area to de-select the edge.
6. Select the top extrude feature.
7. Select the front cylindrical surface of the top extrude feature.

8. Click **Window > Close** to close the M4–MACH_SCREW.PRT window.
9. Click **File > Erase > Current**.
10. In the Erase dialog box, click **Select All** 📦, then click **OK** to erase all components of the assembly.

This completes the procedure.
Managing Files in Creo Elements/Pro

Understanding Creo Elements/Pro’s file types and how they are used will help you manage your design.

Common File Extensions

- .prt — Part Files
- .asm — Assembly Files
- .drw — Drawing Files

Memory Management

- An open object is In Session.
- Erasing Memory (RAM)

Version Numbers and Deleting

- Version Numbers increase by one each time you save.
- Delete All Versions
- Delete Old Versions

Renaming Models

- Rename On Disk and In Session
- Rename In Session

Common File Extensions

The following are three file extensions used to identify three common Creo Elements/Pro object types: parts, assemblies, and drawings.

- .prt — This extension represents a part object.
- .asm — This extension represents an assembly object. An assembly file contains pointers and instructions that identify and position a collection of parts and subassemblies.
- .drw — This extension represents a 2-D drawing. The drawing file contains pointers, instructions, and detail items for documenting part and assembly models in a drawing.

Version Numbers and Deleting

Every time you save an object, you write it to disk. Rather than overwriting the current file, Creo Elements/Pro creates a new version of the file on disk and gives it a version number that increments each time the file is saved. This is also known as a *dot number*, and can be seen in the figure above.

To see all versions of an object in the File Open dialog box, click Tools and select All Versions from the drop-down list.

Deleting files permanently removes them from the working directory on your hard drive or network storage area. Be careful when deleting files; you cannot undo deleted files.
There are two different methods to delete models:

- **Old Versions** — Deletes all but the latest version of the given file.
- **All Versions** — Deletes all versions of the given file.

**Memory Management**

Creo Elements/Pro is a memory-based system, which means that files you create and open are stored within system memory (RAM). It is important to remember that until you save your files, you risk losing them if there is a power outage or system crash.

When a model is in system memory, it is referred to as being *In Session*. Models are kept In Session (in system memory or RAM) until you either erase them or exit Creo Elements/Pro.

When you close the window that contains a model, the model is still open In Session.

There are two different methods to erase models from session:

- **Current** — Only the model in the current window is erased from system memory (and the window closed). You can click **File > Erase > Current** from the main menu to erase the current window’s contents from memory.
- **Not Displayed** — Only erases from memory those models that are not open in any Creo Elements/Pro windows. You can click **File > Erase > Not Displayed** from the main menu.

Erasing models does not delete them from the hard drive or network storage area; it only removes them from session.

**Renaming Models**

If you need to change the name of any model, you can rename it from directly within Creo Elements/Pro.

There are two different methods to rename models:

- **On Disk and In Session** — The system renames the file both in system memory and on the hard drive.
- **In Session** — The system renames the file only in system memory.

Problems can result if you rename a file on disk and then retrieve a model (not already in session) that depends on the previous file name; for example, a part cannot be found for an assembly.
PROCEDURE - Managing Files in Creo Elements/Pro

Scenario
Erase files from memory and rename a part.

Step 1: Set your working directory.

1. If necessary, start Creo Elements/Pro.
2. Click File > Set Working Directory from main menu, at the top of the interface.
3. In the Select Working Directory dialog box:
   • Navigate to the folder Intro_Creo_ElementsPro.
   • Double-click the folder Module_01.
   • Double-click the folder Workdir.
   • Click OK to set the folder as your working directory.
4. Click File > Open from the main menu or Open from the main toolbar to open the File Open dialog box.
5. In the address bar at the top of the File Open dialog box, click Intro_Creo_ElementsPro to look in that folder. Browse into any folder you choose but do not open any files.
6. In the Common Folders list of the File Open dialog box, click Working Directory to return to your working directory.

Notice file extensions displayed for the two parts, an assembly, drawing and format file.
Step 2: Open, save and observe the version number changes.

1. In the File Open dialog box:
   • Click **Tools** and select **All Versions** from the drop-down list.
   • Observe the different version numbers associated with each file. Note that the part WHEEL.PRT has been saved three times.
   • Click **Tools** and select **All Versions** deactivate it.
   • Select WHEEL.PRT and click **Open** to open the latest version of the wheel.

2. Use the datum display toolbar at the top of the interface to ensure the display of all datum features are disabled.

3. Click **Save** from the main toolbar and click **OK** from the Save Object dialog box.

4. Click **Open** from the main toolbar.

5. In the File Open dialog box:
   • Click **Tools** and select **All Versions** from the drop-down list.
   • Observe that a new version of the wheel has been added, WHEEL.PRT.4.
   • Click **Cancel** to close the dialog box.
Step 3: Edit the model and then erase it from session.

1. In the model tree, right-click and hold your mouse down on the Extrude 1 feature, then select Edit from the pop-up menu.
2. Double click the dimension value 17.6, edit the value to 25 and press ENTER.
3. Click Regenerate from the main toolbar.
4. Click Open from the main toolbar.
5. In the File Open dialog box:
   - Click In Session from the Common Folders list.
   - Observe that WHEEL.PRT is the only model in session (or in memory).
6. From the main menu, click Window > Close.
7. Click Open from the main toolbar.
8. In the File Open dialog box:
   - Click In Session from the Common Folders list.
   - Observe that WHEEL.PRT is still in session (or in memory).
   - Click Cancel to close the dialog box.
Closing a window does not erase the model from memory, only from display.

9. Click **File > Erase > Not Displayed**.
10. Click **OK** from the Erase Not Displayed dialog box.
11. Click **Open** from the main toolbar.

12. In the File Open dialog box:
   - Click **In Session** from the Common Folders list.
   - Observe that WHEEL.PRT is no longer in session.
   - Click **Working Directory** from the Common Folders list.
   - Select WHEEL.PRT and click **Open** to open the last saved version of the wheel.

The change you previously made to the wheel is longer visible because you erased that version of the model from memory without first saving it. You are now looking at WHEEL.PRT.4 which was saved to disk before the change was made.

**Step 4:** Rename WHEEL.PRT to be WHEEL-NEW.PRT.

1. Click **Open** from the main toolbar.
2. In the File Open dialog box, select WHEEL.ASM and then click **Open**.
3. In the model tree, notice that WHEEL.PRT and TIRE.PRT are listed as members of the assembly.
4. From the main menu, click \textbf{Windows > 1 WHEEL.PRT} to activate the window that has WHEEL.PRT open.

5. From the main menu, click \textbf{File > Rename:}
   - Type \texttt{wheel-new} in the New Name text box and press ENTER.
   - Click \texttt{OK} to complete the rename.

6. From the main menu, click \textbf{Windows > 2 WHEEL.ASM} to activate the window that has WHEEL.ASM open.

7. In the model tree, notice that the renamed model WHEEL-NEW.PRT is now listed as a component of the assembly.

8. Click \texttt{Save} from the main toolbar and click \texttt{OK} from the Save Object dialog box.

9. Click \texttt{Open} from the main toolbar.

10. In the File Open dialog box:
    - Observe that WHEEL.PRT has been renamed to WHEEL-NEW.PRT.
    - Click \texttt{Tools} and select \texttt{All Versions} from the drop-down list.
    - Observe that because you saved the assembly, the latest versions is now WHEEL.ASM.3.
    - Click \texttt{Cancel} to close the dialog box.

\begin{tikzpicture}
    \node[anchor=south west,inner sep=0] at (0,0) {\includegraphics[width=\textwidth]{image}};
\end{tikzpicture}

Before renaming the wheel, it was important that WHEEL.ASM was open (In Session). Had it not been open, it would not have known that the name of the wheel had changed. It is also important that WHEEL.ASM be saved with this new information.
11. Click **Window > Close** to close the WHEEL.ASM window.
12. Click **Window > Close** to close the WHEEL.PRT window.
13. Click **File > Erase > Not Displayed**.
14. Click **OK** from the Erase Not Displayed dialog box.

This completes the procedure.
Understanding the Basics of Sketcher

A good understanding of sketcher concepts such as sketch plane, orientation, and references will make you be a better Creo Elements/Pro user.

Sketcher Setup:

• Sketch Plane
• Sketch Orientation
• Flip View Direction
• Use Previous

Edit Sketch Setup

Sketch Dialog Box

Sketcher References:

• Sketcher Geometry Snaps to References
• Any Model Geometry Selected in Sketcher

Adding Additional References

References Dialog Box

Sketcher Setup

A sketch is most commonly used to define the shape of an extrude or revolve feature. In those features, it defines the shape you will extrude or revolve.

Before you can start sketching a shape, you must first use the Sketch dialog box to select and orient the plane you will be sketching on.

• Sketch Plane — You can select any datum plane or planar surface to be your sketch plane. The sketch plane will be oriented parallel to your computer screen.
• Sketch Orientation — As soon as you have selected a sketch plane, Creo Elements/Pro will automatically select an orientation Reference and attempt to guess the orientation you want the model to be in. The “guess” is made based on the current orientation of your model.
  – Reference — A datum plane or surface normal to the selected sketch plane is automatically selected as an orientation reference. You can however choose any orientation reference you want, as long as it is normal to the sketch plane.
  – Orientation — The orientation direction that the Reference faces is either Top, Bottom, Left or Right.
• **Flip** — The **Flip** button will reorient your sketch so that you are viewing it from the other side. The view is rotated 180 degrees about a vertical axis.

• **Use Previous** — The **Use Previous** button is a big time saver when you are creating multiple features on the same sketch plane. Clicking it enables you to use the sketch plane and orientation of the previous sketch.

**Edit Sketch Setup**

To open the Sketch dialog box and edit the sketch plane or orientation, click **Sketch > Sketch Setup** from the main menu, when in sketcher mode.

You must be in sketcher to edit the Sketch Setup. This means you must edit the definition of the sketch feature or feature that contains an internal sketch.

**Sketcher References**

You use sketch reference to snap sketch geometry to. For example if you want the center of a circle on the edge of a model, you snap to that edge rather than dimensioning the circle to the edge. This eliminates extra dimension and adds intent to your design.

Sketch references are also used by the system for creating the initial weak dimensions and constraints applied when you sketch geometry.

Sketch references appear as brown, dashed entities in sketcher. Typically, the system automatically creates a vertical and horizontal reference using the default datum planes in the model.

**Adding Additional Reference**

Any time you are in sketcher, you can add additional references. To re-open the References dialog box, click **Sketch > References** from the main menu.
PROCEDURE - Understanding the Basics of Sketcher

Scenario

A sketch is most commonly used to define the shape of an extrude or revolve feature. It defines the shape you will extrude or revolve. In this exercise you will learn to select and orient a sketch plane and then select sketcher references to help define your sketch.

Step 1: Set your working directory and open SKETCH.PRT.

1. Click File > Set Working Directory from main menu, at the top of the interface.
2. In the Select Working Directory dialog box:
   - Navigate to the folder Intro_Creo_ElementsPro.
   - Double-click the folder Module_01.
   - Double-click the folder Sketch.
   - Click OK to set the folder as your working directory.
3. Use the datum display toolbar at the top of the interface to ensure that only the display of datum planes are enabled.
4. Click Open from the main toolbar.
5. In the File Open dialog box, select SKETCH.PRT and then click Open.

Step 2: Setup a sketch feature on datum plane FRONT.

1. In the sketcher toolbar, click Sketch Tool
   This is located at the top of the sketch toolbar on the right side of the interface.
2. Use the Sketch dialog box to select and orient your sketch plane:
   • The **Plane** collector is highlighted, ready for you to select the plane you will sketch on.
   • In the graphics area, click to select the face of the model marked as **X1** in the figure.
   • The **Reference** collector is now highlighted and datum plane TOP has been automatically selected as the orientation reference.
   • The **Orientation** direction has automatically been set to **Top**.

3. When you click **Sketch**, the following will happen:
   • The sketch plane you selected will be positioned parallel to your computer screen.
   • Datum plane TOP will be oriented to face the top of your computer screen.
   • The feature toolbars at the right of the interface will change to sketcher toolbars, ready for you to begin sketching.
   • Click **Sketch** from the Sketch dialog box.

4. Click **Hidden line**.
Step 3: Change the orientation of your sketch plane and begin sketching.

1. From the main menu, click Sketch > Sketch Setup.
2. From the Sketch dialog box:
   • From the Orientation drop-down list, select Bottom. This will force datum plane TOP to face the bottom of your screen.
   • Click Flip to view the model from the other side. This will rotate the model 180 degrees about the vertical.
   • Click Sketch.
3. Click Plane Display from the main toolbar to disable their display.
4. Sketch a rectangle:
   • Click Rectangle from the sketcher toolbar. The sketcher toolbar is located on the right side of the interface.
     – In the graphics area, cursor over the brown horizontal and vertical reference lines. Notice the cursor snaps as you pass over the reference lines.
     – Click at X1 to snap the start point of the rectangle to the intersection of the reference lines.
     – Drag your mouse and click at X2 to complete the rectangle. Note that the actual size of your rectangle is not important at this point because you can use dimensions to change its size at any time.
     – Drag your mouse away from the rectangle and then middle-click at X3 to release the rectangle tool.
Light gray colored “soft” dimensions are automatically created when you sketch a shape. If you edited the dimension values, they will change color and become a “strong” dimension.

5. Resize the rectangle:
   - Click and drag the edges of the rectangle to change its size.
   - Notice that only two of the rectangle edges will move. This is because the other two are constrained to the brown reference lines.
   - Double click the value of the vertical dimension, edit it to 7, and press ENTER.
   - Double click the value of the horizontal dimension, edit it to 25, and press ENTER.

Step 4: Add sketched references and re-sketch the rectangle using the new references to define the rectangle’s size.

1. In the main menu, click **Undo** until a few times, until the rectangle is gone.
2. From the main menu, click **Sketch > References**.

   The two references listed were automatically selected for you. These are the horizontal and vertical references you used to place the start point of the rectangle.
3. Select two additional references as shown:
   • Click the vertex at the end of the hidden line shown at X1.
   • Click the horizontal edge shown at X2.
   • Click **Close** from the References dialog box.

4. Sketch and size a rectangle using the new references:
   • Click **Rectangle** from the sketcher toolbar.
     – Click at X1 to snap the start point of the rectangle to the intersection of the reference lines.
     – Drag your mouse down and to the right.
     – Click to place the endpoint of the rectangle when it is snapped to both the vertex reference shown at X2 and the horizontal reference shown at X3.
     – Drag your mouse away from the rectangle and then middle-click at X4 to release the rectangle tool.

   ![Diagram of rectangle placement using X1, X2, X3, X4 references]

   If done correctly, the rectangle will have no soft dimensions because its size is defined by the selected references. If yours did not work, click **Undo** a few times and try again.

5. When finished sketching, click **Done Section** to complete the sketch.
Step 5: Use the sketch to extrude material from the model.

1. Press **CTRL + D** to place the model back into a default orientation.
2. Click **Shading**.
3. Ensure that **Sketch 1** is still selected. If the sketched rectangle is not highlighted in red and shown as selected in the model tree, click it again.
4. With Sketch 1 still selected, start the **Extrude Tool** from the feature toolbar.
   The feature toolbar is located on the right side of the interface.

5. In the extrude dashboard, above the graphics area:
   - Click **Remove Material**.
   - Click **Blind** and then select **Through All** from the drop-down list.
   - Click **Complete Feature** to complete the feature.

Step 6: Move the sketch plane to datum plane FRONT.

1. In the model tree, right-click **Sketch 1**, then select **Edit Definition** from the pop-up menu.
2. From the main menu, click **Sketch > Sketch Setup** to open the Sketch dialog box:
   - In the model tree, click to select datum plane FRONT.
   - Notice in the dialog box that the Sketch Plane is now datum plane FRONT.
   - Click **Sketch** to close the Sketch dialog box.

3. Press **CTRL + D**.
4. Notice that the sketch has moved from the front face of the model to datum plane FRONT in the center of the model.
5. Click **Done Section** to complete the sketch.

6. Middle-click and drag to spin the model so you can see how Extrude 4 has changed.

7. In the model tree, right-click Extrude 3, and select **Edit** from the pop-up menu.

8. Double-click the dimension value 7, edit it to **15**, and press ENTER.

9. Click **Regenerate** from the edit toolbar to update the model using the new dimension value. The edit toolbar is located at the top of the interface.

10. Middle-click and drag to spin the model so you can see how it has changed.

   Because Sketch 1 referenced the edge of Extrude 3, it grew as Extrude 3 grew.

11. Click **File > Erase > Current**, then click **Yes** to confirm.

   This completes the procedure.
Module 2

Basic Part Modeling

Module Overview
In this module, you will begin the creation of a wheel used in the Aston Martin slot car. The exercise will take you through the steps used to create the part model in Creo Elements/Pro.

For a more in-depth understanding of the features and process used in this exercise, see Module 7, Basic Part Modeling - References.

Objectives
After completing this module, you will be able to:
• Create new Creo Elements/Pro parts.
• Understand basic sketcher theory and tools.
• Use sketcher to define an extruded shape.
• Create extrude features.
• Create hole features.
• Create datum planes.
Basic Part Modeling

The typical part model is created using four fundamental elements:

1. Default Datums
2. Base Feature
3. An Extrude is a Sketched Feature
4. A Hole is a Direct Feature

New Part

Each new part you create in Creo Elements/Pro will contain a default set of datum planes and a coordinate system that are copied in from a template model. Think of these default datums as the foundation that you build your part on.

Unlike solid geometry, reference geometry such as datum planes and coordinate systems have no mass, surface area, or size. Datum features are references used to sketch on, dimension to, assemble to, and so on. Their uses and benefits will become more apparent as you learn to use Creo Elements/Pro.

Base Feature

The first solid feature you create is referred to as the “base” feature. It is typically an extrude or revolve feature placed at the center of the default
datum planes. After the base feature, additional features are added to further define the shape, size and function of your part. It is the combination of these features that will define the geometry of your part.

**Sketched Features**

Extrude and Revolve are the most commonly used “sketched” features. They are referred to as sketched features because the shape that is extruded or revolved is defined by a sketch. Other, not so commonly used sketched features are sweeps, blends, and variable section sweeps.

**Direct Features**

Direct features are sometimes called “pick & place” features as they are applied directly to the model without the need for a sketch. Examples of direct features are rounds, chamfers, holes, draft features, and so on. The shape of direct features are defined by the feature type, dimensions values, and references they are applied to. For example, a round feature is defined by the edge it is placed on and the radius value entered.
PROCEDURE - Basic Part Modeling

Scenario

You will begin modeling a wheel that will be used in the Aston Martin slot car. You will start by creating a new part that will initially contain only default datum features copied from the template model. You will then add simple features to define the basic shape and functional geometry of the wheel.

In subsequent exercises, you will document the wheel design in a drawing, create a wheel assembly that is assembled to the slot car and then, improve the wheel design by adding additional, more advanced features. Finally, you will create a photo realistic rendering of the completed design.

Step 1: Set your working directory and create a new part named wheel.

1. If necessary, start Creo Elements/Pro.
2. Click File > Set Working Directory from main menu, at the top of the interface.
3. In the Select Working Directory dialog box:
   • Browse to the folder Intro_Creo.ElementsPro.
   • Double-click the folder Module_02-06.
   • Double-click the folder Part.
   • Click OK to set the folder as your working directory.

   The wheel part you create will be saved to and opened from this “working directory”.

4. Create the new wheel part model:
   • Click New from the file toolbar, at the top-left of the interface.
   • In the New dialog box, notice the default object Type is Part and Sub-type is Solid, these are the correct selections for creating a solid part.
   • Type wheel in the Name field and click OK.
5. Use the datum display toolbar at the top of the interface to ensure that only the display of datum planes are enabled.

The datum planes FRONT, RIGHT and TOP represent the 3D space of your model. Think of these datums as the foundation your wheel will be built on.

**Step 2:** Create a circular sketch to define the shape of the wheel.

Begin the wheel design by creating a 2D circular sketch feature. You will select datum plane FRONT as your Sketch Plane and then sketch a circle with a diameter of 17.6.

1. Start the **Sketch Tool** from the datum toolbar.
   
   The datum toolbar is located on the upper-right side of the interface.

2. Select and orient the Sketch Plane:
   - Click to select datum plane FRONT (from the model tree or graphics area) as the Sketch Plane.
   - In the Sketch dialog box, ensure the selected Reference is datum plane TOP and the selected Orientation direction is **Top**.
   - Click **Sketch** to enter Sketcher mode.

You are now in sketch mode. The sketch plane FRONT is parallel to the computer screen, oriented by datum plane TOP facing towards the top of the screen. Sketcher toolbars have replaced the feature toolbars on the right side of the interface.
3. Sketch the circle:
   - Click **Center and Point Circle** from the sketcher toolbar. The sketcher toolbar is located on the right side of the interface.
   - In the graphics area, cursor over the horizontal and vertical reference lines. Notice the cursor snaps as you pass over the reference lines.
   - Click at **X1** to snap the center of the circle to the intersection of the reference lines.
   - Drag your mouse and click at **X2** to complete the circle. Note that the actual size of your circle is not important at this point.
   - Drag your mouse away from the circle and then middle-click at **X3** to release the circle tool.

Light gray colored “soft” dimensions are automatically creates each time you sketch a shape. When you edited the value of a soft dimension, its color changes and it becomes a “strong” dimension. Soft dimensions are Creo Elements/Pro’s guess as to how the sketch should be defined.

4. Edit the size of the circle:
   - Double-click the value of the soft diameter dimension (the numerical value at the end of the leader).
   - Edit the value to **17.6** and press ENTER.
   - Click **Done Section** from the sketcher toolbar, to complete the sketch feature.
Step 3: Use the Extrude tool to create a solid cylinder.

Use the previously created external sketch and the Extrude tool to create a solid cylinder that is extruded a depth of 4.5 mm, symmetrically about the sketch plane FRONT.

1. Press **CTRL + D** to place the model back into a default orientation.
2. Ensure that **Sketch 1** is still selected. If the sketched circle is not highlighted in red and shown as selected in the model tree, click it again.
3. With Sketch 1 still selected, start the **Extrude Tool** from the feature toolbar.
   The feature toolbar is located on the right side of the interface.
   The feature is automatically previewed using default extrude options. You will use the dashboard located above the graphics area to edit those options.
4. In the extrude dashboard located above the graphics area:
   - Click **Blind** and then select **Symmetric** from the depth drop-down list.
   - Edit the depth value to **4.5** and press **ENTER**.
   - Click **Complete Feature**.

© 2009 PTC
Step 4: Use the Extrude tool to create a second solid cylinder, this time using an internal sketch.

Use the Extrude tool to create a second solid cylinder that is extruded a depth of 9.2 mm, symmetrically about the sketch plane FRONT. An internal sketch of a 15.6 diameter circle will define the shape of the extrude.

1. Click **Plane Display** to disable their display.

2. Start the **Extrude Tool**.

3. Select and orient the Sketch Plane:
   - In the dashboard, select the **Placement** tab.
   - Click **Define** to open the Sketch dialog box.
   - Click **Use Previous** to use the sketch plane of the previous feature. In this case, the previous sketch plane was datum plane FRONT.

4. Click **Center and Point Circle**:
   - Click at **X1** to snap the center of the circle to the intersection of the reference lines.
   - Drag your mouse and click at **X2** to complete the circle.
   - Drag your mouse away from the circle and then middle-click at **X3** to release the circle tool.

5. Edit the size of the circle:
   - Double-click the value of the diameter dimension.
   - Edit the value to **15.6** and press ENTER.
   - Click **Done Section**.
When learning to sketch, it can be helpful to use the **Undo** and **Redo** buttons at the top of the interface. There is no need to cancel the sketch and start over.

6. Press **CTRL + D** to place the model in a default orientation.

7. In the extrude dashboard:
   - Click **Blind** and then select **Symmetric** from the depth drop-down list.
   - Edit the depth value to **9.2** and press ENTER.
   - Click **Complete Feature**.

Observe in the model tree that Extrude 1 has an external sketch named Sketch 1 associated to it. You created Extrude 2 using an internal sketch so there is no external sketch associated to it. An “internal” sketch enables you to sketch the feature’s shape during creation of the feature, rather than as a separate feature. On the other hand, an “external” sketch enables you to use the same sketch for multiple features. You will find both methods used in Creo Elements/Pro training materials but for your own designs, use the method you are most comfortable with.
Step 5: Use the Extrude tool to remove material from the part.

Use the Extrude tool to remove material from the model. The sketched shape will be a circle that is offset .75 from the inner model edge. To meet the engineering team’s requirements, the depth of this extrude feature will be defined using a different depth option on each side of the sketch plane.

1. If necessary, press CTRL + D to place the model in a default orientation.
2. Start the Extrude Tool.
3. Right-click and hold your mouse button down in the graphics area, then select Define Internal Sketch from the pop-up menu.
4. From the model tree, click datum plane FRONT as the Sketch Plane.
5. Click Sketch from the Sketch dialog box.
6. Click No hidden from the model display toolbar.

7. Click Center and Point Circle:
   - Click at X1 to snap the center of the circle to the intersection of the reference lines.
   - Drag your mouse and click at X2 to complete the circle.

8. Click Normal Dimension from the sketcher toolbar:
   - Click the sketched circle at X1.
   - Click the inner circular model edge at X2.
   - Middle-click at X3 to place the dimension.
   - Type .75 and press ENTER.
9. Click Done Section.
10. Click **Named View List** from the view toolbar and select **Default Orientation** from the drop-down list.

11. Click **Shading** from the model display toolbar.

12. In the dashboard, select the **Options** tab:
   - Edit the **Side 1** blind depth value to 1.5 and press ENTER.
   - From the **Side 2** drop-down list, click **None** and then select **Through All** from the drop-down list.

13. In the dashboard, click **Remove Material**.

   The extrude will remove material a depth of 1.5 on Side 1 of the sketch plane and through the entire model on Side 2.

14. Click **Complete Feature**.

15. Middle-click and drag to spin the model so you can see material was removed from the model.

16. Click **Named View List** and select **Right** from the drop-down list.

17. In the model tree, right-click **Extrude 3** and select **Edit** from the pop-up menu.

To meet a key design requirement of the wheel, the engineering team insisted the depth of this cut be defined by a blind depth, 1.5 mm forward from datum plan FRONT and through the entire model in the other direction. This was accomplished using both depth options **Blind** and **Through All**. You are just learning now but with experience, you will learn to create models using your design intent rather than simply excepting the default options Creo Elements/Pro presents to you.
Step 6: Create a datum plane and use it as your sketch plane.

Create a datum plane that is offset from 5 mm from the back of the wheel. Use the new datum plane as the sketch plane of an extrude feature. After completing the extrude feature, embed the datum plane into the extrude feature.

1. Press **CTRL + D** and click **Plane Display** to enable their display.
2. Middle-click and drag to spin the model until you can view the back of the model.
3. Click **Datum Plane Tool** from the datum toolbar.
4. From the selection filter located just above the DATUM PLANE dialog box, click **All** and then select **Surface** from the drop-down list.
5. Click the back surface of the model highlighted in red. The datum plane will be offset from this reference.
6. Edit the offset value to 5 (away from the model) by editing the Translation field or moving the drag handle.
7. Click **OK** from the DATUM PLANE dialog box to complete the feature.
8. With the new datum plane DTM1 still selected, start the **Extrude Tool**.
9. Right-click and hold your mouse button down in the graphics area, then select **Define Internal Sketch** from the pop-up menu.

Because DTM1 was selected before you clicked the **Extrude Tool**, it was automatically used as the Sketch Plane.
10. Click **Sketch** from the Sketch dialog box.

11. Click **Center and Point Circle** and place a circle at center of the model.

12. Middle-click to release the circle tool.

13. Edit the diameter of the circle to **4.25** and press ENTER.

14. Click **Done Section**.

15. Press **CTRL + D**.

16. Middle-click and drag to spin the model until you can view the back of the model.

17. In the graphics area, click the yellow direction arrow so that the extrude direction is down, into the model.

18. In the dashboard, click **Blind** and then select **To Next** from the drop-down list.

19. Click **Complete Feature**.

20. In the model tree, click and drag datum plane **DTM1** onto **Extrude 4** and then release your mouse.

21. Click the + next to Extrude 4 to see that DTM1 is now embedded in the feature.

22. Click **Plane Display** to disable their display.

23. In the model tree, right-click Extrude 4 and then select **Edit** from the pop-up menu.

24. Double-click the dimension value 5, edit it to 1 and press ENTER.

25. Click **Regenerate** from the edit toolbar to update the model using the new dimension value. The edit toolbar is located at the top of the interface.
Because DTM1 is embedded in Extrude 4, the offset dimension for DTM1 is now displayed when Extrude 4 is edited. To keep your model organized and easy to understand, it is best practice to embed datum features referenced by a specific feature.

**Step 7:** Create a coaxial type hole.

Use the Hole tool to create a coaxial hole on the axis of the axle hub. The hole will be 2.33 in diameter and have a blind depth of 6. The car axle will be inserted into the hole when assembled.

1. Click **Axis Display** to enable their display.
2. If necessary, middle-click and drag to spin the model until you can view the back of the model.
3. Start the **Hole Tool** from the feature toolbar:
   - In the graphics area, click axis A_1 to position the hole.
   - Press and hold CTRL while you click the placement surface shown in red.
   - Edit the hole diameter to **2.33** and depth to **6**.
   - Click **Complete Feature**.
Because axis A_1 and the placement surface were selected as references, this hole was automatically created as a coaxial type hole. Other hole types available are Linear, Radial and Diameter.

4. Click **Axis Display** to disable their display.

5. Press **CTRL + D**.

6. Click **Save** and then click **OK** from the Save Object dialog box.

7. Click **File > Backup** and in the Backup dialog box:
   - Browse to the folder **Module_02-06**.
   - Double-click the folder **Submissions**.
   - Double-click the folder **Module02**.
   - Click **OK** to backup the model.

After you complete this course, files backed up to the Submissions folder will be submitted to PTC Academy so that you can obtain your certification.

8. Click **File > Erase > Current**, then click **Yes** to confirm.

This completes the procedure.
Module Overview

In this module, you will begin the creation of a 2-D drawing documenting your wheel design. The exercise will take you through the basic steps used to create a 2-D drawing in Creo Elements/Pro.

For a more in-depth understanding of the drawing creation process used in this exercise, see Module 8, Basic Drawing Creation - References.

Objectives

After completing this module, you will be able to:

• Understand drawing concepts and theory.
• Create new drawings using drawing templates.
• Understand the drawing ribbon user interface.
• Edit the drawing scale.
• Edit the properties of drawing views.
• Create a cross-section view.
• Show and manipulate annotations in your drawing views.
• Publish your drawing to a PDF file.
Basic Drawing Creation

Drawing creation can be summarized in four basic steps:

1. Create a New Drawing
2. Add and Manipulate Views
3. Show and Create Annotations
4. Manipulate Annotations

Drawings Theory

Part and assembly designs are typically documented in a 2-D drawing. While not always required, the 2-D drawing is the traditional final design deliverable at many companies. The released 2-D drawing in conjunction with the 3-D model geometry is then used to create and inspect the completed design.

A 2-D drawing contains parametric views of the 3-D design model, dimensions, and a title block. The drawing may also contain notes, tables, and further design information.

A Creo Elements/Pro drawing is bi-directional. If a change is made to the design model, the drawing that displays that model automatically updates to reflect the change. Conversely, if a change is made in the drawing, the design model automatically updates accordingly.

Creating a New Drawing

There are three methods for creating a drawing:

- **Use template** - A template drawing is used to automatically create a drawing containing predefined views, format, and possibly annotations.
- **Empty with format** - A drawing is created based on a selected format size. All views of the design model must be added manually.
- **Empty** - A drawing is created based on a selected drawing size. The views and format must be added manually.
In this exercise we will create a drawing using a template. A template does not give you a perfectly completed drawing but it does give you a head start by automatically placing views and the drawing format.

**Add and Manipulate Views**

Even when a drawing is created using a template, additional views are typically required to properly document a design. The following view types that can be added to a drawing:

- General - You define the orientation of this view.
- Projection - This view is automatically projected from an existing view.
- Detailed - A detailed close up view of a selected area on another view.
- Auxiliary - A view projected from selected geometry of an existing view.
- Revolved - A revolved section view.

Each view has a set of properties that can be edited to change the view type, display, scale, and other options.

**Show and Create Annotations**

You can show the dimensions and notes that are in your part or assembly, in your drawing. This means you are not required to recreate dimensions to document your design.

If required, you can also create “driven” dimensions in a drawing. Unlike dimensions shown from the model, driven dimensions will not drive your model design. Driven dimension will update when your model changes.

Notes and datum annotations can also be shown or created in a drawing.

**Manipulate Annotations**

Drawing annotations can be manipulated to create a clean and standard compliant drawing. Annotations can be moved, tolerances added, text size changed, and so on. Anything needed to create a standard compliant drawing is possible in Creo Elements/Pro.
PROCEDURE - Basic Drawing Creation

Scenario

Complete this module to learn how to document your design in a 2-D drawing. If drawing creation and drafting principles are not taught in your program, skip to Module 4.

Now that you have started the design of the wheel, you will begin documenting the design in a 2-D drawing. After you create a new drawing using a template, you will edit properties of the drawing views. You will then show and manipulate dimensions in the drawing.

In subsequent exercises, you will create a wheel assembly that is assembled to the slot car and then, improve the wheel design by adding additional, more advanced features. Finally, you will create a photo realistic rendering of the completed design.

Step 1: Begin documenting the wheel design in a 2-D drawing.

Starting the documentation of your design before it is complete, promotes concurrent design and provides additional tool for assessing your design early in the process. In this task, create a drawing using the A3 size drawing template.

1. If necessary, start Creo Elements/Pro.
2. Click File > Set Working Directory from main menu, at the top of the interface.
3. In the Select Working Directory dialog box:
   - Browse to the folder Intro_Creo_ElementsPro.
   - Double-click the folder Module_02-06.
   - Double-click the folder Drawing.
   - Click OK to set the folder as your working directory.
   
   The drawing you create will be saved to and opened from this “working directory”.

4. Click New from the file toolbar.
5. In the New dialog box:
   - Select Drawing as the Type.
   - Type wheel in the Name field and then click OK.

Module 3 | Page 4 © 2009 PTC
6. Use the datum display toolbar at the top of the interface to ensure the display of all datum features are disabled.

7. From the New Drawing dialog box:
   • If the Default Model has not already been set to WHEEL.PRT, click **Browse**, select WHEEL.PRT and then click **Open** to set the drawing’s default model.
   • Select **a3_drawing** from the list of drawing templates.
   • Click **OK** and a drawing will automatically be created.

An A3 drawing is 297 X 420 mm, similar in size to an ANSI B size which is 11 X 17 inches.
8. Select each drawing tab to observe the functionality found in each:
   - **Layout** – Sheets, formats, views, display settings and drawing objects are controlled from this tab.
   - **Table** – Tables are created and edited using tools in this tab.
   - **Annotate** – Dimensions, notes and tolerances are shown, created and controlled using tools in this tab.
   - **Sketch** – 2-D draft entities can be sketched using tools in this tab.
   - **Review** – Update your drawing, compare different versions, query for information and take measurements using tools in this tab.
   - **Publish** – Preview, print and export your drawing from this tab.

9. If necessary, select the **Layout** tab.

10. Edit the overall drawing scale:
   - Double-click the text **SCALE: 3:1** located in the lower-left of the graphics area.
   - Enter **4** and press ENTER to change the overall drawing scale.

11. Press and hold **CTRL**, then middle-click and drag over the shaded view. Drag your mouse toward you to zoom-in, away from you to zoom-out.

12. Release the **CTRL** key, then middle-click and drag to position the view in the center of the graphics area.
**Step 2:** Edit the display properties of individual drawing views.

1. **Edit properties of the shaded view:**
   - Ensure that the **Layout** tab is selected.
   - Move your mouse over the shaded view, when the view highlights, click to select it.
   - Right-click and select **Properties** from the pop-up menu.

2. In the Drawing View dialog box, edit the scale of the view:
   - Select **Scale** from the Categories list.
   - Click **Custom scale**, edit the scale from 4 to 2 and press ENTER.
   - Click **Apply** and observe that the view is scaled and a scale note automatically added.

3. In the Drawing View dialog box, edit the display of the view:
   - Click **View Display** from the Categories list.
   - Select **No Hidden** from the Display style drop-down list.
   - Click **OK** to apply the change and close the dialog box.

4. With the **Layout** tab still selected, attempt to select the view note **SCALE 2:1**, you will not be able to select it.

5. Select the **Annotate** tab, then click to select the view note **SCALE 2:1**, a red selection box will be displayed around the note.

> Drawing tabs work as filters, annotations cannot be selected when the **Layout** tab is open and view properties cannot be edited when the **Annotate** tab is selected.
6. With the view note selected, right-click and select **Edit Value** from the pop-up menu.

7. Edit the scale from 2 to **3** and press ENTER.

8. Click **Refit** from the view toolbar at the top of the interface.

9. Edit the top view to show hidden lines:
   - Select the **Layout** tab.
   - Click an empty area of the drawing to deselect any selected entities.
   - Move your mouse over the top view, when the view highlights, click to select it.
   - Right-click and select **Properties** from the pop-up menu.
   - Click **View Display** from the Categories list.
   - Select **Hidden** from the Display style drop-down list.
   - Click **OK** to close the dialog box.
10. If necessary, click Refit from the view toolbar at the top of the interface.

11. Edit the right view to be a x-section view named A-A:
   - Move your mouse over the right view, when the view highlights, click to select it.
   - Right-click and select Properties from the pop-up menu.
   - Click Sections from the Categories list.
   - Click 2D cross-sections from the Section options area.
   - Click Add Section and Done from the menu manager in the lower-right.
   - Type A as the cross-section name and press ENTER.
   - Click to select datum plane RIGHT from the model tree.
   - Click OK to close the dialog box.

12. With the right view still selected, right-click and select Add Arrows from the pop-up menu, then click the front view to place the cut arrows.
Step 3: Show the model’s dimensions and axis in the drawing.

1. If necessary, click **Refit** from the view toolbar at the top of the interface.

2. From the **Annotate** tab, click **Show Annotations**.

3. In the model tree:
   - Click **Sketch 1**.
   - Press and hold **Shift** while you click **Hole 1**.

4. In the Show Model Annotations dialog box:
   - Click **Select All** to show all dimension from the selected features.
   - Click the **Datums Tab** and in the Show column, click the three check-boxes that display axis A_1 in the three 2-D views. Do not select the check-box that displays the axis in the 3-D view.
   - Click **OK**.

5. Right-click in the graphics area and select **Cleanup Dimensions** from the pop-up menu:
   - Disable **Create Snap Lines**.
   - Edit the Offset value from 12.5 to **8** and press ENTER.
   - Click **Apply** and then click **Close**.

6. Click in the graphics area to deselect the dimensions.

7. Click **Repaint** from the view toolbar.
Step 4: Manipulate drawing annotations.

Move and manipulate dimensions so your drawing looks like the image below. Your drawing does not have to match exactly, it is only important that you learn how to manipulate the annotations.

1. If necessary, click **Refit**.
2. With the **Annotate** tab selected, select any dimension, axis, or note you want to manipulate. Multiple items can be selected using the CTRL key or pick-box selection.
3. Use the following methods to manipulate the selected annotations:
   - To move the dimension and text, or a note, click and drag the handle at the center of the text.
   - To move only the dimension’s text, click and drag the handles at either side of the text.
   - To move the entire dimension, click and drag handles at the arrow head tips.
   - To clip the dimension witness lines, click and drag the handle at the end of each extension line.
   - To flip dimension arrows, right-click and select **Flip Arrows**.
   - To resize an axis, drag the handle at either end of the selected axis.
   - To move a dimension from one view to another, right-click and select **Move Item to View**, then click the view you want the item moved to.
4. To move the views, right-click and deselect the **Lock View Movement**, then select and move any view as required.
**Step 5:** Add model parameters in the drawing format and print the drawing.

1. Use the Shift key along with your middle-mouse to pan and then zoom in on the title block area of the drawing, located in the lower-right corner of the drawing.

   No Title or Project names are displayed. The parametric format used in the drawing reads this information from the model and that information has not been entered.

2. Click **Open** from the file toolbar at the top of the interface.
3. Select WHEEL.PRT and click **Open**.
4. Click **Tools > Parameters** from the main menu.
5. In the Parameters dialog box:
   - Edit the **Value** of the DESCRIPTION parameter to **PTC ASTON MARTIN WHEEL DESIGN**.
   - Edit the **Value** of the PROJECT parameter to **PTC SLOT CAR**.
   - Click **OK**.

6. Click **Window** from the main menu and select WHEEL.DRW to activate the drawing.

   The parametric format read the parameters from the model.
7. Click **Refit** from the view toolbar at the top of the interface.

8. Select the **Publish** tab:
   - Click **PDF**.
   - Click **Export**.
   - Click **OK** from the Save a Copy dialog to create a PDF of the drawing.

9. Click **Save** and then click **OK** from the Save Object dialog box.

10. Click **File > Backup** and in the Backup dialog box:
    - Browse to the folder **Module_02-06**.
    - Double-click the folder **Submissions**.
    - Double-click the folder **Module03**.
    - Click **OK** to backup the drawing and all files required by the drawing.

    After you complete this course, files backed up to the Submissions folder will be submitted to PTC Academy so that you can obtain your certification.

11. Click **Window > Close** to close the WHEEL.DRW window.

12. Click **Window > Close** to close the WHEEL.PRT window.

13. Click **File > Erase > Not Displayed**.

14. Click **OK** from the Erase Not Displayed dialog box.

This completes the procedure.
Module 4

Basic Assembly Modeling

Module Overview
In this module, you will create a wheel assembly, containing the wheel part you have started to design along with an already complete tire part.

After you have completed the wheel subassembly, you will add it to the front and rear axle assemblies. The exercise will take you through the basic assembly steps. After placing the wheel assembly into the front axle assembly the first time, you will use copy and paste to save time placing three additional instances of the subassembly.

For a more in-depth understanding of the assembly creation process used in this exercise, see Module 9, Basic Assembly Modeling - References.

Objectives
After completing this module, you will be able to:
• Create new Creo Elements/Pro assembly.
• Assemble the first component of an assembly using the Default constraint.
• Assemble components using the Automatic option to create Mate, Insert, and Align constraints.
• Use copy and paste functionality to assemble components.
Basic Assembly Modeling

The basic assembly modeling process can be summarized in four steps:

1. Default Assembly Datums

2. Default Placement of First Component

3. Orient Added Components

4. Constrain Components

New Assembly

Each new assembly you create in Creo Elements/Pro will contain a default set of datum planes and a coordinate system that are copied in from a template model. Think of these default datums as the foundation that you begin assembling components to.

Unlike solid geometry, reference geometry such as datum planes and coordinate systems have no mass, surface area, or size. Assembly datum features are often used as assembly references.

Default Placement of First Component

To place the first component in your assembly, click Assemble from the feature toolbar. In the Open dialog box, select the component you want to assemble and click Open, then click to position the model anywhere in the graphics area.

The first component of an assembly is typically constrained the Default constraint. Apply the Default constraint using one of the following methods:

- Right-click in the graphics area and select Default Constraint from the pop-up menu.
• In the assembly dashboard at the top of the graphics area, click **Automatic** and select **Default** from the drop–down list.

**Orient Added Components**

Additional components are placed in the assembly using the **Assemble** tool. As subsequent components are added to the assembly, it is often helpful to reorient the component inside the assembly, before constraints are applied.

As with any part or assembly in Creo Elements/Pro, if you middle-click and drag, the entire assembly will spin. Use the following keyboard and mouse combinations to orient only the component being placed:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Spin</strong> – The component will spin within the assembly. Partially constrained components only spin in unconstrained directions.</td>
<td>Ctrl + Alt + Arrow</td>
</tr>
<tr>
<td><strong>Pan</strong> - The component will pan about the assembly. Partially constrained components only pan in unconstrained directions.</td>
<td>Ctrl + Alt + Arrow</td>
</tr>
<tr>
<td><strong>Component Drag</strong> – The component will spin and pan about the assembly. Partially constrained components can only be dragged in unconstrained directions.</td>
<td>Ctrl + Alt + Arrow</td>
</tr>
</tbody>
</table>

**Constrain Components**

After you have placed and oriented a component it is important that you add assembly constraints to define its final design position. Using the wheel and tire assembly shown:

• An **Insert** constraint is applied to cylindrical surface of each part. This constraint type aligns the center axis of each model.

• An **Align** constraint is applied to datum planes FRONT of each model. This constraint centers the tire on the wheel.

• There is actually one degree of freedom remaining, the wheel can still spin about the center axis of the wheel. An additional constraint could be added but by default, Pro/ENGINEER assumes it is fully constrained. This is done to save time because often, the remaining degree of freedom is not required to position an inserted component.

The **Insert** and **Align** constraints can be explicitly selected from the constraint drop-down list in the dashboard under **Automatic**, however, it is often easier to let Creo Elements/Pro select them based on the references you select. In this case, selecting the two cylindrical surfaces caused an **Insert** to be automatically applied. Selecting the two datum planes caused the **Align** constraint to be applied.
PROCEDURE - Basic Assembly Modeling

Scenario
You will start by creating a new assembly model into which you will assemble your wheel and then an existing tire model. After the wheel assembly is complete you will assemble it to the front and read axle assemblies.

To save time, after assembling the wheel subassembly the first time, you will use Copy and Paste to assemble the remaining three instances. Finally, you will open the Aston Martin assembly to see how the new wheels look on the car.

In subsequent exercises, you will improve the wheel design by adding additional, more advanced features and then finally, you will create a photo realistic rendering of the completed design.

Step 1: Create an assembly containing WHEEL.PRT and TIRE.PRT.

1. If necessary, start Creo Elements/Pro.
2. Click File > Set Working Directory from main menu, at the top of the interface.
3. In the Select Working Directory dialog box:
   • Browse to the folder Intro_Creo_ElementsPro.
   • Double-click the folder Module_02-06.
   • Double-click the folder Assembly.
   • Click OK to set the folder as your working directory.
   
   The assembly you create will be saved to and opened from this “working directory”.

4. Use the datum display toolbar at the top of the interface to ensure the display of all datum features are disabled.

5. Click New from the file toolbar.
6. In the New dialog box:
   • Select Assembly as the Type.
   • Type wheel in the Name field and then click OK.
Assemble the wheel using a Default Constraint, then assemble the tire to the wheel using Automatic to create Insert and Align constraints.

7. Click **Assemble** from the feature toolbar:
8. Select WHEEL.PRT and click **Open** from the Open dialog box.
9. Click in the graphics area to position the part.
10. In the graphics area, right-click and select **Default Constraint** from the pop-up menu.
11. Click **Complete Component**.

The first component of an assembly is typically placed using the **Default Constraint**.

12. Click **Assemble** from the feature toolbar:
13. Select TIRE.PRT and click **Open** from the Open dialog box.
14. Click in the graphics area to position the tire near the wheel.

15. Select the first set of assembly references:
   - Click the inner cylindrical surface of TIRE.PRT.
   - Click the outer cylindrical surface of WHEEL.PRT.

Notice in the dashboard that an **Insert** type constraint was automatically created.
16. Click **Plane Display** to enable their display.

17. Select the second set of assembly references:
   - Mouse over datum plane FRONT from TIRE.PRT and when it prehighlights in blue, click to select it.
   - Mouse over datum plane FRONT from WHEEL.PRT and when it prehighlights in blue, click to select it.
   - Ensure that the offset type shown in the dashboard is **Coincident** and not **Offset**.

   If you select the wrong reference when assembling components, you can use the **Undo** button to backup and re-select. There is no need to cancel the component placement and start over.

18. In the dashboard, select the **Placement** tab. Notice that **Insert** and **Align** type constraints were automatically created based on the references you selected to position TIRE.PRT.

19. Click **Complete Component**.

20. Click **Plane Display** to disable their display.

21. Press **CTRL + D**.

22. Click **Save** and then click **OK** from the Save Object dialog box.

**Step 2:** Assemble the WHEEL.ASM to AXLE_FRONT.ASM.

You will now assemble your wheel assembly to both the front and rear axle assemblies.
1. Click **Open** from the file toolbar.

2. Select AXLE_FRONT.ASM and click **Open**.

3. Click **Assemble** from the feature toolbar:

4. Select WHEEL.ASM and click **Open** from the Open dialog box.

5. Click in the graphics area to position the WHEEL.ASM.

6. Select the first set of assembly references:
   - Middle-click and drag to spin until you can see the back of WHEEL.ASM.
   - Click the cylindrical surface of AXLE.PRT.
   - Click the cylindrical surface of the hole in WHEEL.PRT.

7. Reorient WHEEL.ASM:
   - Right-click and drag while you press **CTRL + ALT** to move WHEEL.ASM away from AXLE_FRONT.ASM.
   - Release the **CTRL + ALT** keys.
   - Middle-click and drag to spin until you can see the bottom of the hole in WHEEL.PRT.
8. Select the second set of assembly references:
   • Click the circular surface at the bottom of the hole in WHEEL.PRT.
   • Middle-click and drag to spin until you can see the end surface of AXLE.PRT.
   • Click the circular surface at the end of AXLE.PRT.
   • Ensure that the offset type shown in the dashboard is **Coincident** and not **Offset**.

The end of the axle should now be mated to the bottom of the hole.
Rather than spinning the model to select the circular surface of the axle, you could have used your Query Select skills to select it. If you want to try, click **Undo** and try again, without spinning the model.

9. Click **Complete Component**.
10. Press **CTRL + D**.
11. Copy and paste a second instance of WHEEL.ASM into the assembly:
   • In the model tree, click WHEEL.ASM.
   • Press CTRL + C to copy.
   • Press CTRL + V to paste.
   • Click in the graphics area to position WHEEL.ASM.
   • Middle-click and drag to spin until you can see the end surface of AXLE.PRT.

Creo Elements/Pro remembers the references selected in WHEEL.ASM the first time you assemble it. The second time, you will only have to select references from AXLE.PRT.

12. Select assembly references from AXLE.PRT:
   • Click the cylindrical surface of AXLE.PRT as the **Insert** reference.
   • If necessary, right-click and drag while you press CTRL + ALT to move WHEEL.ASM away from AXLE.PRT.
   • Click the circular end surface of AXLE.PRT as the **Mate** reference.
   • Click **Complete Component** ✓.
13. Press **CTRL + D**.
14. Click **Save** and then click **OK** from the Save Object dialog box.

**Step 3:** Assemble the WHEEL.ASM to AXLE_REAR.ASM.

1. Click **Open** from the file toolbar.
2. Select AXLE_REAR.ASM and click **Open**.
3. Paste WHEEL.ASM into the AXLE_REAR.ASM:
   - Press **CTRL + V** to paste.
   - Click in the graphics area to position WHEEL.ASM.

   You are able to paste WHEEL.ASM from the previous assembly into this new assembly.

4. Click the cylindrical surface of AXLE.PRT as the **Insert** reference.
5. Select the **Mate** reference from AXLE.PRT:
   - If necessary, right-click and drag while you press **CTRL + ALT** to move WHEEL.ASM away from AXLE.PRT.
   - Click the circular end surface of AXLE.PRT.

6. Click **Complete Component**.

7. Press **CTRL + D**.

8. Paste the second instance of WHEEL.ASM into the assembly:
   - Press **CTRL + V** to paste the component.
   - Click in the graphics area to position WHEEL.ASM.
   - Middle-click and drag to spin until you can see the end surface of AXLE.PRT.

9. Click the cylindrical surface of AXLE.PRT as the **Insert** reference.
10. Select the **Mate** reference from AXLE.PRT:
   - If necessary, right-click and drag while you press **CTRL + ALT** to move WHEEL.ASM away from the AXLE.PRT.
   - Click the circular end surface of AXLE.PRT.
   - Click **Complete Component**.

11. Press **CTRL + D**.

12. Click **Save** and then click **OK** from the Save Object dialog box.

13. Click **File > Backup** and in the Backup dialog box:
   - Browse to the folder **Module_02-06**.
   - Double-click the folder **Submissions**.
   - Double-click the folder **Module04**.
   - Click **OK** to backup the assembly and all components required by the assembly.

---

After you complete this course, files backed up to the Submissions folder will be submitted to PTC Academy so that you can obtain your certification.
Step 4: Open the Aston Martin assembly to see how the new wheels look.

1. Click **Open** from the file toolbar.
2. In the **Common Folders** section of the File Open dialog box, click **Working Directory**.
3. Select **ASTON_MARTIN.ASM** and click **Open**.

   Your new wheels look a little dull on such a hot car, don’t you think? In the next module, you will add some details to make it look much better.

4. Click **Window > Close** until you have closed all of the open windows.
5. Click **File > Erase > Not Displayed**.
6. Click **OK** from the Erase Not Displayed dialog box.

This completes the procedure.
Module Overview

In this module, you will complete the wheel design by adding additional features and then make edits based on your evaluation of the design.

You will first add additional features to make the wheel more esthetically pleasing. Next, you will cut a cross-section through the wheel assembly and take measurement to evaluate its fit to the tire.

Finally, you will make edits to the design and observe that changes made in one mode are automatically updated every other mode of Creo Elements/Pro. For example, a change made in the drawing is automatically propagated to the part and assembly models.

For a more in-depth understanding of the advanced modeling and design tools used in this exercise, see Module 10, Advanced Modeling and Design - References.

Objectives

After completing this module, you will be able to:

- Create a revolve feature.
- Use geometry tools within sketcher.
- Mirror sketcher geometry.
- Create an axial pattern.
- Create a draft feature.
- Create a multi-set round feature.
- Create an reference patterns.
- Create an chamfer feature.
- Apply real time rendering to your model.
- Cut and display a cross-section.
- Use measure tools to evaluate your models.
Advanced Modeling and Design

To complete the wheel design, you will use a variety of advanced features and design tools.

Advanced Features

- Revolve
- Round
- Draft
- Chamfer

Patterns

- Axis Pattern
- Reference Pattern

Cross-Sections

Measuring Tools

Bi-Directional Associativity

Advanced Features

To complete the wheel design, you will use some features you have not yet tried.

- Revolve - A sketched feature in which the sketch is revolved about a centerline or axis in order to add or remove material.
- Draft - Used to apply slope to a surface, typically used in molded or cast parts.
- Round - Add or remove material by creating smooth, usually radial transitions on an edge or between surfaces.
- Chamfer - Add or remove material by creating a beveled surface on an edge or between surfaces.
Patterns

The Pattern tool enables you to quickly duplicate a feature within your model. In this exercise, you will learn to pattern about an axis using the Axis type pattern. You will also use the Reference pattern to create patterns where a feature follows the pattern of a feature it references.

Cross-Sections

You will cut a cross-section through the wheel assembly so that you can visually inspect the fit of the tire to the wheel. The display of Cross-sections can be toggled on and off in the part, assembly or drawing.

Measuring Tools

You will use Creo Elements/Pro’s measuring tools to analyze the size and fit of your models. Values obtained from the measuring tools to edit the wheel so that it fits the tire correctly.

Bi-Directional Associativity

You will make edits to your design in both the part and drawing modes. You will then observe that because of bi-directional associativity, a change made anywhere is updated everywhere.
PROCEDURE - Advanced Modeling and Design

Scenario
The marketing group called and they said your wheel is too plain to be put on their Aston Martin slot car. They have a point.

In this exercise you will add additional features to improve on the look and feel of the design. You will cut a cross-section through the wheel assembly so that you can verify the fit and function of the design both visually and using the measurement tools. Based on measurements taken, you will edit your design so that it not only looks better but functions better.

In the subsequent exercise, you will create a photo realistic rendering of the completed design.

Step 1: Open the Aston Martin assembly.

1. If necessary, start Creo Elements/Pro.
2. Click **File > Set Working Directory**.
3. In the Select Working Directory dialog box:
   - Browse to the folder *Intro_Creo_ElementsPro*.
   - Double-click the folder *Module_02-06*.
   - Double-click the folder *Advanced*.
   - Click **OK**.
4. Use the datum display toolbar at the top of the interface to ensure the display of all datum features are disabled.
5. Click **Open** from the file toolbar.
6. Select *ASTON_MARTIN.ASM* and click **Open**.

Your new wheels look a little dull on such a hot car, don’t you think? Let’s add some details to make them look better.
Step 2: Remove material using the Revolve tool.

1. In the graphics area, click to select any one of the WHEEL.PRT models from ASTON_MARTIN.ASM.
2. With WHEEL.PRT selected, right-click in the graphics area and select Open from the pop-up menu.
3. Start the Revolve Tool from the feature toolbar.
4. Select and orient the sketch plane:
   - Right-click in the graphics area and select Define Internal Sketch.
   - In the model tree, click datum plane TOP as the Sketch Plane.
   - In the Sketch dialog box, select Top from the Orientation drop-down list (it is currently set to Bottom).
   - Click Sketch from the Sketch dialog box.

If you forgot to select Top from the Orient drop-down list, click Sketch > Sketch Setup and select it now. Click Sketch from the Sketch dialog box when finished.

5. Click Hidden line from the main toolbar.
6. Click Axis Display to enable their display.

7. Click Zoom In to zoom in to the upper left corner of the model:
   - Click at X1 to define the upper-left corner of the zoom box.
   - Click at X2 to define the lower-right corner of the zoom box.
   - Middle-click to release the zoom in tool.
8. Click **Sketch > References** from the menus at the top of the interface.

9. Click the top edge of the model shown as $X_1$ and then click **Close** from the References dialog box.

10. Right-click in the graphics area and select **Centerline** from the pop-up menu.
    - Click at $X_1$ to place the start point of the centerline.
    - Click at $X_2$ to place the endpoint of centerline.
    - Middle-click to release the centerline tool.
11. Click **3-Point / Tangent End Arc** from the sketcher toolbar:
   - Click below the centerline at X1 to place the start point of the arc on the vertical reference.
   - Click on the center line at X2 to place the endpoint of the arc on the centerline.
   - Move your mouse to size the arc, then click at X3 to place the arc.
   - Middle-click to release the arc tool.

12. If a T is not displayed at X2, add the **Tangent** constraint manually:
   - Press and hold CTRL, then click to select both the arc and horizontal centerline.
   - Release CTRL, then right-click and select **Tangent** from the pop-up menu.

13. Click **Normal Dimension** from the sketcher toolbar:
14. Place and edit a dimension defining the centerline placement:
   - Click the horizontal reference line, X1.
   - Click the centerline, X2.
   - Middle-click at X3 to place the dimension.
   - Edit the value of the dimension to .5 and press ENTER.
15. Middle-click to release the dimension tool.

16. Double-click the radius dimension, edit it to 25, and press ENTER.

You may have to zoom out in order to see the radius dimension.

17. Click in the graphics area to deselect the dimension.

18. Right-click in the graphics area and select Line from the pop-up menu.
   - Click to snap the start point of the line to the endpoint of the arc, shown as X1.
   - Click to snap the endpoint along the top reference edge, at approximately a 45° angle, shown as X2.
   - Middle-click to release the line tool.

19. Click Normal Dimension from the sketcher toolbar:

20. Place and edit dimension defining the upper endpoint of the line:
   - Click the vertical reference line, X1.
   - Click the upper endpoint of the line, X2.
   - Middle-click at X3 to place the dimension.
   - Edit the value of the dimension to .3 and press ENTER.
21. Place and edit the dimension defining the lower endpoint of the line:
   • Click the vertical reference line, X1.
   • Click the lower endpoint of the line, X2.
   • Middle-click at X3 to place the dimension.
   • Edit the value of the dimension to \( \frac{1}{2} \) and press ENTER.

22. Click **Done Section**.

23. Press **CTRL + D** to place the model in a default orientation.

24. Click **Shading** from the main toolbar.

25. In the graphics area, click datum axis A_1 as the **Rotate** axis.

26. In the dashboard, click **Remove Material**.

27. If necessary, click the yellow material side arrow so that it is pointing out, away from the model.

28. Click **Complete Feature**.

If you forgot to change the material side of the feature in step 26, right-click Revolve 1, and select **Edit Definition** from the pop-up menu. This will open the dashboard for that feature enabling you to correct it.

29. Click **Axis Display** to disable their display.

30. Press **CTRL + D**.

31. Click **Save** and then click **OK** from the Save Object dialog box.
**Step 3:** Extrude and pattern spokes in the wheel.

1. Start the **Extrude Tool**.
2. Click **Hidden line** so that you can easily see and reference hidden geometry while sketching.

3. Select and orient the Sketch Plane you will be sketching on:
   - Right-click in the graphics area and select **Define Internal Sketch**.
   - In the model tree, click datum plane FRONT.
   - Click **Sketch** from the Sketch dialog box.

4. Click **Use Edge** and click the hidden line shown. This is the third circle from the center of the model.

5. Right-click in the graphics area and click **Centerline** from the pop-up menu.
   - Click at **X1** to snap the start point of the centerline to the vertical reference.
   - Click at **X2** to snap the endpoint to the vertical reference.
   - Middle-click to release the centerline tool.

6. Click **Center and Point Circle**:
   - Click at **X1** to snap the center of the circle to the center of the model.
   - Drag your mouse and click at **X2** to complete the circle.
   - Middle-click to release the circle tool.
7. Double-click the diameter dimension, edit the value to 5 and press ENTER.

8. Click in an empty area of the graphics area to deselect the diameter dimension.

9. Right-click in the graphics area and click Line from the pop-up menu.
   - Click at X1 to snap the start point of the line to the center of the model.
   - Click at X2 to snap the endpoint of the line to the upper arc.
   - Middle-click to release the line tool.

10. With the new line still clicked, click Edit > Mirror from the main menu, then click the vertical centerline as the mirror reference.

11. Delete extra sketcher geometry, leaving only the two sketched lines and arcs to be extruded:
   - Click Trim/Delete Segment \(\text{□} \) from the sketcher toolbar.
   - In the graphics area, hold down the left mouse button and drag over the sketcher geometry marked by an X.

   This does not have to be completed as one step, each time you release your mouse button, clicked geometry is deleted. The only sketch entities that should remain are two lines and 2 arcs.

12. Verify that the sketch is a single closed:
   - Middle-click to release the Trim/Delete Segment \(\text{□} \) tool.
   - In the sketcher diagnostics toolbar located in the top-right corner of the interface, click Shade Closed Loops \(\text{□}\).
13. Click **Normal Dimension** from the sketcher toolbar:
   - Click each angled line, X1 and X2.
   - Middle-click between the lines at X3 to place the dimension.
   - Edit the angle dimensions value to 25 and press ENTER.

14. Click **Done Section**.

15. Press **CTRL + D** and then click **Shading**.

16. In the graphics area:
   - Right-click and select **Remove Material** from the pop-up menu.
   - Right-click on the depth drag handle (small white box) and select **Through All** from the pop-up menu.

17. Click **Complete Feature**.

As you can see from the steps above, many of the options you have been selecting in the dashboard are also accessible using right–click pop-up menus in the graphics area.
18. With **Extrude 5** still selected, click **Edit > Pattern**.

19. Click **Axis Display** to enable their display.

20. In the pattern dashboard:
   - Click **Dimension** and select **Axis** from the drop-down list.
   - Click axis A_1 from the model.
   - Edit the number of pattern instances from 4 to 6.
   - Click **Pattern Grid Rotation** to evenly space the distance between instances of the pattern.

21. Click **Axis Display** to disable their display.

22. Click **Complete Feature**.

---

**Step 4:** Add an outer hub to the wheel using an extrude feature.

1. If necessary, press **CTRL + D**.
2. Start the **Extrude Tool**.
3. Right-click in the graphics area and select **Define Internal Sketch**.
4. Move your mouse over the model face closest to you, when it pre-highlights, click to select it as the Sketch Plane.
5. Click **Sketch** from the Sketch dialog box.
6. Click **Center and Point Circle** and place a circle at the center of the model.

7. Edit the diameter to 2 and press **ENTER**.

8. Click **Done Section**.

9. Click **Named View List** and select **Default Orientation** from the drop-down list.

10. In the graphics area, click the yellow direction arrow to flip the extrude direction back into the model.

11. In the dashboard, edit the depth from **Blind** to **To Next**.

12. Click **Complete Feature**.

**Step 5:** Add draft to the cylindrical surface of the hub.

1. If necessary, press **CTRL + D**.

2. Start the **Draft Tool** from the feature toolbar.

3. Move your mouse over the cylindrical surface of the hub, when it pre-highlights, click to select it as the draft surface.
4. In the graphics area, right-click and select **Draft Hinges** from the pop-up menu.

5. Move your mouse over the circular surface of the hub and when it pre-highlights, click at X1 to select the surface (do not click an edge). This is the Draft Hinge reference.

6. In the draft dashboard:
   - Edit the draft angle to 10 and press ENTER.
   - Click **Reverse Angle** so that geometry expands from the hinge surface down to the bottom of the hub.
   - Click **Complete Feature**.

7. Press **CTRL + D**.

8. Click **Save** and then click **OK** from the Save Object dialog box.
Step 6: Round the edges of the wheel spokes.

1. In the model tree, expand **Pattern 1 of Extrude 5** and click **Extrude 5[1]** to identify the first instance of the pattern. This is where you will place the next round feature.

2. Middle-click and drag to spin the model until you can see the upper surface of the first spoke.

3. Start the **Round Tool** from the feature toolbar.

4. Move your mouse over the edge shown as X1 and click to select it.

5. Press and hold CTRL while you select the edge shown as X2.

6. Edit the radius value to .75 and press ENTER.

7. Press CTRL + D.

8. Move your mouse over the edge shown as X1 and click to select it.

9. Press and hold CTRL while you select the edge shown as X2.

10. Edit the radius value to .6 and press ENTER.

11. In the round dashboard:
   - Select the **Sets** tab.
   - Click **Set 1** and then **Set 2** to observe the two round sets you have defined within the one round feature.
   - Click **Complete Feature**.
12. With Round 1 still selected, click Edit > Pattern.

The default pattern type is now Reference. This pattern will reference the pattern of the spokes.

13. Click Complete Feature ✓.

14. If necessary, press CTRL + D.

15. If necessary, in the model tree, expand Pattern 1 of Extrude 5 and click Extrude 5[1] to identify the first instance of the pattern. This is where you will place the next round feature.


17. Click the edge shown.

18. Edit the radius value to .1 and press ENTER.

19. Click Complete Feature ✓.

20. With Round 2 still selected, right-click in the graphics area and select Pattern from the pop-up menu.

21. Click Complete Feature ✓.
Step 7: Add a two edge round feature in the hub area.

1. If necessary, press **CTRL + D**.
2. Start the **Round Tool**.
3. Press and hold **CTRL** while you select the two edges shown.
4. Edit the radius value to .3 and press ENTER.
5. Click **Complete Feature**.

Step 8: Add a round along the inner edge of the wheel.

1. Press **CTRL + D** then zoom in as required.
2. Start the **Round Tool**.
3. Click the edge shown.
4. Edit the radius value to .1 and press ENTER.
5. Click **Complete Feature**.

Step 9: Add a chamfer to break the edge of the axle hole.

1. Middle-click and drag to spin the model until you can view the back of the model.
2. Start the **Edge Chamfer Tool** from the feature toolbar:
3. Click the inner edge of the hole as shown.
4. Edit the chamfer D value to .3 and press ENTER.
5. Click **Complete Feature**.
6. Press **CTRL + D**.

7. Click **Enhanced Realism** to toggle on real time rendering.

8. Middle-click and drag to spin and admire your completed wheel.

9. Click **Save** and then click **OK** from the Save Object dialog box.

10. Click **Open** from the file toolbar.

11. Select **ASTON_MARTIN.ASM** and click **Open**.

12. Middle-click and drag to spin the car assembly.

Now that you have added the additional details, your wheel looks a lot better on the Aston Martin!

13. Click **Enhanced Realism** to toggle off real time rendering.

14. Click **Save** and then click **OK** from the Save Object dialog box.
Step 10: Create a cross section to verify the fit between the wheel and tire.

1. In the graphics area, click to select any of the four WHEEL.PRT models.
2. With WHEEL.PRT selected, right-click in the graphics area and select Select Parent from the pop-up menu. This will select the parent assembly WHEEL.ASM.
3. With WHEEL.ASM selected, right-click in the graphics area and select Open.

4. Click View Manager from the view toolbar.
5. From the View Manager dialog box:
   - Select the Xsec tab.
   - Click New.
   - Type A as the cross section name and press ENTER.
   - Click Done from the Menu Manager in the lower-right of the interface.
   - In the model tree, select datum plane ASM_RIGHT.
   - Double-click cross section A from the Names list.
   - Click Close.

6. Click Named View List from the view toolbar and select Right from the drop-down list.
It appears that you have a few design issues. The diameter of the wheel is too big and the outer cylinder of the wheel is not wide enough. Let's go investigate and fix the issues.

7. Click **Analysis > Measure > Length** from the main toolbar.
8. Click the inner edge of the tire as shown.

This measurement shows that the width of the outer wheel cylinder should be edited to 7.

9. Click **Analysis > Measure > Diameter** from the main toolbar.
10. Put your mouse over the surface of the tire shown, when it pre-highlights, click to select it.

This measurement shows that the minor diameter of the wheel should be edited to 15.15.

11. Click **Cancel** to close the Distance dialog box.
Step 11: Edit the wheel to fit the tire.

1. Press **CTRL + D**.
2. In the model tree, expand the WHEEL.PRT node:
   - Right-click **Extrude 1** and select **Edit** from the pop-up menu.
   - Move your mouse over the 4.5 dimension value, when it pre-highlights, double click it.
   - Type the new value 7 and press ENTER
   - Click **Regenerate Model** from the edit toolbar to update the model using the new dimension value.

3. In the model tree with the WHEEL.PRT node still expanded:
   - Right-click **Extrude 2** and select **Edit** from the pop-up menu.
   - Double-click the 15.6 dimension value, edit it to **15.15** and press ENTER.
   - Click **Regenerate Model** to update the model.

You have received info from the marketing team, they think the wheel needs more spokes. Also, the engineering team thinks the wheel is be too heavy.
4. Click **View Manager** from the view toolbar.

5. From the **Xsec** tab of the View Manager dialog box:
   - Right-click **No Cross Section** from the Names list.
   - Select **Set Active** from the pop-up menu.
   - Click **Close**.

   You can set cross sections active by double-clicking or selecting **Set Active** from the pop-up menu.

6. In the model tree with the WHEEL.PRT node still expanded:
   - Right-click **Pattern 1 of Extrude 5** and select **Edit** from the pop-up menu.
   - Double-click the pattern value 6, shown as **6 EXTRUDES**.
   - Edit the value to **10** and press **ENTER**.
   - Click **Regenerate Model** to update the model.

7. From the main menu, click **Window** and select **ASTON_MARTIN.ASM** from the drop-down list, to activate the window.

8. Click **Named View List** from the view toolbar and select **Front** from the drop-down list.

   Our engineers are worried that the wheel base looks a little too narrow, lets go fix that.
Step 12: Edit the length of the wheel hub from the drawing.

1. Click Open from the file toolbar.
2. Select WHEEL.DRW and click Open.

Because Creo Elements/Pro is bi-directionally associative, all edits made in WHEEL.PRT are automatically updated in the drawing. Just as you have seen edits automatically updated in ASTON_MARTIN.ASM.

3. Select the Annotate tab from the drawing interface.
4. Locate the dimension value 1 used to offset the sketch plane of Extrude 4.
5. Click the dimension to select it.
6. With the dimension selected, pre-highlight and then double click the value 1, edit it to 4 and press ENTER.
7. Press CTRL + G to regenerate the model using the new value.

All views of the drawing have updated according to your edit.
8. Click **File > Backup** and in the Backup dialog box:
   - Browse to the folder **Module_02-06**.
   - Double-click the folder **Submissions**.
   - Double-click the folder **Module05**.
   - Click **OK** to backup the drawing and all files required by the drawing.

After you complete this course, files backed up to the Submissions folder will be submitted to PTC Academy so that you can obtain your certification.

9. From the main menu, click **Window** and select **ASTON_MARTIN.ASM** from the drop-down list, to activate the window.

10. Click **Regenerate Model** to update the model.
11. Click **Save** and then click **OK** from the Save Object dialog box.
12. Click **Window > Close** until you have closed all of the open windows.
13. Click **File > Erase > Not Displayed.**
14. Click **OK** from the Erase Not Displayed dialog box.

Congratulations! You have completed the design of the Aston Matin wheel. In the next module, you will create a photorealistic image of the car using render capabilities within Creo Elements/Pro.

This completes the procedure.
Module 6

Photorealistic Rendering

Module Overview

Photorealistic images are a great way to let others see and evaluate the esthetics of your design. Images rendered from models in Creo Elements/Pro can also be used in catalogs or marketing materials.

In this module, you will learn to assign material specific appearances to a model, place that mode in a room and defined scene. Finally you will learn to render and output the photorealistic image you create.

Objectives

After completing this module, you will be able to:
• Assign an appearance or color to a model.
• Define the scene and room that a model will be rendered in
• Render a photorealistic image of a model.
• Output a rendered image to a graphics file.
Photorealistic Rendering

There are four basic steps to creating a photorealistic image in Creo Elements/Pro:

1 - Assign Appearances
2 - Define the Scene
3 - Set the Render Output
4 - Render the Scene

Assign Appearances

The Appearance Gallery dialog box allows you to view, search, and assign available appearances to a model. You can assign or set appearances to an entire part, individual surfaces or quilts. In the assembly mode, you can assign an appearance to the entire assembly, active individual components or parts in the assembly.

Define the Scene

A scene file is a collection of render settings applied to a model. These settings include lights, rooms, and environment effects.

You can save only one scene with the model. When you reload the model from its location, the scene that is saved with the model is activated.

Room and lights within the scenes scale parametrically, depending on the size of the model to which the scene is applied. The room is automatically resized or the position of the lights change making the scene reusable with any kind of geometry.
Set the Render Output

By default, Creo Elements/Pro will render to the Full Window of the graphics area. Other outputs types such as Tiff, RGB, JPEG, and so on can be set as the render output.

You can set and save the output type of a rendered model from the Render Setup dialog box.

Render the Scene

After appearances have been applied, the scene defined, and the output type set, you can render a model by clicking View > Render Window.

The quality of the render can be set in the Render Setup dialog box. The default option is Draft but the quality should be set to High or Maximum for quality outputs.

💡 As you increase the quality of the render, you also increase the time required to complete the render. Setting the quality level to Maximum will create an even higher quality image, however, it may take too long to complete on some lower-end computers.
PROCEDURE - Photorealistic Rendering

Scenario

Now that the design of your wheel is complete, it’s time to create photorealistic images you can send to the marketing group!

In this exercise you will assign material specific appearances to both the wheel and time. You will then create a photorealistic rendering of the wheel assembly. Finally, you will create a photorealistic rendering of the top level Aston Martin slot car assembly.

Step 1: Set your working directory and open WHEEL.ASM.

1. If necessary, start Creo Elements/Pro.
2. Click File > Set Working Directory.
3. In the Select Working Directory dialog box:
   • Browse to the folder Intro_Creo_ElementsPro.
   • Double-click the folder Module_02-06.
   • Double-click the folder Render.
   • Click OK.
4. Use the datum display toolbar at the top of the interface to ensure the display of all datum features are disabled.
5. Click Open from the file toolbar.
6. Select WHEEL.ASM and click Open.
7. Click Enhanced Realism to toggle on real time rendering and get a quick preview of the rendered wheel assembly.
**Step 2:** Apply a chrome appearance to WHEEL.PRT.

The wheel model was created using the default Creo Elements/Pro grayish-blue color. It will look much better in the final rendering if you apply a chrome appearance from the appearance gallery.

1. Click **Enhanced Realism** to toggle off real time rendering.
2. Click **Appearance Gallery** from the main toolbar (the small down arrow next to the grey ball).

3. In the **Library** section of the Appearance dialog box, navigate to select **adv-metal-chrome.dmt** from the Photolux Library:
   - Click **metals.dmt** (X1).
   - Ensure the **Photolux Library** folder is open (X2).
   - Click to expand the **Metals** folder node (X3).
   - Scroll as required and click **adv-metal-chrome.dmt** (X4).

4. Click to select **adv-chrom-plate** from the **Library** section of the Appearance dialog box.

The active appearance shown in the main toolbar is now the **adv-chrom-plate** appearance.
5. Move your mouse over WHEEL.PRT and when it prehighlights, click to select it.

6. Click OK from the Select dialog to apply the appearance.

   The true chrome shine will be displayed when the model is rendered.

---

**Step 3:**  Apply a matted black rubber appearance to TIRE.PRT.

The tire looks a little light and shiny. Apply a matted black rubber appearance from the appearance gallery.

1. Click Appearance Gallery from the main toolbar.

2. In the Library section of the Appearance dialog box, navigate to select adv-rubber.dmt.
   - adv-rubber.dmt is found in the Misc folder of the Photolux Library.

3. Click to select adv-rubber-matte-black.

   The active appearance shown in the main toolbar is now the adv-rubber-matte-black appearance.
4. Move your mouse over TIRE.PRT and when it prehighlights, click to select it.

5. Click **OK** from the Select dialog to apply the appearance.

**Step 4:** Set the wheel assembly into a scene and room.

1. Click **View > Model Setup > Scene** from the main menu.

2. In the Scene Gallery section of the **Scene** tab:
   - Click to select the scene **Photolux-Studio-Soft**.
   - Right-click **Photolux-Studio-Soft** and select **Activate** from the pop-up menu.

3. With the Scenes dialog box still open, click the **Room** tab.
   - In the Size section of the tab, click **Align Floor Against Model**.

The floor is now snapped to the lowest geometry on the model.

4. Zoom out until you can see the round floor of the room.
   - Press and hold **CTRL**, then middle-click and drag upward to zoom out.
5. Use spin, pan, and zoom tools to orient your model to an orientation you want to render:
   - Middle-click and drag to spin.
   - Press and hold SHIFT, then middle-click and drag to pan.
   - Press and hold CTRL, then middle-click and drag to zoom.
6. Click Close from the Scenes dialog box.

Step 5: Render the wheel assembly and output an image file.

1. Click View > Render Window from the main menu.

   The wheel has been rendered using the Draft quality settings.

2. Click View > Model Setup > Render Setup from the main menu.

3. In the Render Setup dialog box:
   - Click the Quality setting Draft and select High from the drop-down list.
   - Click the Output tab.
   - In the Render To drop-down list, select JPEG.
   - Click Close.

4. Click View > Render Window from the main menu.

Because the output was set to JPEG, a file named WHEEL.JPG was written to your working directory. Also notice that the window was not rendered, only the JPEG file was created and saved.
5. In the Render Setup dialog box:
   • Click the **Output** tab.
   • In the **Render To** drop-down list, select **FULL WINDOW**.
   • Click **Close**.

6. Click **View > Render Window** from the main menu.

As you increase the quality of the render, you also increase the time required to complete the render. Setting the quality level to **Maximum** will create an even higher quality image, however, it may take too long to complete on some lower-end computers.

7. Click **Save** and then click **OK** from the Save Object dialog box.

8. Click **Window > Close** until you have closed all of the open windows.

**Step 6:** Set the Aston Martin assembly into a scene and render it.

1. Click **Open**.
2. Select **ASTON_MARTIN.ASM** and click **Open**.
3. In the model tree, right click on **SLOT_GUIDE.ASM** and select **Representation > Exclude**.

We have temporarily excluded **SLOT_GUIDE.ASM** so that the floor of our room will be automatically moved to the bottom of the tires rather than the bottom of the slot guide.
4. Click View > Model Setup > Scene from the main menu.

5. In the Scene Gallery section of the Scene tab:
   • Click to select the scene Photolux-Studio-Soft.
   • Right-click Photolux-Studio-Soft and select Activate from the pop-up menu.

6. Click the Room tab in the Scenes dialog box.
   • In the Size section of the tab, click Align Floor Against Model.

The floor is now snapped to the bottom of the tires.

7. Zoom out until you can see the round floor of the room.

8. Click Close from the Scenes dialog box.
9. Use spin, pan, and zoom tools to orient your model to an orientation you want to render:
   • Middle-click and drag to spin.
   • Press and hold SHIFT, then middle-click and drag to pan.
   • Press and hold CTRL, then middle-click and drag to zoom.

10. Click **View > Render Window** from the main menu.
**Step 7:** Save the rendered image and then save and close the models.

1. Click **File > Save a Copy** to open the Save a Copy dialog box:
   - Browse to the folder **Module_02-06**.
   - Double-click the folder **Submissions**.
   - Double-click the folder **Module06**.
   - Click **JPEG (*.jpg)** from the Type drop-down list.
   - Click **OK** to save the JPEG file.

After you complete this course, files backed up to the Submissions folder will be submitted to PTC Academy so that you can obtain your certification.

2. Click **Save** and then click **OK** from the Save Object dialog box.
3. Click **Window > Close** until you have closed all of the open windows.
4. Click **File > Erase > Not Displayed**.
5. Click **OK** from the Erase Not Displayed dialog box.

Congratulations! You have completed the rendering exercise for the Aston Martin slot car.

This completes the procedure.
Module 7

Basic Part Modeling - References

Module Overview
This module contains a set of reference topics intended to give you a more in-depth understanding of the functionality used in the Basic Part Modeling exercise of Module 2.

Objectives
After completing this module, you will be able to:
• Understand sketcher theory.
• Understand sketcher setup and orientation.
• Create sketch features.
• Create internal sketches.
• Sketch lines, circles and centerlines.
• Dimension entities within sketcher.
• Modify dimensions within sketcher.
• Create solid extrude features.
• Understand common dashboard options of the extrude feature.
• Create coaxial holes.
• Create linear holes.
• Understand common dashboard options of the hole feature.
• Understand and create datum features.
• Use sketcher to define an extruded shape.
• Create extrude features.
• Create hole features.
• Create datum planes.
Reviewing Sketcher Theory

A sketch is a 2-D entity that graphically captures an idea with lines, constraints, and dimensions.

2-D sketches are:
- Placed on a 3-D model.
- Used to create solid features.

In Creo Elements/Pro, you use the 2-D Sketcher mode to capture your engineering idea. You sketch your idea using various types of lines which are then trimmed, constrained, dimensioned, and modified accordingly. An example of a sketch is shown in the upper-right figure.

This 2-D sketch is then placed into a 3-D model, as shown in the lower-right figure. Once the sketch is placed, it can be used to create solid features, as shown in the figures on the left. Notice that the same sketch can be used to create two completely different types of geometry.
Specifying the Sketch Setup

The Sketch Setup determines the sketching plane and the model's orientation in the graphics area.

- Sketch Setup consists of:
  - Sketch Plane
  - Sketch Orientation
    - Reference
    - Direction
- Model orientation helps determine initial sketch setup.
- Use Sketch Orientation to orient the sketch parallel to the screen.

Specifying the Sketch Setup Theory

When you create a sketch feature, the Sketch Setup is used to tell Creo Elements/Pro which plane the sketch feature will be created on and how it will be oriented:

- Sketch Plane — The 2-D sketch exists in this planar reference. The sketching plane can be either a datum plane or a planar surface of an existing solid or surface feature. If you create more than one sketch on the same sketch plane, you can click Use Previous in the Sketch dialog box to use the previous sketch feature's sketch setup.
- Sketch Orientation — Determines how the sketch will be oriented in the graphics area and model. Sketch orientation consists of two items:
  - Orientation Reference — The orientation reference determines the 2-D orientation of the sketch. This reference is also either a datum plane or a planar surface and must be normal to the sketch plane.
Orientation Direction — Determines the direction that the orientation reference faces. The orientation reference can be assigned to face top, bottom, right, or left. These directions are named to reflect how the reference orients with regard to the Creo Elements/Pro graphics area. Note that datum planes have two sides, brown and gray, and that the brown, or positive side, orients to the selected direction.

When you specify a sketch plane, the default orientation reference and orientation direction are determined based on the model's orientation in the graphics area when you entered the sketch setup.

Different combinations of selected orientation reference and orientation direction will yield the same sketch orientation in the graphics area. In the lower-left figure, the datum plane RIGHT could be selected as the Orientation Reference to face right to yield the same result. You can also reverse the sketch orientation by clicking Flip from the Sketch dialog box. If ever you reorient the model while sketching, you can click Sketch Orientation to return the sketch parallel to the screen.

When you start a new sketch feature you are required to specify the sketch setup. However, once you are creating the sketch feature you can always reenter sketch setup by clicking Sketch > Sketch Setup from the main menu.
Creating Sketches ('Sketch' Feature)

To create a Sketch Feature, specify the Sketch Setup, select additional sketch references, and sketch the geometry.

- You can modify the Sketch Setup.
- You can use references to snap geometry or dimensions.
- You can create 3-D geometry by using the Sketch feature.
- Feature requirements.

Specifying Sketch Setup

Sketch Geometry Snapped to Added Reference

Creating Sketches ('Sketch' Feature) Theory

You can create a sketch feature by starting the Sketch Tool from the feature toolbar. Creating a sketch feature involves the following three steps:

- Specify the sketch setup. Once the sketch setup has been defined, you can always change it to another plane.
- Select additional sketch references that you intend to dimension from or snap to with sketch geometry. For example, in the lower-right figure, some of the existing geometry was specified as sketch references for a new Sketch feature.
- Sketch the geometry.

Sketch Feature Requirements

The following rules apply to sketched sections when creating sketch features:

- A sketched section should not contain any “gaps,” or open ends.
- A sketch cannot contain any overlapping entities.
• An open section sketch is required for creating a rib feature.
• All loops of a multiple loop section must be closed.
• When creating a revolve feature, you must only sketch geometry on one side of the centerline.
Creating Internal Sketches

An internal sketch is contained in the feature it defines.

- Internal sketch benefits:
  - Organization
  - Reduced Feature Count
- External sketch benefits:
  - Same sketch can be used for multiple features
  - Can be unlinked

Internal Versus External Sketches

Internal Sketches

You are given the choice of using either internal or external sketches in Creo Elements/Pro.

PTC does not recommend one type of sketch over the other; you should use the type that works best for you. In this topic, we discuss how to use internal sketches and some of the benefits they can provide.

Creating an Internal Sketch

Internal sketches are created during the creation of any sketched feature.

- Start the feature tool for any sketched feature (for example, Extrude Tool).
- Click Define from the Placement tab in the dashboard and create a sketch. You can also right-click and select Define Internal Sketch to enter Sketcher.
- Complete the feature and an internal sketch with the name S2D000# is created and embedded within the feature.

Pros and Cons of Internal Sketches

Internal sketches provide some benefits that external sketches do not.
• **Organization** — Because internal sketches are embedded in the feature they define, you always know where to find them. External sketches are separate features that can be renamed and reordered like other features. In a model containing hundreds of features, it can take some time to determine which sketch is used to define which feature. This is not a problem, just something to be aware of when selecting the type of sketch you will use.

• **Reduced Feature Count** — Because internal sketches are not features, they do not add to the total number of features in a model. Creating a separate external sketch for every sketched feature in your model can dramatically increase the number of features in a model. In models containing hundreds or even thousands of features, external sketches can dramatically increase the total feature count in a model. Again, this is something you will want to consider when selecting the type of sketch you will use.

**Pros and Cons of External Sketches**

External sketches provide some benefits that internal sketches do not.

• You can always redefine an external sketch to internal.
• You can select a different sketch for the same feature.
• The same external sketch can be specified for multiple features.
• You can unlink a specified external sketch.
• External sketches result in a higher feature count because there is an additional sketch feature for every sketched feature as displayed in the model tree.
Sketching Lines

Sketched entities are the basis for a solid face or surface of a 3-D model.

- There are two types of lines:
  - 2 Point Line
  - 2 Tangent Line

There are two main types of lines available in Sketcher:

- 2 Point Line — Click **Line** from the Sketcher toolbar or right-click and select **Line** to create a line between two points. Each time you click the mouse you start a line point or endpoint. You can continue clicking the mouse to create lines that are chained together. That is, the endpoint of one line is the starting point of the next line. You can either middle-click or select another function from the Sketcher toolbar to terminate line creation.

- 2 Tangent Line — Click **Line Tangent** from the Sketcher toolbar to create a line that is tangent to two circles, two arcs, or a circle and arc. You can only select arcs or circles when creating a 2 Tangent Line.
Sketching Circles

- There are four types of Circles:
  - Center and Point
  - Concentric
  - 3 Point
  - Tangent to 3 Entities

Concentric Circle

Circle Tangent to 3 Entities

Circle Created by Picking 3 Points

Sketching Circles

There are four types of circles available in Sketcher:

- Center and Point — Click **Center and Point Circle** from the Sketcher toolbar and select the location for the center and a location that determines the diameter. You can also right-click and select **Circle**.

- Concentric — Click **Concentric Circle** from the Sketcher toolbar to create a circle that is concentric about an existing circle or arc.

- 3 Point — Click **3 Point Circle** from the Sketcher toolbar and select three locations that the circle must pass through.

- Tangent to 3 Entities — Click **3 Tangent Circle** from the Sketcher toolbar and select three arcs, circles, or lines that the circle must be tangent to.
Sketching Centerlines

A centerline is a type of construction geometry that can be used to enforce symmetry and control sketch geometry.

- There are two types of construction Centerlines:
  - Centerline
  - 2 Tangent Centerline

Symmetry Created using Centerline

Dimensioning a Circle without a Centerline

Dimensioning a Circle using a Centerline

Sketching Centerlines

A centerline is a type of construction geometry that can be used to define a line of symmetry with a sketch. They are also used to control sketch geometry. In the lower-left figure the circle is dimensioned to the vertical and horizontal references. In the lower-right figure the circle is dimensioned radially by using a centerline. Centerlines must be fully constrained by using dimensions or constraints like any other sketched entity. They have infinite length and do not create feature geometry.

There are two types of construction Centerlines:

- Centerline — Click **Centerline** from the Sketcher toolbar or right-click and select **Centerline** to create a Centerline through two points.
- 2 Tangent Centerline — Click **Sketch > Line > Centerline Tangent** from the main menu to create a centerline that is tangent to two circles, two arcs, or a circle and arc. You can only select arcs or circles when creating a 2 Tangent Centerline.
Dimensioning Entities within Sketcher

How you dimension your sketch will reflect your design intent.

- Dimension types include:
  - Line length
  - Angle
  - Distance
  - Radius
  - Diameter
  - Revolved Diameter
  - Arc length
  - Included angle
- Middle-click to place dimensions.
  - Location can determine type.
- Convert weak dimensions to strong.

Dimensioning Entities within Sketcher Theory

When dimensioning a sketch, it is important to create dimensions that capture your design intent because these dimensions are displayed when you edit the model and when you create drawings of the model.

Dimensions are all created using the Normal Dimension icon. You can also right-click and select Dimension. Select entities to be dimensioned and middle-click to place the dimension. At this point you can either press ENTER to accept the current dimension value, or type a different one and press ENTER. The type of dimension created depends upon what is selected and where the dimension is placed.

The following dimension types can be created:

- Line length — Select a line and place the dimension. The line length is dimensioned.
- Angle — You can create an angle measurement by selecting two linear references. Where you place the dimension determines how the angle is measured (acute versus obtuse). You can also create an arc angle by
selecting an arc endpoint, the arc center, and the other endpoint, and then placing the dimension.

- **Distance** — Select two entities to measure the distance between and place the dimension. Again, where you place the dimension will determine whether it is vertical, horizontal, or slanted. The Dim Orientation dialog box enables you to determine whether the dimension is to be vertical or horizontal.

- **Radius** — Select an arc or circle once, then place the dimension. You can toggle a radius dimension to a diameter or linear dimension by right-clicking and selecting **Convert to Diameter** and **Convert to Linear**, respectively.

- **Diameter** — Double-click an arc or circle, then place the dimension. You can toggle a diameter dimension to a radius or linear dimension by right-clicking and selecting **Convert to Radius** and **Convert to Linear**, respectively.

- **Revolved Diameter** — Select the entity, a centerline, and the entity again and place the dimension. Alternatively, you can select the centerline, the entity, and the centerline again.

- **Arc length** — You can create an arc length dimension by selecting the arc segment, its two endpoints, and placing the dimension. The arc length dimension displays an arch symbol over the dimension value. You can toggle the arc length measurement to an arc angle dimension and vice-versa by right-clicking and selecting **Convert to Angle** and **Convert to Length**, respectively.

- **Included angle** — Similar to a revolved diameter dimension, you can create an included angle dimension by selecting an angled line, a centerline, and the angled line again before placing the dimension. You can toggle the included angle to an angle dimension and vice-versa by right-clicking and selecting **Convert to Angle** and **Convert to Total included angle**, respectively.

**Weak Dimensions**

Because the Intent Manager must maintain a fully defined sketch at all times, a sketch initially is dimensioned using weak dimensions. As you dimension your sketch (these are strong dimensions) using your desired design intent, the weak dimensions automatically disappear.

You can convert weak dimensions to strong dimensions by selecting the weak dimension, right-clicking, and selecting **Strong**. Similar to creating a new dimension, you can either accept the current dimension value being made strong, or type a new one. Editing a weak dimension automatically makes it strong.
You can modify individual dimensions or many all at once.

- Modify dimensions by:
  - Editing the value.
  - Dragging the entity to which the dimension is attached.
  - Using the Modify Dimensions dialog box.

Modify Dimensions within Sketcher

You can modify dimensions in Sketcher by using any of the following methods:

- Edit the dimension manually by double-clicking it. The geometry placement will update to the new dimension. You can also edit the dimension value when you create it without having to double-click it.
- Click and drag the entity that the dimension is attached to. The dimension value will update automatically.
- Use the Modify Dimensions dialog box. When you select the dimension, it highlights in the graphics area. You can edit values or scroll the wheel next to the dimension you wish to modify. The dimension value will increase or decrease depending on the direction of scrolling.
  - You can adjust the sensitivity to adjust how finely or coarsely dimension wheels scroll.
  - If Regenerate is selected, the sketch geometry will update immediately after a dimension is edited. If the check box is cleared, you can adjust any or all dimensions within the Modify Dimensions dialog box, and the geometry will not update until you click Regenerate Section.
  - If Lock Scale is selected, you can modify one dimension and all other dimension values update automatically to new values at the same ratio.

Locking the scale to edit dimensions is common when creating the first feature of a model.
Creating Solid Extrude Features

Create extruded features from 2-D sketches.

- Extrude sections perpendicular to the sketching plane.
- Add or remove material from the model.

Creating Solid Extrude Features

An extrude feature is based on a two-dimensional sketch. It linearly extrudes a sketch perpendicular to the sketching plane to create or remove material. You can either select the sketch first and then start the Extrude tool, or you can start the Extrude tool and then select the sketch.

In an assembly you cannot create an extrude feature that adds material. You can only remove material.
Common Dashboard Options: Extrude Depth

You can extrude a sketch to many different depth options.

- Extrude depth options:
  - Blind
  - Symmetric
  - To Next
  - Through All
  - Through Until
  - To Selected
  - Side 1/Side 2
- Set using dashboard or right-clicking drag handle

Common Dashboard Options: Extrude Depth

When you create an extrude feature from a 2-D sketch, the depth at which the feature extrudes can be set in a variety of ways depending upon the design intent you wish to capture. You can specify the desired depth option using the dashboard or by right-clicking on the drag handle in the graphics area. Extrude depth options include:

- Blind (Variable) — This is the default depth option. You can edit this depth value by dragging the drag handle, editing the dimension on the model, or using the dashboard.

- Symmetric — The section extrudes equally on both sides of the sketch plane. You can edit the total depth at which the feature extrudes just as you can with the Blind depth option. Therefore, the Symmetric depth is essentially the same as a Blind Symmetric depth.

- To Next — This option causes the extrude to stop at the next surface encountered. A depth dimension is not required, as the next surface controls the extrude depth.

- Through All — This option causes the section to extrude through the entire model. A depth dimension is not required, as the model itself controls the extrude depth.

- Through Until — This option causes the extrude to stop at the selected surface. A depth dimension is not required, as the selected surface controls the extrude depth. Note that the section must pass through the selected surface.

- To Selected — This option causes the extrude to stop at the selected surface. A depth dimension is not required, as the selected surface controls the extrude depth. Unlike the Through Until depth option, the section does not have to pass through the selected surface.

- Side 1/Side 2 — You can independently control the depth at which the section extrudes on each side of the sketching plane. By default, the section extrudes on Side 1; however, you can cause the section to extrude...
on Side 2 as well. Any of the above options can be used for either side except for Symmetric.

The To Next and Through All options only consider geometry present at the time (in the feature order) when the extrude is created. Features created after the extrude feature is created do not cause the extrude feature's depth to change.

You can also switch depth options by right-clicking on the drag handle in the graphics area.
Common Dashboard Options: Feature Direction

You can edit the depth direction and material direction of a feature.

- Depth Direction
  - Side 1
  - Side 2
- Material Direction

Common Dashboard Options: Feature Direction

When you create a feature, such as an extrude feature, there are two yellow arrows that appear in the interface, as shown to the right.

In this case, the arrow on the right displays perpendicular to the section and denotes the depth direction. The arrow on the left displays parallel to the section and denotes the material direction.

Specifying the Depth Direction

The depth direction arrow in the interface shows you which direction the feature will be created with respect to the sketching plane. You can flip the
direction of feature creation either by using the dashboard or by clicking the arrow in the interface. In the upper-right figure, the depth direction was flipped.

By default, the feature is created in only one direction. This is known as Side 1. However, you can add the second direction so the feature is created in both directions from the sketch plane. This second side is Side 2. In the lower-left figure, the Side 2 depth direction was added to the feature.

**Specifying the Material Direction**

The material direction arrow in the interface shows you which side of the sketch material will be removed when creating a cut. This arrow only displays when removing material. Like the depth direction arrow, you can flip the material direction either by using the dashboard or by clicking the arrow in the interface. In the lower-right figure, the material direction for the cut was flipped from the inside to the outside. Consequently, the material that was removed flipped from the inside to the outside.
Creating Coaxial Holes

A coaxial hole is placed at the intersection of an axis and a surface.

- Placement references:
  - Datum axis
  - Surface or datum plane
- Offset references:
  - None

Hole Creation Theory

When creating hole features on a model, you locate holes by selecting placement (primary) and offset (secondary) references. The first piece of geometry selected to place the hole is the placement reference. Next, you either select additional placement references or offset references to further dimensionally constrain the hole feature. The type of geometry selected as the placement reference determines the type of hole being created.

Creating Coaxial Holes

To create a coaxial hole, you only select placement references. An axis is selected as the first placement reference. This axis identifies the location of the hole. A second placement reference, of either a surface or datum plane, is then selected to specify the surface where the hole starts drilling into the model. In the figures on this slide, datum axis A_1 and the front surface are the placement references.

You can also view your selected references in the Placement tab of the dashboard.

Once the hole references are satisfied, the hole preview appears with a default diameter dimension and depth value, which can be modified by using the drag handles or dashboard, or by editing the dimensions on the model.
Creating Linear Holes

A linear hole is created by selecting one placement reference and two offset references.

- Placement references:
  - Datum plane or surface
- Offset references:
  - Datum plane or surface
  - Edge
  - Datum axis

Hole Creation Theory

When creating hole features on a model, you locate holes by selecting placement (primary) and offset (secondary) references. The first piece of geometry selected to place the hole is the placement reference. Next, you either select additional placement references or offset references to further dimensionally constrain the hole feature. The type of geometry selected as the placement reference determines the type of hole being created.

Creating Linear Holes

To create a linear hole, a planar surface is selected as the placement reference. This surface identifies where the hole starts 'drilling' into the model. Two offset references are then selected to dimensionally constrain the hole feature. In the upper figure on this slide, the front surface of the model is the placement reference. In the lower-right figure, the top surface and datum plane DTM1 are the offset references. You can select offset references directly from the model or you can drag the green reference handles to the desired reference.

You can view your selected references in the reference collectors in the Placement tab of the dashboard. Within this tab, you can edit offset reference
values as well as modify whether the hole is offset or aligned to an offset reference. In the lower-right figure, the hole is aligned to datum plane DTM1.
You can add a drill point to your hole as well as add countersinks or counterbores.

- Hole profile options include:
  - Rectangle hole profile
  - Drill point profile
  - Add counterbore
  - Add countersink
    - Exit countersink
  - Lightweight hole display
- Dimension drill point profile to:
  - Shoulder
  - Tip

When you create a hole in Creo Elements/Pro, the default profile is a rectangular shape, as shown in the top hole in the upper figure. This is the rectangle hole profile. Other hole profiles and options available include, and are shown in the upper figure, respectively:

- Drill point profile — Adds the drill tip to the hole profile. You can edit the drill tip angle.
- Add counterbore — Creates a counterbore on the hole. You can edit the counterbore diameter and depth.
- Add countersink — Creates a countersink on the hole. You can edit the countersink angle and diameter. You can also create an exit countersink on a Through All hole.
• Lightweight hole display — Creates a hole that displays as a ring on the placement surface. Switching a hole feature to lightweight hole display affects the model's mass properties.

Dimensioning the Hole Depth for the Drill Point Profile

When you select the drill point profile, you can dimension the hole depth using two different methods:

• Shoulder — You are able to specify the depth of the drilled hole to the end of the shoulder. This is shown in the left image of the bottom-right figure.
• Tip — You are able to specify the depth of the drilled hole to the tip of the hole. This is shown in the right image of the bottom-right figure.

The Dashboard Shape Tab

At any time during the hole creation process, you can select the Shape tab in the dashboard to see the hole profile you are creating. This hole profile image updates automatically as you modify hole profile options, enabling you to preview the final result. Within the Shape tab you can perform the following operations:

• Edit hole diameter and depth.
• Edit drill tip angle.
• Edit counterbore diameter and depth.
• Edit countersink diameter and angle.
• Enable an exit countersink on a through all hole.
Creating Datum Features Theory

Datum features are commonly required as references when creating other features.

- The following types of datum features can be created:
  - Datum Planes
  - Datum Axes
  - Datum Points
  - Datum Coordinate Systems

Creating Datum Features Theory

Datum features are commonly required as references when creating other features. Datum features can be used as dimensioning references, feature placement references, and assembly references. The default color of datum features in the graphics area is brown (datum planes are both brown and grey, depending upon which side is currently being viewed). The following four types of datum features can be created:

- Datum Planes
- Datum Axes
- Datum Points
- Datum Coordinate Systems

Examples of each type of datum feature are shown in the figure.
Module 8

Basic Drawing Creation - References

Module Overview
This module contains a set of reference topics intended to give you a more in-depth understanding of the functionality used in the Basic Drawing Creation exercise of Module 3.

Objectives
After completing this module, you will be able to:
• Understand drawing concepts and theory.
• Create new drawings using drawing templates.
• Create new drawings manually and apply formats.
• Understand basic 2-D drawing orientation.
• Understand the drawing ribbon user interface.
• Create and orient general views.
• Create projection views.
• Create cross-section views.
• Modify drawing views.
• Utilize the drawing tree.
• Understand annotation concepts and types.
• Show, erase and delete annotations.
• Cleanup dimensions.
• Manipulate dimensions.
• Create driven dimensions.
• Insert notes.
• Publish drawing to a PDF and other formats.
Understanding Drawing Concepts and Theory

A drawing is often the final deliverable at a company and contains parametric 2-D or 3-D views of a 3-D model.

- A drawing usually contains at least:
  - Model views
  - Dimensions
  - Title block
- A drawing is bi-directional.

Example of a Model

Example of a Drawing

Analyzing Drawing Concepts and Theory

Once a part or assembly has been modeled, it is usually necessary to document that part or assembly by creating a 2-D drawing of it. Often, a 2-D drawing is the final deliverable at a company. The 2-D drawing usually contains parametric 2-D or 3-D views of the 3-D part or assembly, dimensions, and a title block. The drawing may also contain notes, tables, and further design information. Not every company requires that a drawing be created of a model.

A drawing is bi-directional. If a change is made to a model, a drawing that displays that model automatically updates to reflect that change. Conversely, if a change is made to a model in the drawing, the model automatically updates as well.
Creating New Drawings using Drawing Templates

Drawing templates work in conjunction with the model's saved views to automatically populate default drawing views.

- Drawing Templates are customizable:
  - Create templates that complete a majority of the initial drawing.
  - Additional items can be added to drawing templates.
    ♦ Other views
    ♦ View options
    ♦ Drawing formats
    ♦ Drawing options

Creating New Drawings using Drawing Templates

Like part and assembly templates, a drawing template provides you with a starting point to create your drawings. You use drawing templates when you want to create a standardized drawing. Drawing templates can automatically create views, set the desired view display and view options, display formats, and show model dimensions based on the template. You can configure Creo Elements/Pro to use a default drawing template when creating a new drawing, or you can select a different one. A drawing template is shown in the upper figure, while a drawing created using the drawing template is shown in the lower figure.

The views created within a drawing that uses a template are determined from the model's view orientations. You should consider drawing view orientations when creating your models.

Drawing templates contain three basic types of information for creating new drawings:

1. The first type is basic information that makes up a drawing but is not dependent on the drawing model, such as sheet size, notes, symbols,
formats, and so forth. This information is copied from the template into the new drawing.

2. The second type is representative “view symbols,” which contain the options used to configure drawing views and the actions that are performed on that view. The instructions in the template are used to build a new drawing that references a model to place various views in specific orientations and view states.

3. The third type is a parametric note. Parametric notes are notes that update to new drawing model parameters and dimension values. When a drawing is created from a template, the parametric notes update with the proper information from the models used in the drawing.

**Drawing Template Uses**

You can use drawing templates to define the layout of views, set view display, define tables, place symbols and notes, show dimensions, and create snap lines. A drawing template can also be customized with your company formats and standards. This enables you to automatically create drawings in a fraction of the time it would take to sketch them.

For example, you can create a template for a machined part versus a cast part. The machined part template could define the views that are typically placed for machined part drawings, set the view display of each view (for example, show hidden lines), place company standard machining notes, and automatically create snap lines for placing dimensions.
Creating New Drawings and Applying Formats

Your company can create customized formats that can be used in new drawings.

- Create new drawings using the New dialog box.
  - Specify the Default Model.
  - Specify orientation.
  - Specify size.
  - Specify format (optional).
- A Format:
  - Contains 2-D items.
  - Is created in Format mode.
  - Is applied to a drawing.
- Add or change formats using Sheet Setup.

Creating New Drawings Theory

You can create new drawings within Creo Elements/Pro either by clicking File > New, or by clicking New, selecting the Drawing option, and then editing the drawing Name. You must also specify whether to use a default template. This topic focuses on drawing creation when a default template is not used.

You must specify the Default Model to be used in the drawing. The Default Model is the model that is used in your drawing when you start placing views. You can add additional models to the drawing at a later time. If you have models open in Creo Elements/Pro when a new drawing is created, the model that is in the active window at the time of drawing creation is automatically set as the Default Model.

You must also specify the drawing Orientation, whether Portrait, Landscape, or Variable. If you select Portrait or Landscape, you can choose between numerous standard, predefined drawing sizes. If you select Variable, you must specify the desired drawing size width and height, in units of either inches or millimeters. A C size drawing is shown in the upper figure.

Using Drawing Formats

When creating a new drawing you must also decide whether a format is to be used in the new drawing. A drawing format contains 2-D items that typically include boundary lines, referencing marks, tables, and text. A format has an
extension of *.frm, and is created in Format mode. A format is then applied to a drawing. Your company will likely have created customized formats to be used, as they typically contain your company’s logo, title block, and tolerancing standards. In the lower figure, a C size drawing is shown with a format having been applied.

If you specify a format during drawing creation you do not specify an orientation or size, as these parameters are determined during format creation and carry into the drawing.

Adding and Changing Formats

You can decide whether to add a format at the time of drawing creation or at a later time. To add a format to a drawing after the drawing has been created, you can either click **Sheet Setup** from the Document group in the Layout tab, or you can click **File > Sheet Setup** from the main menu. You can also double-click the drawing size that is displayed along the bottom of the graphics area. You can then select your desired format, or replace an existing format with a different format.
Understanding Basic 2-D Orientations

Manipulate the 2-D orientation of your drawings in the Creo Elements/Pro graphics area.

- Keyboard/Mouse Orientation:
  - Pan
  - Zoom
  - Wheel Zoom
- Additional Orientation options:
  - Refit
  - Change sheets

Orientation using Keyboard and Mouse Combinations

To view specific areas of a drawing, you can pan and zoom the drawing using a combination of keyboard and mouse functions, as shown in the following table.

<table>
<thead>
<tr>
<th>Orientation</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pan</td>
<td>![Pan Icon]</td>
</tr>
<tr>
<td>Zoom</td>
<td>![Zoom Icon] Ctrl + ![Zoom Icon] +</td>
</tr>
</tbody>
</table>

Cursor over the area of interest before zooming in. The zoom function uses the cursor position as its area of focus. You can also zoom by using the scroll wheel. To control the level of zoom, press a designated key while using the scroll wheel, as shown in the following table:
# Zoom Level

<table>
<thead>
<tr>
<th>Zoom Level</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom</td>
<td><img src="image" alt="Keyboard and Mouse Selection" /></td>
</tr>
<tr>
<td>Fine Zoom</td>
<td><img src="image" alt="Keyboard and Mouse Selection" /></td>
</tr>
<tr>
<td>Coarse Zoom</td>
<td><img src="image" alt="Keyboard and Mouse Selection" /></td>
</tr>
</tbody>
</table>

## Additional Orientation Options

In addition to using keyboard and mouse combinations, the following additional drawing 2-D orientation options are available:

- **Refit** — Refits the entire drawing sheet in the graphics area.
- **Change sheets** — You can change drawing sheets in a multi-sheet drawing. The sheet numbers display under the graphics area as individual tabs. To change sheets you can select the tab corresponding to the sheet you wish to navigate to. You can also select the desired sheet number in the drawing tree. Often your company’s title block will display the drawing sheet number in a multi-sheet drawing, as shown in the lower-right figure.
Understanding the Drawing Ribbon User Interface

The Drawing mode was reorganized with a ribbon-style user interface.

- The ribbon organizes and configures user-interface.
  - Tabs based on the current task.
  - Sets up selection scope.
  - Appropriate right-click options.

- Ribbon structure
  - Tabs contain groups of commands.
  - Can be customized.

Understanding the Drawing Ribbon User Interface Theory

The Drawing mode has been reorganized into a ribbon-style user interface. A cross between a tabbed dialog box and a toolbar, the ribbon appears above the graphics area. The ribbon organizes and configures the user interface by:

- Organizing the current task into a series of tabs.
  - The tabs represent a task in the typical drawing creation workflow.
  - Each tab contains groups of icon commands.

- Setting up the selection scope.
  - By default, you can only select items that pertain to the selected tab. For example, you cannot select an annotation (detail item) when the Layout tab (for drawing views) is active.
    - You can select out-of-context items by pressing the ALT key. However, the available actions will be limited compared to what is available within the appropriate tab.
  - The available selection filters correspond to the active tab.
  - The Drawing Tree updates to display only items that pertain to the active tab.

Ribbon User Interface Structure

Within each tab in the ribbon, icon commands are organized into groups. Depending on the available screen space, less common options may be accessed by clicking a down arrow to reveal additional commands.
Customizing the Ribbon User Interface

The ribbon user interface can be customized to control icon display and placement. When in the Customize Screen function, right-click on ribbon icons for the following options:

- Icon display size — Icons can be set to display as large or small.
- Icon and text — Commands can be displayed as a large or small icon with text, icon only, or text only.
- Command priority — Commands can be reordered within their group to place frequently used options in easy reach. However, you cannot move commands between groups.
Creating and Orienting General Views

A general view is usually the first view of a series to be created.

- You can edit the following attributes when creating or editing general views:
  - View name
  - View type
  - View orientation
    - Model view name

Creating and Orienting General Views

When you create a drawing, the first view added to a drawing is a general view. A general view is usually the first of a series of views to be created. When you create or edit a general view in a drawing, the Drawing View dialog box appears displaying the View Type category.

You can edit the following attributes of a general view in the View Type category:

- View name — The view name displays in the drawing tree and when you cursor over the view in the graphics area. It also displays in the Layer tree when selecting the active layer object.
- View type — If there is more than one general view on the drawing, you can edit the view type from general to a different view type. This option is only available when editing an existing general drawing view.
- View orientation — Determines the orientation of the view in the drawing. You can set the view orientation using model view names that are created in the model itself. These are the same model views that are found in the model's saved view list and view manager. A general view can be placed in any orientation.
Creating Projection Views

A Projection view is an orthographic projection of another view’s geometry along a horizontal or vertical direction from the parent view.

- Projected view characteristics:
  - Child of view it is projected from
  - Orientation is 90° from parent view
  - Third angle or First angle

Creating Projection Views

A Projection view is an orthographic projection of another view’s geometry along a horizontal or vertical direction from the parent view. The orientation of the projection view is always 90° from the parent view, and its scale is dependent on the parent view. If the orientation of the parent view is updated, the orientation of the child projection views also updates.

You can either insert projection views by clicking Projection from the Model Views group in the Layout tab, or by selecting a drawing view, right-clicking, and selecting Insert Projection View. In either case, you must specify the parent view from which the projection view projects. When you create a projection view it is given a default name that is based on the direction of projection.

The default projection type for projection views is third angle. If desired, the projection type can be changed to first angle.

You can also project 3-D general views.
Creating Cross-Section Views

You can add cross-sections to drawing views and edit their Xhatching.

• Cross-section views:
  – Use cross-sections from the 3-D model.
  – Have Xhatching that can be edited.
  – Enable you to add arrows to a perpendicular view.
    ♦ Flip material direction

Creating Cross-Section Views

You can add cross-sections to drawing views using the Sections category of the Drawing View dialog box. When you specify that you want to add a section to a drawing view, a list of available cross-sections displays in a drop-down list. This list of available cross-sections comes from the 3-D model itself. You can only select valid cross-sections for a given drawing view. A valid cross-section is one that is parallel to the screen when placed in the view.

A cross-section displays in a drawing view with a set of Xhatching. You can edit the following attributes of the Xhatching lines.

• Spacing — For spacing, you can select either Half or Double from the menu manager. Each time you select half or double the spacing between Xhatching lines halves or doubles, respectively. You can also type a spacing value for the Xhatching lines. In the upper image of the lower-right figure, the spacing has been changed to a value of 0.15. In the lower image, the spacing has been changed to a value of 0.6.

• Angle — For angle, you can select a Xhatching line angle in 30 or 45 degree increments between 0 and 150 degrees. You can also type an angle value. In the lower image of the lower-right figure, the Xhatching line angle has been modified from 45 degrees to 120 degrees.

In addition to creating a section view, you can optionally add section arrows to any view that is perpendicular to the section view. In the lower-left figure,
the arrows were added to the drawing view. The direction that the arrows point indicates the direction of material to keep in the section view. You can flip this material direction if desired.
Modifying Drawing Views

You can perform many operations on a drawing view to change its display.

- Operations include:
  - Move the view.
    - Lock view movement
  - Delete views.
    - Child views
  - Modify properties.
    - Scale
    - View display
  - Edit the sheet scale.

Modifying Drawing Views Theory

When a view is placed on a drawing, there are a variety of operations that can be performed to change how the view displays. In most cases, you can modify a view that has already been placed on a drawing. The following are different types of operations that can be performed on views in a drawing.

Moving Views

By default, when views are placed on a drawing they cannot be moved. They are locked to the drawing. You can unlock drawing views for movement in the drawing by selecting a view, right-clicking, and toggling the Lock View Movement option. The toggle for locking view movement is a system setting rather than an individual drawing view setting. If one view is unlocked, all views are unlocked.

Once views are unlocked, a drawing view can be moved according to any parent/child relationships that exist between views. Since a general view has no parent views, it can be moved anywhere on the drawing. When a general view is moved, any child views move accordingly. A child view, on the other hand, can only move according to the angle of projection from the parent view.

Deleting Views

You can delete views from a drawing. All items associated with the deleted drawing view including child views are also deleted. For example, if you delete a general view that has three child projection views, the child projection view associated with it is also deleted.
views must also be deleted. The system highlights child views that are to be deleted, as shown in the lower-right figure.

Modifying Drawing View Properties

The following are two types of drawing view properties that can be modified:

• Scale — Is modified in the Scale category of the Drawing View dialog box. In most cases, the scale of a placed view is specified as the default scale for the sheet, or the sheet scale. You can also define a custom scale for a drawing view that makes it larger or smaller than the defined sheet scale. If a custom scale is defined, it is listed under the drawing view, as shown in the upper figure. Note that for some drawing views, such as a projection view, you cannot specify a custom scale because the drawing view scale is dependent upon its parent view.

• View Display — Is modified in the View Display category of the Drawing View dialog box. Three view display options that can be modified include:
  – Display style — Controls the display of the entire view. Options include Follow Environment, Wireframe, Hidden, No Hidden, and Shading. The Follow Environment display style may vary from company to company depending upon how the default display style is defined. In the upper figure, the display style was edited from No Hidden to Shading.
  – Tangent edges display style — You can define how tangent edges display within the drawing. Options include Default, None, Solid, Dimmed, Centerline, and Phantom.
  – Colors come from — For display styles other than shading, you can define where the colors for the drawing view geometry lines come from. The default option is that the colors are defined based on the drawing. You can specify that the colors come from how they are defined in the model.

Editing the Sheet Scale

You can also edit the sheet scale at the bottom of the graphics area. The sheet scale value edits the scale of the active model only. When you edit the sheet scale of the active model, any drawing views of that active model on that sheet update their scale based on the new value. In the lower-left figure, the sheet scale was increased from 1 to 1.75.
Utilizing the Drawing Tree

The drawing tree enables you to visualize and manipulate drawing elements.

- Drawing Tree
  - Changes with Ribbon Tab
  - Select items
  - Right-click options

Utilizing the Drawing Tree Theory

Drawing elements are shown in a hierarchical tree similar to the model tree. The drawing tree changes its display to match the current drawing task, based on the tab selected in the drawing ribbon. The drawing tree enables you to visualize the items in the drawing, and also enables you to right-click them for access to additional various options.

Keep in mind the following when working with the drawing tree:

- The drawing tree appears above the model tree. Each can be independently resized or collapsed.
- The drawing tree or the model tree can be toggled to display the layer tree.
Understanding Annotation Concepts and Types

You can add additional detail to drawing views to convey information needed to manufacture the part or components of the assembly.

- Add the following annotations to drawings:
  - Dimensions
    - Driving
    - Driven (Created)
  - Axes
  - Notes
  - Tables
  - Bills of Material

Analyzing Annotation Concepts and Types

You can add additional detail to drawing views in the form of annotations to convey information needed to manufacture the part or components of the assembly. There are numerous annotations you can add to a drawing, including, but not limited to:

- Dimensions — Used to display measurements, distances, and depths between specific geometric entities on a drawing view. You can add both driving dimensions from the model, or create your own dimensions.
- Axes — Used to show the centers of holes or bolt circles.
- Notes — Add additional information to a drawing that may not be found in dimensions.
- Tables — Used to show additional drawing information in tabular format. Examples include names of optional components in an assembly, specific dimension values for part numbers in a common drawing, and cam lift values per degree.
- BOM — Used to show components in an assembly and their quantities.
Showing, Erasing, and Deleting Annotations

Dimensions and other detail items created in a 3-D model can be shown in drawings.

- Show various types, based on tab
- Context sensitive, based on selection
- Erase/Unerase
- Delete

![Showing Axes and Dimensions](image1.png)

Showing Axes and Dimensions

Show Model Annotations

Showing Annotations Theory

When you create a 3-D model, you simultaneously create various items useful for annotating the model in a drawing, such as dimensions and axes.

When creating a 2-D drawing you can select which information from the 3-D model to show in the drawing:

- Dimensions
  - Driving Dimension Annotation Elements
  - All Driving Dimensions or Strong Driving Dimensions
  - Driven Dimensions, Reference Dimensions, or Ordinate Dimensions
- Geometric Tolerances
- Notes
- Surface Finishes
- Symbols
- Datums
  - Set Datum Planes, Set Datum Axes, or Set Datum Targets
  - Axes

The Show Model Annotations dialog box is context sensitive. You can control which annotations display on the drawing and where they display based on how items are selected:

- Select a model from the model tree — Indicates all the selected item types for the model on the drawing. The items may appear in multiple views.
• Select features from the model tree — Indicates the selected item types for the selected features on the drawing. The items may appear in multiple views.

• Select a drawing view — Indicates all the selected item types within a particular drawing view.

• Select features from a particular drawing view — Indicates the selected item types for the selected features on the drawing, within the view in which the feature was selected. If an item is not appropriate to that view, it does not display.

• Select a component in a particular drawing view (Assembly Drawings only) — Indicates the selected item types for the selected component on the drawing, within the view in which the component was selected. If an item is not appropriate to that view, it does not display.

All of the possible items that can be shown based on the selected tab and selected items display in the drawing in a preview color. You can then select or de-select items to show by using the dialog box or by selecting from the drawing.

When dimensions are shown, the system automatically arranges and spaces them apart. You can then adjust them further manually or by using the Cleanup Dimensions dialog box.

Erasing and Deleting Annotations Theory

If, at any point during drawing creation you decide that you no longer want certain shown items, you can erase or delete them. The differences between these two options are as follows:

• Erase — Temporarily removes the items from the display. The items are shown grayed out in the drawing tree.
  – Erased items can be returned to the display by right-clicking and selecting Unerase.

• Delete — Removes the items from the drawing.
  – Any item originating in the model is retained in the model, and can be shown again.
  – Any item created in the drawing, such as dimensions or notes are deleted and will need to be re-created.

To erase/delete items, you select them in the drawing, then right-click and select Erase or Delete. You can select items to erase or delete using the following methods:

• Select an individual item.
• Press CTRL and select multiple items.
• Use a selection filter to quickly select desired items.
• Select items from the drawing tree.
Cleaning Up Dimensions

Creo Elements/Pro can automatically arrange the display of selected dimensions based on controls that you set.

- Functions include:
  - Offset dimensions in evenly spaced increments.
  - Create breaks in witness lines.
  - Flip dimension arrows that do not fit between witness lines.
  - Center dimensions between witness lines.
  - Create snap lines.

The Clean Dimensions Dialog Box

Cleaning Up Dimensions

You can use Creo Elements/Pro’s clean dimensions functionality to automatically perform the following tasks:

- Clean dimensions by view, or by selecting individual dimensions. You cannot clean angle or diameter dimensions.
- Offset dimensions from edges or view boundaries.
- Space dimensions in even increments.
- Create breaks in witness lines where they intersect other witness lines or draft entities.
- Automatically flip arrows on dimensions when they do not fit between witness lines.
- Center dimensions between witness lines.

The lower-left figure displays dimensions before the cleanup process has been performed, while the lower-right figure displays dimensions after the cleanup process has been performed.
Creating Snap Lines

When cleaning dimensions you have the option of creating snap lines with the offset dimensions. Objects snap to these lines, which are created at the specified offset value. The lower-right figure displays snap lines that were created during the dimension cleanup process. Even after the cleanup process has been performed, you can manipulate dimensions and snap them to the displayed snap lines. There are two important points to know about snap lines:

• Snap lines do not display in a printed drawing.
• You can delete snap lines after use.
Manipulating Dimensions

When dimensions are placed on a drawing, they typically must be modified in some way either for clarity or so they adhere to your company's drawing standards.

- Dimensions can be manipulated in the following ways:
  - Move (handles)
  - Align Dimensions
  - Flip Arrows
  - Move Item to View
  - Edit Attachment

Manipulating Dimensions

You can manually manipulate a dimension or dimensions to display them in the desired location. The following operations can be manually performed on dimensions:

- Move dimensions — Select a dimension and move it to a different location of the drawing view. Each dimension, when selected, displays a series of move handles, as shown in the lower figure. Clicking and dragging the different move handles yields different move results. The following move options are available:
  - Move Dimension and Text — Use the handle circled in blue in the lower figure to move both the dimension and the dimension text.
  - Move Text — Use either handle circled in green in the lower figure to move just the dimension text.
  - Move Dimension — Use the handle circled in yellow in the lower figure at either arrow tip to move the dimension.
  - Move Witness Line — Use the handle circled in orange in the lower figure to move the witness line. This handle is the one at the end of the witness line side that touches the model geometry.

- Align Dimensions — You can select multiple dimensions including linear, radial, and angular, and align them to one another. The selected
dimensions align to the first dimension selected. Once the dimensions are selected, you can either right-click and select **Align Dimensions**, or you can click **Align Dimensions** from the Arrange group in the Annotate tab.

- **Flip Arrows** — You can flip arrows by right-clicking and selecting **Flip Arrows**, or you can right-click while dragging a dimension to toggle through the different arrow flipping options. For radius dimensions there are four different flip options available, for diameter dimensions there are three different flip options available, and for linear dimensions there are two different flip options available. In the upper figure you can view all the available arrow flipping options for radius dimensions.

- **Move Item to View** — Move dimensions from one drawing view to another. You can select the item to move, then either right-click and select **Move Item to View**, or click **Move to View** from the Arrange group in the Annotate tab.

- **Edit Attachment** — Specify a new attachment position for certain dimensions, a radius dimension, for example. The available new attachment positions highlight in all drawing views and enable you to select a new surface or edge. To edit the attachment, select the dimension, then right-click and select **Edit Attachment**.
Creating Driven Dimensions

You can create additional dimensions within a drawing as needed if a dimension is not available to be shown or as company standards dictate.

- Driven dimension types include:
  - Linear
  - Angular
  - Radial/Diameter
  - Point-Point

- Add additional text:
  - Prefix
  - Postfix

Creating Driven Dimensions

A driven dimension is created by the user. This type of dimension reports a value based upon the references selected when the dimension is created. That is, the dimension value is driven by the geometry selected, and therefore it is not possible to modify the value of a driven dimension. A driven dimension does not pass back to the model; it appears only within the drawing. A created dimension displays in the drawing tree differently than that of a shown dimension. In the right figure, the dimensions in view VIEW_TEMPLATE_3 are created dimensions, while the dimensions in view VIEW_TEMPLATE_2 are shown dimensions.

You can create a Standard driven dimension using Dimension New References from the Insert group in the Annotate tab, or by right-clicking and selecting Dimension - New References. The system creates a dimension based upon one or two selected references similar to how you create dimensions in Sketcher. The dimension’s witness lines automatically clip to their selected references.

Driven Dimension Types

Standard driven dimension types include linear, angular, radial, diameter, or point-point dimensions.
When creating a driven dimension, you can select an edge, edge and point, two points, or a vertex. You can further filter what entities the dimension attaches to using the following attach type menu commands in the menu manager:

- **On Entity** — Attaches the dimension to the entity at the pick point, according to the rules of creating regular dimensions.
- **On Surface** — Attaches the dimension to the location selected on a surface.
- **Midpoint** — Attaches the dimension to the midpoint of the selected entity.
- **Center** — Attaches the dimension to the center of a circular edge. Circular edges include circular geometry such as holes, rounds, curves, and surfaces, and circular draft entities.
- **Intersect** — Attaches the dimension to the closest intersection point of two selected entities.
- **Make Line** — References the current X and Y-axes in the orientation of the model view.

Depending upon the selected references, you may have to further specify the type of dimension to be created. For example, you may be asked to specify whether the dimension you create is to be Horizontal, Vertical, Slanted, Parallel, or Normal to the selected references. If your selected references are arcs or circles, you must specify whether the dimension is to be created between the arc Centers, Tangent, or Concentric.

### Adding Prefix and Postfix Text

You can add additional text to a dimension. Text can be added as a prefix or a postfix to the dimension value. For example, if a radius dimension is typical of all radii on the part, you can add the postfix _TYP_ to the dimension.
Inserting Notes

You can insert notes on a drawing with or without leaders that can contain dimensions.

- Note types include:
  - No Leader
  - With Leader
  - ISO Leader
  - On Item
  - Offset
- Specify Attach Type:
  - On Entity
  - On Surface
  - Free Point
  - Midpoint
  - Intersect

Inserting Notes

You can insert notes on a drawing to convey additional information. For example, you can insert a note stating that all sharp edges must be broken, as shown in the upper-right figure.

The following types of notes can be inserted:

- No Leader — Creates a free note.
- With Leader — Creates a note with a leader.
- ISO Leader — Creates a note with an ISO leader.
- On Item — Creates a note directly attached to an edge, surface, or datum point.
- Offset — Creates a note relative to a detail entity. If the detail entity is moved, the note moves with it.

Notes can be created horizontally, vertically, or at an angle, and you can specify the justification as Left, Center, or Right.

When you specify that the note has a leader, the following leader attach types are available:

- On Entity — Attaches the leader to selected geometry in a drawing view.
- On Surface — Attaches the leader to a selected location on the surface of a drawing view.
• Free Point — Attaches the leader to a location on the screen that you select.
• Midpoint — Attaches the leader to the midpoint of a specified entity.
• Intersect — Attaches the leader to the intersection of two entities.

You can also specify what the attach point of the leader looks like. Options include arrow head, dot, filled dot, no arrow, slash, integral, box, filled box, double arrow, and target. In the lower-right figure, the note was created with an arrow head leader.
Publishing Drawings

You can select the Publish tab in the drawing ribbon to create a hard copy deliverable of your drawing.

- Send the drawing to a printer or plotter.
- Export the drawing to a different electronic format.
- You can print preview the drawing.

![Previewing the Drawing](image)

Publish Group in the Drawing Ribbon

Publishing Drawings

To create a hard copy deliverable of your drawing, you can select the Publish tab in the drawing ribbon. When the Publish tab is selected, the Navigator pane is automatically closed. You can then select the Print/Plot option to send the drawing to a printer or plotter.

When you select another tab in the drawing ribbon, the Navigator pane is automatically opened.

You can also export the drawing to one of the following electronic file formats:

- DXF
- IGES
- Stheno
- TIFF
- PDF
- STEP
- SET
- Medusa
- DWG
- CGM

© 2009 PTC
Of course, any of these exported file formats can also be sent to a printer to generate a hard copy.

Regardless of the publish method specified for output, you can preview what the result will look like. Print Preview creates an accurate preview of the selected output type. It takes into account pen table mapping, line styles, line priorities, printer margins, and other settings. To preview the output you can click **Preview** from the Publish group.

You can also modify the default settings for the publish option specified using the **Settings** icon in the Publish group.
Module 9

Basic Assembly Modeling - References

Module Overview
This module contains a set of reference topics intended to give you a more in-depth understanding of the functionality used in the Basic Assembly Modeling exercise of Module 4.

Objectives
After completing this module, you will be able to:
• Understand assembly theory.
• Understand constraint theory.
• Assemble components using the Default constraint.
• Orient the component being assembled.
• Constrain components using Insert.
• Constrain components using Mate Coincident.
• Constrain components using Align Coincident.
• Utilize the Accessory Window.
Understanding Constraint Theory

Constraints determine how a part is located in an assembly.

- Most constraints are applied between parts within an assembly.
  - Select component reference.
  - Select assembly reference.
- Constraints are added one at a time.
- The active constraint is highlighted in a light orange box.
- Double-click a constraint’s tag to modify it.

You can assemble components using constraints. Constraints determine how a part is located within an assembly. There are many different types of constraints that you can use to assemble components.

Most constraints are applied between parts within an assembly. They specify the relative position of a pair of references. The system adds constraints one at a time. Use placement constraints in combinations to specify both placement and orientation. It is important to choose your constraints based on the design intent of your assembly, so that when you edit a dimension on a part, the assembly reacts as predicted.

When you create a constraint, its references are highlighted on the models and the Constraint Type is displayed. For most constraints it is necessary that you select two references, a component reference on the component being placed, and an assembly reference from an item in the assembly. When the first reference has been selected, a red, dashed line connects the first selected reference to your cursor until you select the second reference, as shown in the lower-left figure.

When multiple constraints are created, the active constraint is highlighted in a light orange box. For example, in the upper-right figure the top Insert constraint is the active constraint. To activate a different constraint, simply...
select the displayed name or select it from the Placement tab in the dashboard. You can then right-click to perform a desired action.

You can also double-click a constraint's tag in the graphics area to edit the constraint, as shown in the lower-right figure. Editing options include switching the constraint type, changing the constraint orientation, and viewing as well as deleting the constraint's placement references.

You can toggle Constraints To Connections in the dashboard to convert existing connections to constraints within an assembly.
Assembling Components using the Default Constraint

It is standard practice to assemble the first component of an assembly using the Default constraint.

• Benefits of using the Default constraint:
  – No references are specified.
  – No parent/child relationships are created.

Assembling Components using the Default Constraint

The Default constraint enables you to align the internal system-created coordinate system of the component to the internal system-created coordinate system of the assembly. The system places the component at the assembly origin, as shown in the left figure. Because the internal system coordinate system is used, no references are specified, and no parent-child references are created. It is a standard practice to assemble the initial assembly component using a Default constraint, as shown in the right figure.
Orienting the Component being Assembled

You can reorient a component with respect to the assembly during placement.

- Component Orientation Controls:
  - Drag
  - Spin
  - Pan

Basic Component Orientation Methods

When assembling a component, you can reorient it with respect to the assembly. Reorienting the component closer to its assembly location aids in its assembly by making it easier to select references. When you use the Automatic option, the system is better able to determine the correct placement constraints to use.

You can reorient the component according to the constraints that have been applied to it. As constraints are applied the degrees of freedom are reduced, further limiting how the component can be moved.

The following types of component reorientation operations are available:
<table>
<thead>
<tr>
<th>Operation</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component Drag</td>
<td>Ctrl + Alt +</td>
</tr>
<tr>
<td>Spin</td>
<td>Ctrl + Alt +</td>
</tr>
<tr>
<td>Pan</td>
<td>Ctrl + Alt +</td>
</tr>
</tbody>
</table>
Constraining Components using Insert

Use the Insert constraint to position two revolved surfaces coaxial.

- References you can select include:
  - Cylindrical surfaces
  - Conical surfaces

Constraining Components using Insert

The Insert constraint enables you to insert one revolved surface into another revolved surface, making their respective axes coaxial. For example, you can create an Insert constraint to match a shaft to the hole, as shown in the figure. This constraint is especially useful when axes are unavailable or inconvenient for selection. Keep in mind the Insert constraint only constrains surfaces coaxial, and does not "slide" one component into another.
Constraining Components using Mate Coincident

Use the Mate Coincident constraint to position two surfaces or datum planes coplanar and facing each other with an equivalent offset value of zero.

- References you can Mate Coincident include:
  - Planar surfaces
  - Datum planes
  - Conical surfaces

Constraining Components using Mate Coincident

The Mate Coincident constraint enables you to position two planar surfaces or datum planes to lie in the same plane (coplanar), and to face each other, as shown in the upper-right figure. If datum planes are mated Coincident, their brown (positive) sides face each other. Using the Mate Coincident constraint, you can also select pairs of conical surfaces, which makes the surfaces coincident and coaxial in one step, as shown in the lower-right figure. When components are mated Coincident to one another, it is the same as assigning an offset value of zero, except that an offset value is not created for editing. The components can be positioned in any location as long as their normals face each other.

Datum planes have positive and negative sides designated by color. If you rotate a model with datum planes displayed, look closely to see that the colors are brown and gray.

If two planar surfaces are mated Coincident, you can use the Change Constraint Orientation option in the dashboard to convert the Mate Coincident constraint into an Align Coincident constraint. You can also
double-click the Mate constraint tag in the graphics area and edit the constraint type to an Align constraint.
Use the Align Coincident constraint to position two surfaces or datum planes coplanar and facing in the same direction with an equivalent offset value of zero.

- References you can Align Coincident include:
  - Planar surfaces
  - Datum axes
  - Datum planes
  - Edges
  - Points/Vertices

The Align Coincident constraint enables you to make two planar surfaces or datum planes lie in the same plane (coplanar) and face in the same direction. Align can also be used to make two axes coaxial, or two points or edges coincident, but the selected references must be of the same type, for example, plane-to-plane, axis-to-axis, and so on. With Align constraints, the surfaces or the brown sides of datum planes, face the same direction instead of facing each other as when mated.

When components are aligned coincident to one another, it is the same as assigning an offset value of zero, except that an offset value is not created for
editing. The components can be positioned in any location as long as their normals face in the same direction.

Datum planes have positive and negative sides designated by color. If you rotate a model with datum planes displayed, look closely to see that the colors are brown and gray.

If two planar surfaces are aligned coincident, you can use the Change Constraint Orientation option in the dashboard to convert the Align constraint into a Mate constraint. You can also double-click the Align constraint tag in the graphics area and edit the constraint type to a Mate constraint.
Utilizing the Accessory Window

The accessory window enables you to manipulate the incoming component individually to facilitate reference selection.

- Accessory window uses:
  - Component placement
  - Data sharing
  - Sheetmetal forms
- Toggle the accessory window on or off.
- The accessory window can be docked or undocked.

Viewing the Accessory Window

Utilizing the Accessory Window

When assembling components, you can use the accessory window. The accessory window displays only the incoming model, enabling you to manipulate the component individually to facilitate reference selection. You can toggle the accessory window on or off using the **Show In Separate Window** icon. The accessory window can be used in the following instances:

- Component placement — The accessory window can be particularly beneficial if you are assembling a very small component into a very large assembly.
- Data sharing
- Sheetmetal forms

When the accessory window is toggled on, you can choose whether or not to display the incoming model in the graphics area by toggling the **Show In Assembly Window** icon. Of course, you can select references on
the incoming model in either the accessory window or the graphics area, depending on where it is displayed.

The accessory window can be docked or undocked. If docked, it appears within the D:\ed_serv\EN\mcad_icons_370; graphics area, and always in front, preventing “lost windows”. You can drag the window to a different location within the graphics area or resize it like any other conventional window. When the accessory window is docked, the model tree pane splits and displays the incoming model's model tree at the lower portion. The accessory window model tree supports layer tree functionality.

If the accessory window is undocked, the incoming model's model tree will display in that window. The undocked accessory window model tree supports layer tree functionality, also. You can undock the accessory window using a configuration option.

**Accessory Window Config Options**

The following configuration options determine the accessory window behavior:

- accessory_window_display — Controls the display of the accessory window. Options include:
  - docked — Places the accessory window as a separate window within the graphics area.
  - undocked — Places the accessory window as a separate window in addition to the D:\ed_serv\EN\mcad_icons_370; window. This option is equivalent to the “old” separate window.

- comp_assemble_start — Sets the initial assembly placement behavior when assembling a new component. Options include, but are not limited to:
  - default — Displays the incoming model in the main graphics area only.
  - constrain_in_window — Displays the incoming model in the accessory window only.
Module Overview

This module contains a set of reference topics intended to give you a more in-depth understanding of the functionality used in the Advanced Modeling and Design exercise of Module 5.

Objectives

After completing this module, you will be able to:

• Understand design intent.
• Utilize sketcher constraints.
• Sketch using On-the-Fly constraints.
• Sketch arcs.
• Use Entity from Edge within sketcher.
• Create solid revolve features.
• Understand round theory.
• Create axial patterns.
• View and edit model properties.
• Analyze the mass properties of a model.
• Take measurements from models.
• Measure for global interference.
Understanding Design Intent

Design Intent in Sketcher is to create, constrain, and dimension a sketch in a manner that will cause it to update predictably if modified.

- Design intent is captured in sketches by:
  - How it is constrained.
  - How it is dimensioned.
- Capture design intent by using the Intent Manager to:
  - Maintain fully defined sketches at all times.
  - Maintain weak/strong items.

Design Intent Captured with Dimensions

Design Intent Captured with Constraints

Understanding Design Intent Theory

When creating models with Creo Elements/Pro, it is critical that you capture the design intent of the model. Design intent ensures predictable results when a model is modified. Creating sketch features enables you to capture design intent. Design intent is captured and can be varied in sketches by:

- How it is constrained — Changing how a sketch is constrained affects the predictable behavior of the sketch, thereby varying design intent.
- How it is dimensioned — Changing how a sketch is dimensioned affects the predictable behavior of the sketch, again varying design intent.

Using the Intent Manager to Capture Design Intent

The upper-right figure shows a freehand sketch. No design intent has been applied to it. When you edit the sketch, it is not known how it will behave. The middle-right figure shows the desired sketch to be achieved. The Intent
Manager helps you apply design intent to your sketch so it appears as the middle image, not the top image.

Start by sketching the rough shape of your desired sketch. The Intent Manager will begin to dynamically apply constraints to help you lock in your sketch. For example, if you sketch a line approximately vertical, the Intent Manager will dynamically apply a vertical constraint to that line, helping you lock in design intent. When you stop sketching, a series of gray dimensions appears in addition to your constraints.

- The Intent Manager must maintain a fully defined sketch at all times. The dimensions and constraints maintain the size, shape, and location of all sketched items, which helps you capture design intent. Modify the default dimension scheme if needed by editing or adding dimensions so you properly capture your intended design intent.
- The Intent Manager contains both Weak and Strong items.
  - Weak items are gray, whereas Strong items are light orange.
  - Dimensions and constraints can be Weak or Strong.
  - The system will add or remove Weak items as necessary to maintain the fully constrained sketch.
  - You cannot delete Weak items.
  - Strong items are Weak items that were made strong either directly or by modifying them.
Utilizing Constraints

Constraints are rules enforced by Creo Elements/Pro on your sketched entities.

- Constraint types include:
  - Vertical
  - Horizontal
  - Perpendicular
  - Tangent
  - Midpoint
  - Coincident
  - Symmetric
  - Equal
  - Parallel

Utilizing Constraints Theory

Constraining the sketch is an important means to capture design intent. As you add constraints, you add logic to your sketches. You also minimize the number of dimensions required to document your design intent. This is why it is important to constrain your sketched entities before dimensioning your sketch.

The following table lists the available constraints, which can be activated from the flyout in the Sketcher toolbar, by selecting multiple entities and right-clicking, or by clicking Sketch > Constrain from the main menu:

<table>
<thead>
<tr>
<th>Constraint</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical</td>
<td>Makes lines vertical or aligns points vertically.</td>
</tr>
<tr>
<td>Horizontal</td>
<td>Makes lines horizontal or aligns points horizontally.</td>
</tr>
<tr>
<td>Perpendicular</td>
<td>Makes lines perpendicular to one another.</td>
</tr>
<tr>
<td>Tangent</td>
<td>Makes lines tangent to arcs and circles.</td>
</tr>
<tr>
<td>Constraint</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Midpoint</td>
<td>Places a point on the middle of a line or arc.</td>
</tr>
<tr>
<td>Coincident</td>
<td>Aligns two entities or vertices to the same point. Also creates Collinear and Point on Entity constraints.</td>
</tr>
<tr>
<td>Symmetric</td>
<td>Makes two points or vertices symmetric about a centerline.</td>
</tr>
<tr>
<td>Equal</td>
<td>Makes lines equal length, gives arcs/circles equal radii, makes dimensions equal, or creates equal curvature.</td>
</tr>
<tr>
<td>Parallel</td>
<td>Makes lines parallel to one another.</td>
</tr>
</tbody>
</table>

At any time, you can click Sketch > Constrain > Explain and select a constraint from the sketch. The message window provides an explanation of the constraint.
Sketching with On-the-Fly Constraints

When sketching entities, you can manipulate constraints on-the-fly as they appear.

- On-the-fly constraints enable you to capture design intent.
- Constraint manipulations include:
  - Lock/Disable/Enable
  - Disable constraints from appearing on the fly
  - Toggle the active constraint

Sketching with On-the-Fly Constraints Theory

As you sketch geometry entities, constraints appear dynamically on-the-fly to quickly capture design intent. The constraints actually cause the geometry to snap as you sketch it, based on the constraint that appears. For example, as you sketch a line close to horizontal, a Horizontal constraint will dynamically display and snap the line horizontal, enabling you to quickly capture your horizontal line design intent. Taking advantage of these constraints ensures that you do not have to manually constrain entities after they are sketched.

When a constraint appears, you should perform the following manipulations to further aid you while sketching:

- Lock constraint — Enables you to lock the constraint so the geometry remains snapped. Locked constraints are denoted by circles, as shown in the upper-right figure.
- Disable constraint — Enables you to disable the constraint so it does not influence the geometry. Of course, you can always re-enable the disabled constraint. Disabled constraints are denoted by slashes, as shown in the lower-left figure.
- Disable constraints from appearing on-the-fly — Enables you to sketch an entity without any on-the-fly constraints appearing.
• Toggle active constraint — When a constraint appears on-the-fly while sketching, it displays in red and is considered active. When more than one constraint appears at the same time, only one can be the active constraint. The active constraint has the previously defined manipulations applied to it. The toggle manipulation is only available if more than one on-the-fly constraint appears at the same time. In the lower-right image, the Equal Length constraint is active in the left image and the Horizontal constraint is active in the right image.

The following table lists the manipulations available and the corresponding mouse and keyboard operation:

<table>
<thead>
<tr>
<th>Constraint Manipulation</th>
<th>Mouse/Keyboard Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lock/Disable/Enable the Constraint</td>
<td>Right-click to toggle between constraint types.</td>
</tr>
<tr>
<td>Disable constraints from appearing on-the-fly</td>
<td>Press and hold SHIFT while sketching the entity.</td>
</tr>
<tr>
<td>Toggle the Active Constraint</td>
<td>Press TAB.</td>
</tr>
</tbody>
</table>

Manipulating the constraints on-the-fly does not cancel the Sketcher entity tool that you are using. For example, if you are sketching a line and manipulate a constraint that dynamically appears, the Line tool remains active.
Sketching Arcs

You can create numerous types of arcs within Sketcher.

- There are five types of Arcs:
  - 3-Point
  - Tangent End
  - Concentric
  - Center and Endpoints
  - Tangent to 3 Entities

3-Point Versus Tangent Arc Creation

Arc Tangent to 3 Entities  Center and Endpoints Arc

Sketching Arcs

There are five types of arcs available in Sketcher:

- 3-Point — Click **3-Point / Tangent End Arc** from the Sketcher toolbar and select the locations for the two arc endpoints and the arc diameter. When you select an existing line endpoint, a green "quadrant" symbol appears around that endpoint. Move the cursor through the quadrants perpendicular to the line to create a 3-Point arc. You can also right-click in Sketcher and select **3-Point/Tangent End**.

- Tangent End — Click **3-Point / Tangent End Arc** from the Sketcher toolbar, select an existing line endpoint, and move the cursor through the green quadrants parallel to the line to create a Tangent End arc. You can also right-click and select **3-Point/Tangent End**.

- Concentric — Click **Concentric Arc** from the Sketcher toolbar to create an arc that is concentric about an existing arc or circle.

- Center and Endpoints — Click **Center and Ends Arc** from the Sketcher toolbar to create an arc with center and ends that you select.

- Tangent to 3 Entities — Click **3 Tangent Arc** from the Sketcher toolbar and select three arcs, circles, or lines that the arc must be tangent to.
Using Geometry Tools within Sketcher

Use Geometry Tools to modify existing sketched entities.

Using Trim/Delete Segment

You can dynamically trim the parts of sketched entities you no longer need. When dynamically trimming, any entity that you touch while dragging will be deleted. In the upper-left figure, the extra arcs are deleted.

Using Trim Corner

You can trim or extend sketched entities to other entities in Sketcher. To trim entities, select the entity side you want to keep. In the upper-right figure, the two entities are selected to be trimmed, and the gap between the entities is closed.

Using Divide

You can divide a sketched entity into two or more new entities. The system divides the entity at the point(s) you select. In the lower-left figure, the circle is divided to become two separate arcs.

Some sketched features require portions of a sketch to maintain an equal number of entities.

Using Geometry Tools within Sketcher Theory

You can use various Geometry Tools within Sketcher to modify existing geometry. You can dynamically trim entities, trim entities to other entities, divide entities, and mirror entities. You can undo any operation done using Geometry Tools.
Using Mirror

You can mirror selected sketched entities about a centerline. Mirrored entity geometry will join with the original entity to become one entity given the following two criteria:

- The entity is normal to the centerline being mirrored about.
- One endpoint lies on the centerline.

In the lower-right figure, the top horizontal line and bottom are both perpendicular to the mirroring centerline and have an endpoint that lies on the centerline. When the geometry is mirrored, the result is one horizontal entity on the top and one arc on the bottom.

You cannot mirror dimensions, text entities, or centerlines.
Utilizing Sketch References

Sketch references are used to capture design intent by snapping geometry or dimensioning to them.

• The following types of entities can be selected:
  – Existing geometry
  – Sketches
  – Datum features
• Unused references automatically removed.

The References Dialog Box

Utilizing Sketch References

You use sketch references to snap sketch geometry to, which can cut down the number of dimensions required. Sketch references are also used by the system for creating the initial weak dimensions and constraints. Should further dimensions be required, you can dimension to or from sketch references. Sketch references appear as dashed entities in the Sketcher.

When selecting entities from existing features, you create a parent/child relationship between the sketch and the entity you added as a reference. However, if you add a sketch reference and it goes unused, the system automatically removes it as a sketch reference. Conversely, if you dimension to or from an entity the system automatically adds it as a sketch reference.

You can add sketch references by clicking Sketch > References from the main menu. At this point, the References dialog box opens. The References dialog box consists of the following items:

• Select References — Select entities in the graphics area. The following types of entities can be selected as sketch references:
– Existing geometry — Select the edges or surfaces of features that have already been created.
– Sketches — Select geometry from existing sketches.
– Datum Features — Select datum planes, datum axes, points, and coordinate systems.
• Select Xsec References — Select a surface or datum plane to intersect with the sketching plane.
• Selection Filters — Used for selecting items within the Reference list. Choices from the drop-down list include Use Edge/Offset, All Non-Dim. Refs, Chain Refs, and All References.
• Replace — Select a reference from the list, click Replace, and select a new reference.
• Delete — Delete the selected reference from the list.
• Reference Status — Displays the status of the sketch with respect to references. Status options include Unsolved Sketch, Partially Placed, and Fully Placed.
• Solve — You can solve an unsolved or partially placed sketch after changing references.

You can also use sketch references for snapping geometry while sketching.
Using Entity from Edge within Sketcher

You can reuse existing geometry by selecting it with **Use Entity from Edge within Sketcher**.

- Two types:
  - Use Edge
  - Offset Edge
- Select edge types:
  - Single
  - Chain
  - Loop

**Reused Entities from Edge**

**Reused Entities Offset from Edge**

**Selecting the Desired Entity from Edge Chain**

Using Entity from Edge within Sketcher

The **Use Edge** and **Offset Edge** options in Sketcher create sketcher geometry by projecting selected geometry edges onto the sketching plane. The two options are the same except the offset edge enables you to specify an offset value to the edges. A positive offset value causes the geometry to become larger, whereas a negative offset value causes the geometry to become smaller. Each entity created has the "~" constraint symbol. The resulting dimensions are always positive when shown in a drawing.

When using the entity from edge options, you can select edges three different ways:

- Single — Edges are selected one at a time.
- Chain — Create sketched entities from a chain of edges or entities. Select two edges from the same surface or face and select which chain of geometry you wish to be created. The lower-right figure shows one possible chain selection from the selected entities.
• Loop — Create sketched entities from a loop of edges or entities. Select a surface or face and the edges or entities that form the loop are selected. If more than one loop exists, you must select the desired one.
Creating Solid Revolve Features

Create revolved features from 2-D sketches.

- Revolve a section about the axis of revolution in a sketching plane.
- Add or remove material from the model.
- Select different axes of revolution.
  - First geometry centerline
  - Axis or edge

Viewing 2-D Sketches

Creating Solid Revolve Features

A revolve feature is based on a two-dimensional sketch. You can use a revolve feature to revolve a sketch about an axis of revolution (in the sketching plane) to create or remove material. You can either select the sketch first and start the Revolve tool, or you can start the Revolve tool and then select the sketch.

When you select a sketch to be revolved, the feature uses, by default, the first geometry centerline sketched within the section as the axis of revolution, as shown in the left image in the lower-left figure. However, you can also select any other straight curve or edge, datum axis, or coordinate system axis as the axis of revolution. If the sketch you are revolving does not contain a geometry centerline, you will need to select one of these other references as the axis of revolution. In the right image in the lower-left figure, the axis of revolution has been changed to the REV datum axis. There are two rules for defining the axis of revolution:

1. Geometry must be sketched only on one side of the axis of revolution.
2. The axis of revolution must lie in the sketching plane of the section.

You can revolve either an open or closed sketch. In the figures, a closed sketch is used to create the feature that adds material, while an open section is used to create the cut that removes material.

You can also thicken the sketch used to create a revolve feature.
Creating Draft Features

Draft features are typically used as finishing features in molded and cast parts.

• Draft features consist of:
  – Draft surfaces
  – Draft hinges
  – Pull direction
  – Draft angles

Creating Draft Features Theory

You can use draft features as finishing features in molded and cast parts, or anywhere sloped or angled surfaces need to be created. You can define several types of draft features by selecting different combinations of curves, edges, surfaces, and planes for the draft surfaces, draft hinges, pull direction, and split plane (optional). Drafts can add or remove material from a model.

A basic draft feature consists of the following four items:

• Draft surfaces — These are the surfaces that are to be drafted. You can select a single surface, multiple individual surfaces, or loop surfaces as the draft surfaces. In the upper-right figure, the left image has one surface drafted, while the right image has four surfaces drafted.

• Draft hinge — Determines the location on the model that remains the same size after the draft is created. The draft surfaces pivot about their intersection with this plane. There does not have to be a physical intersection. Rather, the intersection can be extrapolated. You can select a datum plane, solid model surface, curve chain, or surface quilt as the draft hinge. In the lower figure, the same model was drafted at the same angle, but with the specified draft hinge progressively lower in the model, as highlighted.

• Pull direction — Direction that is used to measure the draft angle. The pull direction is also called the reference plane. By default, the pull direction
is the same as the draft hinge. The direction reference is used to define the draft angle direction, and the draft angle is measured normal to this reference. You can select a datum plane, planar model surface, linear reference such as an edge or two points, or a coordinate system axis. The mold opening, or pull direction, is usually normal to this plane.

- Draft angle — Values range from -30 degree to +30 degrees. When you specify the draft angle, you can reverse the direction that material is added or removed by entering a negative value or clicking the Reverse Angle icon in the dashboard, or by right-clicking on the angle drag handle and selecting Flip Angle.

You can also switch to the different collectors for draft surfaces, draft hinges, and pull direction by right-clicking in the graphics area.

**Best Practices**

If possible, create draft features as some of the last features of your model.
Creating Rounds Theory

Rounds add or remove material by creating smooth transitions between existing geometry.

- Rounds can add or remove material.
- You can select edges or surfaces.

Creating Rounds Theory

Rounds add or remove material by creating smooth transitions between existing geometry. In the lower-right figure, one round adds material and the other removes material. When creating round features on a model, Creo Elements/Pro awaits the selection of edges and/or surfaces to be used as references. The round tool adapts according to the references that you select to create the round feature.

After the references are selected, the round preview appears with a default radius dimension, which can be modified by using the radius drag handle, by editing the dimension on the model, or by using the dashboard. In the upper figure, the round preview is displayed.
Axis Patterning in the First Direction

The axis pattern enables you to pattern features radially about a specified axis.

- Direction based on selected axis.
- Specify number of members and angular spacing.
- Set angular extent.
- Specify member orientation.
- Specify additional, optional dimensions to increment.

Pattern Features Theory

The Pattern tool enables you to quickly duplicate a feature, group of features, or pattern of features. When you create a pattern, you create instances of the selected feature by varying some specified dimensions. The feature selected for patterning is called the pattern leader, while the patterned instances are called pattern members. Each pattern member is dependent on the original feature, or pattern leader.

Axis Patterning in the First Direction Theory

The axis pattern enables you to pattern features radially about a specified axis. The following items are required to create an axis pattern in one direction:

- Specify the axis reference — The pattern extends angularly about the selected reference axis. You can flip the angular direction the pattern extends from clockwise to counterclockwise. In the figures, the axis reference specified is datum axis AXIS.
- Specify the number of pattern members in the first direction — Type the number of members in either the dashboard or the graphics area. The number of pattern members includes the pattern leader. In the lower figures, there are six pattern members.
• Specify the angular spacing — Specified in degrees, you can edit the angular spacing in the dashboard, the graphics area, or by dragging the drag handle.

There are two additional optional settings that you can use when creating axis patterns:

• Set Angular Extent — This option automatically spaces the pattern members equally about the axis reference. You can also select values of 90, 180, 270, and 360 degrees from the drop-down list, or type in the desired angular extent. The range is -360 to +360 degrees. The angular extent value will supersede the angular spacing. In the figures, the angular extent has been set to 360 degrees.

• Member orientation — Determines how the pattern members are to be oriented about the axis reference. With the check box Follow axis rotation selected by default, pattern members are oriented such that the relationship between the pattern leader and axis is maintained for each pattern member. In the lower figure, the middle image is set to Follow axis rotation. With the check box for this option cleared, all pattern members have a constant orientation that is the same as the pattern leader. In the lower figure, the left-most image shows all members having a constant orientation.

Incrementing Additional Dimensions

You can also increment additional dimensions in the first direction at the same time to create a "varying" pattern. The following items are required to increment additional dimensions in the first direction:

• Select the dimension to be incremented from the pattern leader. The pattern leader displays with all dimensions used to create the feature.

• Specify the increment value — In the lower figure, the extrude feature length was incremented 0.3 in the right-most image. Consequently, each pattern member's length increases 0.3 over the previous pattern member.
Viewing and Editing Model Properties

There is a consolidated dialog box for all model properties.

Model Properties Dialog Box

Viewing and Editing Model Properties Theory

The Model Properties dialog box provides common locations for viewing and editing model properties in several categories. Each line item in the dialog box provides basic information at a glance.

Some properties can be expanded by clicking Expand to display additional information.

Clicking Info produces a separate information window with more detailed information.

To create or edit any of the properties, click the change link in the dialog box. The appropriate dialog box for that property then appears.

Several of the model properties listed in this dialog box can be accessed through other menus or dialogs.

The following is a list of the properties contained in the Model Properties dialog box, which is accessed by clicking File > Properties.

- Materials
• Material
• Units
• Accuracy
• Mass Properties
• Relations, Parameters, and Instances
  – Relations
  – Parameters
  – Instance
• Features and Geometry
  – Tolerance
  – Names
• Tools
  – Flexible
  – Shrinkage
  – Simplified Representation
  – Pro/Program
  – Interchange
• Model Interfaces
  – Reference Control
Analyzing Mass Properties

You can calculate a model's mass properties.

- Mass properties include:
  - Volume
  - Surface area
  - Density
  - Mass
  - COG

- Analyses require model density.
- Density units are the same as model units.
- For assemblies, a density for each component is required.

Viewing Mass Properties

Performing a Mass Properties Analysis

Analyzing Mass Properties

You can view a model's mass properties within the Materials section of the Model Properties dialog box. You can also calculate the mass properties by clicking Analysis > Model > Mass Properties from the main menu. Before you can calculate accurate mass properties for a model, however, its density must be defined. A mass properties calculation is dependent upon the density entered for a given model. If the density is updated for a model and its mass properties are recalculated, the results update.

When the system performs a mass properties analysis, the following mass property information is calculated:

- Volume
- Surface Area
- Density
- Mass
- Center of Gravity — The center of gravity (COG) is displayed on the model as a coordinate system with axes 1, 2, and 3, as shown in the lower figure.
You can also perform mass properties analyses on assemblies. However, you must first configure the density of each part model.

**Mass Properties Analysis Options**

There are three options available when performing a mass properties analysis:

- **Quick** — Enables you to compute mass properties without saving the analysis or creating a mass properties feature in the model tree.

- **Saved** — Enables you to save the mass properties analysis for future use. You can specify a unique name for the analysis so it means something to you at a later time. You can retrieve the saved analyses by clicking **Analysis > Saved Analysis** from the main menu.

- **Feature** — Enables you to save the mass properties analysis as a feature in the model tree.
Measuring Models

Several types of measurements can be made on models.

- Measurements include:
  - Diameter
  - Area
  - Length
  - Angles
  - Distances
- Measurements can be saved for quick reuse.
- Measurement units are the same as current model units.

Measuring Diameters

You can measure the diameter of a cylindrical surface. Surfaces can include those created by revolving a sketched entity, extruding a sketched arc, extruding a sketched circle, or round features. When measuring a diameter, you select the surface you wish to measure, and Creo Elements/Pro displays the measurement. The entity you select is called the surface reference. In the lower figure, the diameter of the cylindrical surface is 14.

You can also measure the diameter at a selected point on a surface. This measurement is good for surfaces with non-constant diameter.

Measuring Area

You can measure the area of a surface, quilt, facet, or the entire model. The entity you select is called the geometry reference. You can also select a direction reference to project the area onto a two-dimensional plane.

Measuring Length

You can measure the length of curves or edges on a model. Simply select an edge or curve to display its length. You can also measure an edge chain.
Creo Elements/Pro will report the total length of all selected edges, as shown by the red highlighted edges in the lower figure.

**Measuring Angles**

You can measure the angle between two entities. These two entities are called the “From” reference and the “To” reference, and can consist of surfaces, planes, or edges. You can also specify the direction reference, which projects the angle of the entities onto a two-dimensional plane. When measuring angles, you can optionally modify the Plot Scale and Plot Range that Creo Elements/Pro uses to display the measurement. Scale enables you to adjust the scale of the arrows using the wheel button, specifying the required scale, or by dragging the scale handle. Range enables you to display the angle from 0–360 degrees or from +/-180 degrees.

**Measuring Distances**

You can measure the distance between two references. These two references are called the “From” reference and the “To” reference. You can select points and vertices, edges and curves, surfaces and planes, and axes and coordinate systems.

You can also measure the distance in a projected direction. There are two types of projected distances that can be measured:

- **Direction Reference** — Enables you to measure a distance projected in the direction of a selected reference. In the lower figure, the distance between two vertices, 24.9280, is projected along the model's side planar surface for a value of 21. Measuring projected distances is beneficial because it enables you to easily select a direction reference instead of having to create specific geometry in order to create the measurement.

- **View Plane** — Enables you to measure the projected distance based upon the orientation of the part in the graphics area.

**Measurement Options**

There are three options available when measuring geometry on models:

- **Quick** — Enables you to compute measurements without saving the analysis or creating a measurement feature in the model tree.

- **Saved** — Enables you to save the measurement for future use. You can specify a unique name for the measurement analysis so it means something to you at a later time. You can retrieve the saved analyses by clicking **Analysis > Saved Analysis** from the main menu.

- **Feature** — Enables you to save the measurement as a feature in the model tree.
Measuring Global Interference

You can calculate interferences between components in an assembly.

- Setup:
  - Parts only
  - Sub-assembly only
- Computation type:
  - Exact
  - Quick
- Interference pairs:
  - Highlighted in the model
  - Volume can be calculated

Measuring Global Interference

You can calculate interferences between components in an assembly. There are two different setup options available when computing global interference:

- Parts only — Interference is checked between all parts, regardless of which sub-assembly, if any, they belong to.
- Sub-assembly only — Interference is checked between all sub-assemblies in the top level assembly without determining whether individual parts within the sub-assembly interfere.

When components interfere, the geometry of one part is embedded in another part. The system displays the interference between these two components as a pair in the Global Interference dialog box. Selecting the interfering pair in the dialog box causes the components to be highlighted in the graphics area, as shown in the figures. There are two different computational methods available for computing interferences:

- Exact — When selecting the interfering pair, in addition to highlighting the interfering components, the system also highlights the interfering volume shared between the two components. In addition, the volume of
interference is calculated and displayed in the dialog box, as shown in the upper figure.

- Quick — When selecting the interfering pair, in addition to highlighting the interfering components, the system highlights the approximate interfering volume with a plus symbol in the graphics area, as shown in the lower figure. The volume of interference is not calculated.

**Analysis Options**

There are three options available when computing global interference on models:

- **Quick** — Enables you to compute global interference without saving the analysis or creating a feature in the model tree.
- **Saved** — Enables you to save the analysis for future use. You can specify a unique name for the global interference analysis so it means something to you at a later time. You can retrieve the saved analyses by clicking **Analysis > Saved Analysis** from the main menu.
- **Feature** — Enables you to save the global interference analysis as a feature in the model tree.
Introduction to Creo Elements/Pro

Copyright © 2009 Parametric Technology Corporation. All Rights Reserved.

User and training guides and related documentation from Parametric Technology Corporation and its subsidiary companies (collectively “PTC”) is subject to the copyright laws of the United States and other countries and is provided under a license agreement that restricts copying, disclosure, and use of such documentation. PTC hereby grants to the licensed software user the right to make copies in printed form of this documentation if provided on software media, but only for internal/personal use and in accordance with the license agreement under which the applicable software is licensed. Any copy made shall include the PTC copyright notice and any other proprietary notice provided by PTC.

Training materials may not be copied without the express written consent of PTC. This documentation may not be disclosed, transferred, modified, or reduced to any form, including electronic media, or transmitted or made publicly available by any means without the prior written consent of PTC and no authorization is granted to make copies for such purposes.

Information described herein is furnished for general information only, is subject to change without notice, and should not be construed as a warranty or commitment by PTC. PTC assumes no responsibility or liability for any errors or inaccuracies that may appear in this document.

The software described in this document is provided under written license agreement, contains valuable trade secrets and proprietary information, and is protected by the copyright laws of the United States and other countries. It may not be copied or distributed in any form or medium, disclosed to third parties, or used in any manner not provided for in the software licenses agreement except with written prior approval from PTC.

UNAUTHORIZED USE OF SOFTWARE OR ITS DOCUMENTATION CAN RESULT IN CIVIL DAMAGES AND CRIMINAL PROSECUTION. PTC regards software piracy as the crime it is, and we view offenders accordingly. We do not tolerate the piracy of PTC software products, and we pursue (both civilly and criminally) those who do so using all legal means available, including public and private surveillance resources. As part of these efforts, PTC uses data monitoring and scouting technologies to obtain and transmit data on users of illegal copies of our software. This data collection is not performed on users of legally licensed software from PTC and its authorized distributors. If you are using an illegal copy of our software and do not consent to the collection and transmission of such data (including to the United States), cease using the illegal version, and contact PTC to obtain a legally licensed copy.

For Important Copyright, Trademark, Patent, and Licensing Information:

For Windchill products, select About Windchill at the bottom of the product page. For InterComm products, on the Help main page, click the link for Copyright 20xx. For other products, click Help > About on the main menu of the product.

Registered Trademarks of PTC


Trademarks of PTC

AMPLE, and Design Manager are trademarks of Mentor Graphics Corporation. Helix is a trademark of Microcadam, Inc. Microsoft, ActiveX, Excel, JScript, Vista, Windows, the Windows logo, Visual Basic, the Visual Basic logo, SharePoint, and Active Accessibility are trademarks or registered trademarks of Microsoft Corporation in the United States and/or other countries. Moldflow is a registered trademark of Moldflow Corporation. Mozilla and Firefox are registered trademarks of the Mozilla Foundation. FLEXnet, FLEXnet Publisher, InstallShield, and InstallAnywhere are trademarks or registered trademarks of Acesso Software Inc. Netscape, Netscape Navigator, Netscape Communicator, and the Netscape N and Ship's Wheel logos are registered trademarks or service marks of Netscape Communications Corporation in the U.S. and other countries. OSF/Motif and Motif are trademarks of the Open Software Foundation, Inc. Oracle and interMedia are registered trademarks of Oracle Corporation. Palm Computing, Palm OS, Graffiti, HotSync, and Palm Modem are registered trademarks, and Palm III, Palm Ille, Palm Ilx, Palm V, Palm Vx, Palm VII, Palm, More connected, Simply Palm, the Palm Computing platform logo, all Palm logos, and HotSync logo are trademarks of Palm, Inc. or its subsidiaries. PANTONE is a registered trademark and PANTONE CALIBRATED is a trademark of Pantone, Inc. Proximity and Linguibase are registered trademarks of Proximity Technology, Inc. Elan License Manager and Softlock are trademarks of Rainbow Technologies, Inc. RAND is a trademark and Partner Interface Process and PIP are registered trademarks of RosettaNet, a nonprofit organization. SAP and R/3 are registered trademarks of SAP AG Germany.IRIX is a registered trademark of Symbolics, Inc. S1000D (R) is a registered trademark of ASD. SolidWorks and eDrawings are trademarks or registered trademarks of SolidWorks Corporation. SPARC is a registered trademark and SPARCStation is a trademark of SPARC International, Inc. (Products bearing the SPARC trademarks are based on an architecture developed by Sun Microsystems, Inc.) All SPARC trademarks are used under license and are trademarks or registered trademarks of SPARC International, Inc. in the United States and in other countries. Sun, Sun Microsystems, the Sun logo, Solaris, UltraSPARC, Java and all Java based marks, and "The Network is the Computer" are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States and in other countries. Symbolics, CLOE Runtime, and Minima are trademarks, and CLOE, Genera, and Zetalisp are registered trademarks of Symbolics, Inc. UNIX is a registered trademark of The Open Group. TIBCO is a registered trademark and TIBCO ActiveEnterprise, TIBCO Designer, TIBCO Enterprise Message Service, TIBCO Rendezvous, and TIBCO BusinessWorks are trademarks or registered trademarks of TIBCO Software Inc. in the United States and/or other countries. LightWork Libraries are copyrighted by LightWork Design, Parasolid, SHERPA, Solid Edge, TeamCenter, UG NX, and Unigraphics are trademarks or registered trademarks of UGS Corp., a Siemens group company. Galaxy Application Environment is a licensed trademark of Visix Software, Inc. WebEx is a trademark of WebEx Communications, Inc. API Toolkit is a trademark of InterCap Graphics Systems, Inc. BEA and WebLogic are registered trademarks of BEA Systems, Inc. X Window System is a trademark of X Consortium, Inc.

VERICUT is a copyrighted software and a registered trademark of CGTech. Product may contain RealDWG technology by Autodesk, Inc., Copyright 1998-2006 Autodesk, Inc. All rights reserved (www.autodesk.com/autodeskskreadwg). File Filters © 1986-2002 Circle Systems, Inc. Certain business intelligence reporting functionality is powered by Cognos. DFORMD.DLL is copyrighted software from Compaq Computer Corporation and may not be distributed. Pro/TOOLMAKER contains licensed third-party technology: 5AXMSURF is copyrighted software of ModuleWorks GmbH. Certain 3D Read CAD data exchange tools are copyrighted software of Datakit SRL. Hyphenologist Copyright 1986-1999, Computer Hyphenation Ltd. All rights reserved. RetrievalWare is copyrighted software of Convera Corporation. DataDirect Connect is copyrighted software of DataDirect Technologies. PStill and PSRaster software is copyright © Dipl.- Ing. Frank Siegent, 1996 to present. FAST InStream is copyright © of Fast Search & Transfer, Inc. Portions of the Mathcad Solver © 1990-2002 by Frontline Systems, Inc. Exceed and Exceed 3D are copyrighted software of Hummingbird Ltd., a division of Open Text Corporation. Rational Rose and Rational ClearCase are copyrighted software of IBM Corp. IBM Corporation does not warrant and is not responsible for the operation of this software product. G POST is copyrighted software and a registered trademark of Austin NC. Xdriver and 3dxsrv are copyrighted software of 3Dconnexion, Inc, a Logitech International S.A. company. Larson CGM Engine 9.4, Copyright © 1992-2006 Larson Software Technology, Inc. All rights reserved. LightWork Libraries are copyrighted by LightWork Design 1990–2001. MainWin Dedicated Libraries are copyrighted software of Mainsoft Corporation. Microsoft Jet, Microsoft XML, Technology "Powered by Groove", Microsoft SQL Server 2005, Visual Basic for Applications, Internet Explorer and Portals compiled from Microsoft Developer Network Redistributable Sample Code, including Microsoft DLL redistributables, are all copyrighted software of Microsoft Corporation. pro/PLASTIC ADVISOR is powered by Moldflow technology. Fatigue Advisor nCode libraries from nCode International. NuTCRACKER Server Operating Environment is copyrighted software of MKS Inc.

Oracle 8i run time, Oracle 9i run time, and Oracle 10g run time are Copyright 2002–2004 Oracle Corporation. Oracle programs provided herein are subject to a restricted use license and can only be used in conjunction with the PTC software they are provided with. PDFlib software is copyright © 1997-2005 PDFlib GmbH. All rights reserved. Proximity Linguistic Technology provides Spelling Check/Thesaurus portions of certain software products, including: The Proximity/Bertelsmann Lexikon Verlag Database. Copyright © 1997 Bertelsmann Lexikon
LAPACK libraries used are freely available at http://www.netlib.org (authors are Anderson, E. and Bai, Z. and Bischof, C. and Blackford, S. and Demmel, J. and Dongarra, J. and Du Croz, J. and Greenbaum, A. and Hammarling, S. and McKenney, A. and Sorensen, D.). Certain software components licensed in connection with the Apache Software Foundation and/or pursuant to the Apache Software License Agreement (version 2.0 or earlier) or similar style license. All rights are reserved by the Licensor of such works, and use is subject to the terms and limitations (and license agreement) at http://www.apache.org. This software is provided by its Contributors AS IS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, and any expressed or implied warranties, including, but not limited to, the implied warranties of title non-infringement, merchantability and fitness for a particular purpose are disclaimed. In no event shall the Apache Software Foundation or its Contributors be liable for any direct, indirect, incidental, special, exemplary, or consequential damages (including, but not limited to, procurement of substitute goods or services; loss of use, data, or profits; or business interruption) however caused and on any theory of liability, whether in contract, strict liability, or tort (including negligence or otherwise) arising in any way out of the use of this software, even if advised of the possibility of such damage. Software includes: Apache Server, Axis, Ant, Tomcat, Xalan, Xerces, Batik, Jakarta, Apache POI, Jakarta Regular Expression, Commons-FileUpload, Solr, Tika, and XMLBeans IBM XML Parser for Java Edition, the IBM SaxParser and the IBM Lotus XSL Edition DITA-OT - Apache License Version 1.1; Java-based Software Installers Generator (http://www.izforge.org/izpack/start) Jakarta–ORO NekoHTML and CyberNeko Pull Parser software developed by Andy Clark © Copyright Andy Clark. All rights reserved. Lucene (http://lucene.apache.org) Quartz (scheduler) Copyright 2004-20xx OpenSymphony (http://www.opensymphony.com/quartz/) Jetty Copyright Mortbay.ORG (http://www.mortbay.org/mibindex.html) Google Web Toolkit, Google Web Toolkit (GWT) Incubator, and GWTx; Copyright Google U3D Library Copyright 1999 - 2006 Intel Corporation MyFaces (http://myfaces.apache.org/index.html) JDBCApender (http://www.dankomannhaupt.de/projects/index.html) EHcache Copyright 2003-2007 Luck Consulting Pty Ltd (http://ehcache.sourceforge.net/) cglib Copyright 2002-2004 (http://cglib.sourceforge.net/) LOG4PLSQL Copyright 2002 The LOG4PLSQL project team. All rights reserved (http://log4plsql.sourceforge.net) Log4cxx (http://logging.apache.org/log4cxx/index.html) SPRING See www.springframework.org, JspComponent project software (http://hc.apache.org/) Commons Codec (http://commons.apache.org/codec/) Apache Log4net (http://logging.apache.org/log4net/) Beans Scripting Framework (BSF) Copyright 2002-2006 The Apache Software Foundation - includes software developed at The Apache Software Foundation (http://www.apache.org/) WebFX Coolbar 2 (http://webfx.eae.net) WebFX Cross Browser tree Widget 1.17 (http://webfx.eae.net) PCRE 7.2 (http://www.pcre.org/) JDOM Copyright 2000-2004 Jason Hunter & Brett McLaughlin. All rights reserved. This software consists of voluntary contributions made by many individuals on behalf of the JDOM Project (http://www.jdom.org/) The Ajax Control Toolkit (including compiled, object code and source code versions) are licensed only pursuant to the Microsoft Public License (Ms-PL) which can be found at http://www.codeplex.com/AjaxControlToolkit. Microsoft Ajax Library provided pursuant to the Microsoft Software Supplemental License Terms for Microsoft ASP.NET 2.0 AJAX Extensions. The Boost Library - Misc. C++ software from http://www.boost.org; Provided pursuant to: Boost Software License http://www.boost.org/license_1_0.txt. AspectJ (http://www.eclipse.org/aspectj/) and Eclipse SWT (http://www.eclipse.org/swt/); Copyright 20xx The Eclipse Foundation are distributed under the Eclipse Public License (EPL) (http://www.eclipse.org/org/documents/epl-v10.php) and is provided AS IS by authors with no warranty therefrom and any provisions which differ from the EPL are offered by PTC. Upon request, PTC will provide the source code for such software for a charge no more than the cost of performing this distribution. Command Line Argument Parser. Author peterhal@microsoft.com is licensed pursuant to the Shared Source License for Command Line Parser Library and is provided by the author "as is" with no warranties (none whatsoever). This means no express, implied, or statutory warranty, including without limitation, warranties of merchantability or fitness for a particular purpose, or any warranty of title or noninfringement. No contributor to the Software will be liable for any of those types of damages known as indirect, special, consequential, or incidental related to the Software to the maximum extent the law permits, no matter what legal theory it's based on. The following software is incorporated pursuant to the "BSD License" (Berkeley Software Distribution) or a similar style license; icaj4 is Copyright © 2005, Ben Fortuna. All rights reserved. Dojo – Copyright 2005, The Dojo Foundation, All rights reserved. Jaxen (shipped as part of dom4j) Copyright 2003-2006 The Werken Company. All Rights Reserved. XMP (eXtensible Metadata Platform) technology from Adobe - Copyright © 1999 - 2007, Adobe Systems Incorporated. All rights reserved. Groovy Copyright 2000 James Strachan andob McVicar. All Rights Reserved. Firebug Copyright 2007, Parakey Inc. JMSN (http://sourceforge.net/projects/jmsn/) Thumb Plug TGA Copyright 1991-2003 Echidna, Inc. All rights reserved. ASM Copyright 2000-2005 INRIA, France Telecom. All rights reserved. PDFBox Copyright 2002-2007, www.pdfbox.org. All rights reserved. BerkeleyDB (as used with OpenDS); Copyright 1990-20xx Oracle Corporation. All rights reserved.
Expressions – Basic Library Functions written by: Philip Hazel. Email local part: ph10. Email domain: cam.ac.uk. University of Cambridge Computing Service, Cambridge, England. Copyright 1997-2008 University of Cambridge. All rights reserved. SIMILE Copyright The SIMILE Project 2006. All rights reserved. Note that JQuery: Copyright 2008 John Resig (www.jquery.com), is included in the Ajax section of this distribution and is covered under the MIT LICENSE (see below). Launch4j (http://launch4j.sourceforge.net/). The head subproject (the code which is attached to the wrapped jars) is licensed under the MIT license. Launch4j may be used for wrapping closed source, commercial applications. JempBox Java XMP Library: Copyright 2006-2007, www.jempbox.org. All rights reserved. FontBox - Copyright 2003-2005, www.fontbox.org. All rights reserved. ANTLR Copyright 2003-2008, Terence Parr. All rights reserved. Provided pursuant to ANTLR 3 License. (http://www.antlr.org/license.html) NativeCall Java Toolkit (http://sourceforge.net/projects/nativecall/) Redistribution and use of the above in source and binary forms, with or without modification, is permitted provided that the following conditions are met: (i) Redistributions of source code must retain the above copyright notice, this list of conditions, and the following disclaimer; (ii) Redistributions in binary form must reproduce the above copyright notice, this list of conditions, and the following disclaimer in the documentation and/or other materials provided with the distribution; and (iii) Neither the name of the copyright holder nor the names of any other contributors may be used to endorse or promote products derived from this software without specific prior written permission. THE ABOVE SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS AS IS AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. The Java Getopt.jar file, copyright 1987 1997 Free Software Foundation, Inc. #ZipLib GNU software is developed for the Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA, copyright © 1989, 1991. PTC hereby disclaims all copyright interest in the program #ZipLib written by Mike Krueger. #ZipLib licensed free of charge and there is no warranty for the program, to the extent permitted by applicable law. Except when otherwise stated in writing the copyright holders and/or other parties provide the program AS IS without warranty of any kind, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The entire risk as to the quality and performance of the program is with you. Should the program prove defective, you assume the cost of all necessary servicing, repair, or correction. The following software is incorporated pursuant to the "MIT License" (or a similar license): SLF4J source code and binaries Copyright 2004-20xx QOS.ch. All rights reserved. Script.aculo.us (built on "prototype.conio.net"). Copyright 2005 Thomas Fuchs (http://script.aculo.us, http://mir.aculo.us). ICU4J software Copyright 1995-2003 International Business Machines Corporation and others. All rights reserved. Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization of the copyright holder. json library: Copyright 2002 JSON.org. XPM Copyright 1989-95 GROUPE BULL. DynamicToolbar FCKeditor plugin, v1.1 (080810); Copyright 2008, Gonzalo Perez de la Ossa (http://dense13.com/). JQuery Copyright 2008 John Resig (www.jquery.com) NATIVECALL (C) 2002–2008 Johann Burkard. All rights reserved. (http://johannburkard.de/software/nativecall/) The above software is used and redistributed under the following permissions: Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. The Java™ Telnet Applet (StatusPeer.java, TelnetIO.java, TelnetWrapper.java, TimedOutException.java), Copyright © 1996, 97 Mattias L. Jugel, Marcus Meißner, is redistributed under the GNU General Public License. This license is from the original copyright holder and the Applet is provided WITHOUT WARRANTY OF ANY KIND. You may obtain a copy of the source code for the Applet at http://www.mud.de/se/jta (for a charge of no more than the cost of physically performing the source distribution), by sending e mail to leo@mud.de or marcus@mud.de—you are allowed to choose either distribution method. Said source code is likewise provided under the
GNU General Public License. The following software, which may be called by certain PTC software products, is licensed under the GNU General Public License (http://www.gnu.org/licenses/gpl.txt) and if used by the customer is provided AS IS by the authors with no warranty therefrom without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE (see the GNU GPL for more details). Upon request PTC will provide the source code for such software for a charge no more than the cost of performing this distribution: The PJA (Pure Java AWT) Toolkit library (http://www.eteks.com/pja/en). The following unmodified libraries are likewise distributed under the GNU GPL: libstdc and #ziplib (each are provided pursuant to an exception that permits use of the library in proprietary applications with no restrictions provided that the library is not modified). The following products are licensed with the Classpath exception (Linking this library statically or dynamically with other modules is making a combined work based on this library. Thus, the terms and conditions of the GNU General Public License cover the whole combination. As a special exception, the copyright holders of this library give you permission to link this library with independent modules to produce an executable, regardless of the license terms of these independent modules, and to copy and distribute the resulting executable under terms of your choice, provided that you also meet, for each linked independent module, the terms and conditions of the license of that module. An independent module is a module which is not derived from or based on this library: javax.media.j3d package; Copyright 1996-2008 Sun Microsystems, Inc., 4150 Network Circle, Santa Clara, CA 95054, USA. All rights reserved. The source code is licensed under the GNU Public License, version 2. This project contains the following third-party source code that is provided under separate licensing terms (These terms are found in the THIRDPARTY-LICENSE-*.txt files in the top-level directory of this project. See the README-FIRST.txt for more information.), 3D Graphics API for the Java Platform 1.6.0 Pre-Release licensed under the GNU Public License, version 2, with the Classpath Exception. #ziplib (SharpZipLib, formerly NZipLib), a Zip, GZip, Tar and BZip2 library, Copyright 2000-20xx IC#Code. All rights reserved. #ziplib was originally developed by Mike Krueger (mike@icsharpcode.net), with the following attributions: (i) Zip/Gzip implementation (a Java version of the zlib) originally created by the Free Software Foundation (FSF); (ii) zlib authors Jean-loup Gailly (jloup@gzip.org), Mark Adler (madler@alumni.caltech.edu) and its other contributors; (iii) Julian R Seward for the bzip2 implementation; (iv) the Java port done by Keiron Liddle, Aftex Software (keiron@aftexsw.com); (v) tar implementation by Timothy Gerard Endres (time@git.org); and (vi) Christoph Wille for beta testing, suggestions, and the setup of the Web site. The following is distributed under GNU Lesser General Public License (LGPL) which is at http://www.gnu.org/copyleft/lesser.html and is provided AS IS by authors with no warranty therefrom without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE (see the GNU LGPL for more details). Upon request, PTC will provide the source code for such software for a charge no more than the cost of performing this distribution: eXist, an Open Source Native XML Database. You may obtain a copy of the source code at http://exist.sourceforge.net/index.html. The source code is likewise provided under the GNU LGPL. GTK+ - The GIMP Toolkit. You may obtain a copy of the source code at http://www.gtk.org/, which is likewise provided under the GNU LGPL. Java Port copyright 1998 by Aaron M. Renn (arenn@urbanophile.com). You may obtain a copy of the source code at http://www.urbanophile.com/arenn/hacking/download.html. The source code is likewise provided under the GNU LGPL. JFreeChart is licensed under the GNU LGPL. Java Port copyright 1998 by Aaron M. Renn (arenn@urbanophile.com). You may obtain a copy of the source code at http://www.urbanophile.com/arenn/hacking/download.html. The source code is likewise provided under the GNU LGPL. OmniORB Libraries (OmniOrb) is distributed under the terms and conditions of the GNU General Public License). The generic AIM library provided pursuant to the JAIMBot project (http://jaimbot.sourceforge.net/). JAIMBot is a modular architecture for providing services through an AIM client. It contains a generic AIM library and a Bot that uses this library to provide such services as Offline Messaging and Weather. PTC does not use the Bot. JExcelApi (http://jexcelapi.sourceforge.net/). 7-Zip Copyright 1999-2006 Igor Pavlov (http://www.7-zip.org). libiconv Copyright 1991 Free Software Foundation, Inc. (http://www.gnu.org/software/libiconv/). NHibernate © 200x, Red Hat Middleware, LLC. All rights reserved (http://www.hibernate.org/343.html). MPXJ © 2000-2008, Packwood Software (http://mpxj.sourceforge.net/). Java Server Faces V3.0.1 (http://java.sun.com/javase/javaserverfaces/). DevL Image Lib 0.1.6.7 (http://openl.sourceforge.net/). Zip Master Component Lib 1.79 (http://www.delphzip.org). Exadel RichFaces 3.0.1 (http://www.exadel.com). Jfree / Jfree Chart 1.0.0 (http://www.jfree.org/). Memory DLLLoading code 0.0.1 (http://www.dsplayer.de/open source projects/BTMemoryModule.zip). May include Jena Software © Copyright 2000, 2001, 2002, 2003, 2004, 2005 Hewlett-Packard Development Company, LP: THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. Jena includes: Jakarta-ORO software developed by the Apache Software Foundation (described above).

ICU4J software Copyright © 1995-2003 International Business Machines Corporation and others All rights reserved. Software is used under the MIT license described above. Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization of the copyright holder. CUP Parser Generator Copyright ©1996-1999 by Scott Hudson, Frank Flannery, C. Scott Ananian—used by permission. The authors and their employers disclaim all warranties with regard to this software, including all implied warranties of merchantability and fitness. In no event shall the authors or their employers be liable for any special, indirect or consequential damages, or any damages whatsoever resulting from loss of use, data or profits, whether in an action of contract, negligence or other tortious action arising out of or in connection with the use or performance of this software. ImageMagick software is Copyright © 1999-2005 ImageMagick Studio LLC, a nonprofit organization dedicated to making software imaging solutions freely available. ImageMagick is freely available without charge and provided pursuant to the following license agreement: http://www.imagemagick.org/script/license.php. Info-Zip and UnZip (© 1990 2001 Info ZIP, All Rights Reserved) is provided AS IS and WITHOUT WARRANTY OF ANY KIND. For the complete Info ZIP license see http://www.info-zip.org/doc/LICENSE. “Info-ZIP” is defined as the following set of individuals: Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-Ioup Gailly, Hunter Godfrey, Ed Gordon, Ian Gorman, Chris Herbold, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson, Paul Kienitz, David Kirschaubarm, Johnny Lee, Onno van der Linden, Igor Mandrichenkov, Steve P. Miller, Sergio Monesi, Keith Owens, George Petrov, Greg Roseofs, Kai Uwe Rommel, Steve Salisbury, Dave Smith, Steven M. Schweda, Christian Spieler, Corinna Truta, Antoine Verheijen, Paul von Behren, Rich Wales, and Mike White. ICU Libraries (International Components for Unicode) Copyright 1995-2001 International Business Machines Corporation and others, all rights reserved. Libraries are provided pursuant to the ICU Project (notice is set forth above) at http://www-306.ibm.com/software/globalization/icu/index.jsp. The Independent JPEG Group's JPEG software. This software is Copyright © 1991-1998, Thomas G. Lane. All Rights Reserved. This software is based in part on the work of the Independent JPEG Group. iTex Library - Copyright © 1999-2006 by Bruno Lowagie and Paulo Soares. All Rights Reserved – source code and further information available at http://www.lowagie.com/iText. jpeg-6b.zip - JPEG image compression library, version 6.2. Used to create images for HTML output; Provided pursuant to: http://www.faqs.org/faqs/jpeg-faq/part2. Pop up calendar components Copyright © 1998 Netscape Communications Corporation. All Rights Reserved. METIS, developed by George Karypis and Vipin Kumar at the University of Minnesota, can be researched at http://www.cs.umn.edu/~karypis/metis. Mozilla Japanese localization components are subject to the Netscape Public License Version 1.1 (at http://www.mozilla.org/NPL), Software distributed under the Netscape Public License (NPL) is distributed on an AS IS basis, WITHOUT WARRANTY OF ANY KIND, either expressed or implied (see the NPL for the rights and limitations that are governing different languages). The Original Code is Mozilla Communicator client code, released March 31, 1998 and the Initial Developer of the Original Code is Netscape Communications Corporation. Portions created by Netscape are Copyright © 1998 Netscape Communications Corporation. All Rights Reserved. Contributors: Kazu Yamamoto (kazu@mozilla.gr.jp), Ryoichi Furukawa (furu@mozilla.gr.jp), Tsukasa Maruyama (maruya@mozilla.gr.jp), Teiji Matsuba (matsuba@dream.com). The following components are subject to the Mozilla Public License Version 1.0 or 1.1 at http://www.mozilla.org/MPL (the MPL) and said software is distributed on an AS IS basis, WITHOUT WARRANTY OF ANY KIND, either expressed or implied and all warranty, support, indemnity or liability obligations under PTC's software license agreements are provided by PTC alone (see the MPL for the specific language governing rights and limitations the source code and modifications thereto are available under the MPL and are available upon request): Gecko and Mozilla components Spidermonkey charset Detector Saxon-B (http://www.saxonia.com/documentation/conditions/intro.html). Office Partner Components 1.64 (http://sourceforge.net/projects/opofficepartner/). Rhino JavaScript engine, distributed with a form of the Mozilla Public License (MPL). tiff-v3.4.tar.gz - Libtiff File IO Library version 3.4: (see also http://www.libtiff.org ftp://ftp.sgi.com/graphics/tiff) Used by the image EFI library; Provided pursuant to: http://www.libtiff.org/misc.html. The DITA standards, including DITA DTDs, DITA Schemas, and portions of the DITA specification used in online help; copyright 2005-2009 OASIS Open. All rights reserved. This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit. (http://www.openssl.org/); Copyright © 1998 2004 The OpenSSL Project. All rights reserved. This product includes cryptographic software written by Eric Young (eay@cryptsoft.com) WHICH IS PROVIDED BY ERIC YOUNG "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. This product also includes software written by Tim Hudson (tjh@cryptsoft.com). pcre-4.3-2-src.zip - Perl Compatible Regular Expression Library version 4.3. http://www.pcre.org; Provided pursuant to: PCRE License. png120.zip - PNG image library version 1.2.0. http://www.libpng.org; Provided pursuant to: http://www.libpng.org/pub/png/src/libpng-LICENSE.txt. libpng, Copyright © 2004 Glenn Randers-Pehrson, which is distributed according to the disclaimer and license (as well as the list of Contributing Authors) at http://www.libpng.org/pub/png/src/libpng-LICENSE.txt. METIS is © 1997 Regents of the University of Minnesota.

Curl software, Copyright ©1996 - 2005, Daniel Stenberg. All rights reserved. Software is used under the following permissions: Permission to use, copy, modify, and distribute this software for any purpose with or without fee is hereby granted, provided that the above copyright notice and this permission notice appear in all copies. THE SOFTWARE IS PROVIDED AS IS, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use, or other dealings. Java Advanced Imaging (JAI) is provided pursuant to the Sun Java Distribution License (JDL) at http://www.jai.dev.java.net. The terms of the JDL shall supersede any other licensing terms for PTC software with respect to JAI components. Regular expression support is provided by the PCRE library package, which is open source software, written by Philip Hazel, and copyright by the University of Cambridge, England. This software is based in part on the work of the Independent JPEG Group. Regular Expressions support was derived from copyrighted software written by Henry Spencer, Copyright © 1986 by University of Toronto. SGML parser: Copyright © 1994, 1995, 1996, 1997, 1998 James Clark, 1999 Matthias Clasen. XML parser and XSLT processing was developed using Libxml and Libxslt by Daniel Veillard, Copyright © 2001. libWWW (W3C's implementation of HTTP) can be found at: http://www.w3.org/Library; Copyright © 1994-2000 World Wide Web Consortium, (Massachusetts Institute of Technology, Institut National de Recherche en Informatique et en Automatique, Keio University). All Rights Reserved. This program is distributed under the W3C's Software Intellectual Property License at: http://www.w3.org/Consortium/Legal/2002/copyright-software-20021231. This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See W3C License http://www.w3.org/Consortium/Legal for more details. Copyright © 1995 CERN. "This product includes computer software created and made available by CERN. This acknowledgment shall be mentioned in full in any product which includes the CERN computer software included herein or parts thereof." Perl support was developed with the aid of Perl Kit, Version 5.0. Copyright © 1989-2002, Larry Wall. All rights reserved. The cad2eda program utilizes wxWidgets (formerly wxWindows) libraries for its cross-platform UI API, which is licensed under the wxWindows Library License at http://www.wxwindows.org. ZLib - Compression library; Copyright 1995-2005 Jean-loup Gailly and Mark Adler; Provided pursuant to ZLib License at http://www.zlib.net/zlib_license.html. ATLPort copyright 1999, 2000 Boris Fomitchev is provided by the copyright holder "as is" with absolutely no warranty expressed or implied. Permission to use or copy this software for any purpose is granted without fee, provided the foregoing notices are retained on all copies. Permission to modify the code and to distribute modified code is granted, provided the above notices are retained and a notice that the code was modified is included with the above copyright notice. PTC reserves the right to modify this code and may do so without further notice. OpenCASCADE software is subject to the Open CASCADE Technology Public License Version 6.2 (the "License"). This software may only be used in compliance with the License. A copy of the License may be obtained at http://www.openCASCADE.org. The Initial Developer of the Original Code is Open CASCADE S.A.S., with main offices at 15 bis, rue Ernest Renan 92136, Issy Les Moulineaux, France. The Original Code is copyright © Open CASCADE S.A.S., 2001. All rights reserved. "The Original Code" and all software distributed under the License are distributed by OpenCASCADE on an "AS IS" basis, without warranty of any kind, and the Initial Developer hereby disclaims all such warranties, including without limitation, any warranties of merchantability, fitness for a particular purpose, or noninfringement (please see the License for the specific terms and conditions governing rights and limitations under the License). PTC product warranties are provided solely by PTC. Certain Pro/TOOLMAKER functions/libraries are as follows: CSubclassWnd version 2.0 - Misc. C++ software; Copyright © 2000 NEWare Software. STLPort - C++ templates; ©1999,2000 Boris Fomitchev; Provided pursuant to: STLPort License http://stlport.sourceforge.net/License.shtml. Zip32 - Compression library; Copyright © 1990-2007. Info-ZIP; Provided pursuant to: Info-ZIP License http://www.info-zip.org/pub/infozip/license.html. Inno Setup - Installer package; Copyright 1997-2007 Jordan Russell; Provided pursuant to Inno Setup License http://www.jrsoftware.org/index.php/files/license.txt. 7-Zip - Compression package; Copyright 1999-2007 Igor Pavlov; Provided pursuant to 7-Zip License http://www.7-zip.org/license.txt. The implementation of the loop macro in CoCreate Modeling is based on code originating from MIT.